Third edition

Copyright
This document is Copyright © 2005–2007 by its contributors as listed in the section titled
Authors. You can distribute it and/or modify it under the terms of the Creative Commons
Attribution License, version 3.0 or later (http://creativecommons.org/licenses/by/2.5/).
All trademarks within this guide belong to their legitimate owners.

Authors
Magnus Adielsson
Richard Barnes
Agnes Belzunce
Chris Bonde
Daniel Carrera
Laurent Duperval
Spencer E. Harpe
Tim Kampa
Peter Kupfer
Ian Laurenson
Dan Lewis
Alan Madden

Paul Miller
Michel Pinquier
Andrew Douglas Pitonyak
Carol Roberts
Iain Roberts
Gary Schnabl
Janet M. Swisher
Jim Taylor
Alex Thurgood
Catherine Waterman
Jean Hollis Weber
Linda Worthington

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org

Acknowledgements
This book was created entirely using OpenOffice.org, including writing, page layout, and
PDF creation. Most graphics were produced using OOo Draw, some using The Gimp, an
open-source graphic program.

Publication date and software version
Third edition. Published 17 June 2007. Based on OpenOffice.org 2.2.

You can purchase a printed copy of this book from
http://www.lulu.com/opendocument
You can download an editable version of the chapters in this book
from http://oooauthors.org/en/authors/userguide2/published/

Contents

Contents
Chapter 1
What is OpenOffice.org?.........................................................................................1
What is OpenOffice.org?.............................................................................................................2
What does OpenOffice.org include?...........................................................................................2
The advantages of OpenOffice.org..............................................................................................4
How does OpenOffice.org compare?.....................................................................................5
Features...................................................................................................................................6
New features in version 2.......................................................................................................7
Minimum requirements...............................................................................................................9
Getting the software..................................................................................................................10
Installing the software...............................................................................................................10
How to get help.........................................................................................................................10
Help system..........................................................................................................................10
Free online support...............................................................................................................11
Paid support and training......................................................................................................12
Other resources and addons..................................................................................................12
A short history of OpenOffice.org.............................................................................................12
How is OpenOffice.org licensed?..............................................................................................13
What is “open source”?.............................................................................................................13
Frequently asked questions.......................................................................................................13

Chapter 2
Starting OpenOffice.org........................................................................................15
Starting OOo from the system menu.........................................................................................16
Windows...............................................................................................................................16
Linux/GNOME.....................................................................................................................17
Linux/KDE...........................................................................................................................18
Mac OS X.............................................................................................................................19
Starting from an existing document..........................................................................................20
For Windows users...............................................................................................................20
Using the Quickstarter under Windows....................................................................................20
Using the Quickstarter icon..................................................................................................20
Disabling the Quickstarter....................................................................................................20
Reactivating the Quickstarter...............................................................................................21
Using the Quickstarter under Linux..........................................................................................21
Preloading OOo under Linux/KDE...........................................................................................21
Starting from the command line................................................................................................21

Getting Started Guide

i

Contents

Chapter 3
File Management in OpenOffice.org.....................................................................23
Opening files.............................................................................................................................24
File formats...........................................................................................................................25
Default file formats...............................................................................................................25
Opening text documents.......................................................................................................26
Opening spreadsheets...........................................................................................................26
Opening gresentations..........................................................................................................27
Opening graphic files............................................................................................................27
Opening formula files...........................................................................................................27
Saving files................................................................................................................................27
Password protection..............................................................................................................27
Saving a document automatically.........................................................................................28
Writer can save to these file formats....................................................................................28
Calc can save to these file formats.......................................................................................29
Impress can save to these file formats..................................................................................29
Draw can save to these file formats......................................................................................30
Writer/Web can save in these formats..................................................................................30
Exporting files...........................................................................................................................30
Export to XHTML, BibTeX, LaTeX, and Flash...................................................................30
Export to PDF.......................................................................................................................30
PDF options..........................................................................................................................31
Deleting and renaming files......................................................................................................35
Renaming a file.....................................................................................................................35
Deleting a file.......................................................................................................................35
File associations........................................................................................................................36
Creating new files......................................................................................................................37
Using the Open and Save As dialogs.........................................................................................38
Digital signing of documents....................................................................................................40

Chapter 4
Menus and Toolbars..............................................................................................43
Menus........................................................................................................................................44
Customizing the menu font..................................................................................................44
Customizing menu content...................................................................................................45
Toolbars.....................................................................................................................................46
Floating toolbars...................................................................................................................46
Long-click buttons and tear-off toolbars..............................................................................46
Displaying or hiding toolbars...............................................................................................47
Moving toolbars....................................................................................................................47
ii

Getting Started Guide

Contents

Customizing a toolbar..........................................................................................................48
Creating a new toolbar..........................................................................................................49
Using dockable/floating windows and toolbars........................................................................49
Using the Navigator..............................................................................................................49
Arranging chapters using the Navigator...............................................................................51

Chapter 5
Setting up OpenOffice.org....................................................................................53
Choosing options that affect all of OOo....................................................................................54
User Data options.................................................................................................................54
General options.....................................................................................................................55
Memory options....................................................................................................................56
View options.........................................................................................................................57
Print options.........................................................................................................................58
Path options..........................................................................................................................59
Color options........................................................................................................................60
Font options..........................................................................................................................61
Security options....................................................................................................................62
Appearance options..............................................................................................................62
Accessibility options............................................................................................................63
Java options..........................................................................................................................64
Online Update options..........................................................................................................64
Choosing options for loading and saving documents................................................................65
General Load/Save options...................................................................................................65
VBA Properties Load/Save options......................................................................................66
Microsoft Office Load/Save options....................................................................................67
HTML compatibility Load/Save options..............................................................................67
Choosing language settings.......................................................................................................68
Install the required dictionaries............................................................................................68
Change some locale and language settings...........................................................................68
Choose spelling options........................................................................................................70
Internet options.....................................................................................................................70
Controlling OOo’s AutoCorrect functions................................................................................71

Chapter 6
Getting Started with Writer...................................................................................73
What is Writer?.........................................................................................................................74
The Writer interface..................................................................................................................74
Changing document views........................................................................................................75
Creating a new document..........................................................................................................75
Creating a document from a template...................................................................................75
Getting Started Guide

iii

Contents

Saving a document....................................................................................................................76
Saving as a Microsoft Word document.................................................................................76
Working with text......................................................................................................................77
Selecting items that are not consecutive...............................................................................77
Cutting, copying, and pasting text........................................................................................78
Moving paragraphs quickly..................................................................................................79
Finding and replacing text and formatting...........................................................................79
Inserting special characters...................................................................................................80
Setting tab stops and indents................................................................................................81
Checking spelling.................................................................................................................82
Using AutoCorrect................................................................................................................82
Using word completion........................................................................................................83
Using AutoText.....................................................................................................................83
Inserting dashes and non-breaking spaces............................................................................84
Formatting text..........................................................................................................................84
Using styles...........................................................................................................................84
Formatting paragraphs..........................................................................................................84
Formatting characters...........................................................................................................85
Autoformatting.....................................................................................................................86
Creating numbered or bulleted lists......................................................................................86
Hyphenating words...............................................................................................................87
Undoing and redoing changes...................................................................................................88
Tracking changes to a document...............................................................................................89
Recording changes................................................................................................................90
Inserting notes.......................................................................................................................90
Accepting or rejecting changes and comments....................................................................91
Formatting pages.......................................................................................................................92
Which layout method to choose?.........................................................................................93
Creating headers and footers.....................................................................................................94
Numbering pages.......................................................................................................................95
Including the total number of pages.....................................................................................95
Restarting page numbering...................................................................................................96
Changing page margins.............................................................................................................97

Chapter 7
Getting Started with Calc......................................................................................99
What is Calc?..........................................................................................................................100
Spreadsheets, sheets, and cells................................................................................................100
Parts of the main Calc window...............................................................................................100
Formula bar........................................................................................................................101
iv

Getting Started Guide

Contents

Individual cells...................................................................................................................101
Sheet tabs............................................................................................................................102
File management.....................................................................................................................102
Starting new spreadsheets...................................................................................................102
Opening existing spreadsheets...........................................................................................102
Saving spreadsheets............................................................................................................102
Navigating within spreadsheets...............................................................................................103
Going to a particular cell....................................................................................................103
Moving from cell to cell.....................................................................................................104
Moving from sheet to sheet................................................................................................105
Selecting items in a sheet or spreadsheet................................................................................105
Selecting cells.....................................................................................................................105
Selecting columns and rows...............................................................................................106
Working with columns and rows.............................................................................................107
Inserting columns and rows................................................................................................107
Deleting columns and rows................................................................................................108
Working with sheets................................................................................................................108
Inserting new sheets............................................................................................................108
Deleting sheets....................................................................................................................109
Renaming sheets.................................................................................................................110
Viewing Calc...........................................................................................................................110
Freezing rows and columns................................................................................................110
Splitting the window...........................................................................................................112
Entering data into a sheet........................................................................................................114
Entering numbers................................................................................................................114
Entering text.......................................................................................................................114
Entering numbers as text....................................................................................................114
Entering dates and times.....................................................................................................114
Printing....................................................................................................................................115
Printing a spreadsheet.........................................................................................................115
Print options........................................................................................................................115
Selecting sheets to print......................................................................................................116
Adjusting the print range.........................................................................................................116
Printing rows or columns on every page.............................................................................116
Defining a print range.........................................................................................................117
Adding to the print range....................................................................................................118
Removing a print range......................................................................................................118

Getting Started Guide

v

Contents

Chapter 8
Getting Started with Draw...................................................................................119
What is Draw?.........................................................................................................................120
The Workplace........................................................................................................................120
Toolbars..............................................................................................................................120
Standard toolbar..................................................................................................................122
Line and Filling toolbar......................................................................................................122
Drawing toolbar..................................................................................................................123
Color Bar............................................................................................................................123
Options toolbar...................................................................................................................124
Using the grid.....................................................................................................................125
Rulers..................................................................................................................................126
Status Bar............................................................................................................................127
The basic drawing shapes........................................................................................................127
Drawing a straight line.......................................................................................................127
Drawing a rectangle............................................................................................................128
Drawing a circle or ellipse..................................................................................................129
Writing text.........................................................................................................................129
Using connectors................................................................................................................130
Selection modes......................................................................................................................130
Changing the selection mode..............................................................................................131
Selecting objects......................................................................................................................131
Direct selection...................................................................................................................131
Selection by framing...........................................................................................................131
Selecting hidden objects.....................................................................................................132
Arranging objects...............................................................................................................132
Selecting several objects.....................................................................................................132
Moving and dynamically adjusting an object’s size................................................................133
Dynamic movement of objects...........................................................................................133
Dynamic size modification of objects................................................................................133
Special effects..........................................................................................................................134
Rotation..............................................................................................................................134
Inclination...........................................................................................................................134
Duplication.........................................................................................................................135
Cross-fading.......................................................................................................................136
Editing objects.........................................................................................................................137
Inserting pictures from other sources......................................................................................138
Exporting objects and files......................................................................................................138

vi

Getting Started Guide

Contents

Chapter 9
Getting Started with Impress...............................................................................139
What is Impress?.....................................................................................................................140
Creating a new presentation....................................................................................................140
Planning a presentation.......................................................................................................140
Starting the Presentation Wizard........................................................................................141
Formatting a presentation........................................................................................................144
Main window of Impress....................................................................................................144
Building a presentation.......................................................................................................146
Inserting additional slides...................................................................................................151
Working with slides............................................................................................................153
Workspace..........................................................................................................................155
Running the presentation.........................................................................................................159

Chapter 10
Getting Started with Base....................................................................................161
Introduction.............................................................................................................................162
Creating a database..................................................................................................................163
Creating a new database.....................................................................................................164
Creating database tables.....................................................................................................165
Defining relationships........................................................................................................174
Creating a database form.........................................................................................................176
Using the Wizard to create a form......................................................................................177
Modifying a form................................................................................................................180
Creating forms in Design View..........................................................................................195
Creating subforms in Design View.....................................................................................195
Accessing other data sources...................................................................................................196
Accessing a dBase database...............................................................................................196
Accessing a Mozilla address book.....................................................................................197
Accessing spreadsheets.......................................................................................................197
Registering databases created by OOo2.x..........................................................................197
Using data sources in OpenOffice.org.....................................................................................198
Viewing data sources..........................................................................................................198
Editing data sources............................................................................................................198
Launching Base to work on data sources...........................................................................199
Using data sources in OOo documents...............................................................................199
Entering data in a form............................................................................................................199
Creating queries.......................................................................................................................202
Using the Wizard to create a query.....................................................................................202
Using the Design View to create a query............................................................................206
Getting Started Guide

vii

Contents

Creating reports.......................................................................................................................211
Creating a static report........................................................................................................212
Creating a dynamic report..................................................................................................215
Modifying a report..............................................................................................................217

Chapter 11
Getting Started with Math...................................................................................221
What is Math?.........................................................................................................................222
Getting started....................................................................................................................222
Entering a formula...................................................................................................................223
The Selection window........................................................................................................223
Example 1:..........................................................................................................................224
Right-click menu................................................................................................................225
Markup...............................................................................................................................225
Greek characters.................................................................................................................226
Example 2:..........................................................................................................................227
Customizations........................................................................................................................228
Formula editor as a floating window..................................................................................228
How can I make a formula bigger?.....................................................................................229
Formula layout........................................................................................................................230
Brackets are your friends....................................................................................................230
Equations over more than one line.....................................................................................230
Common problem areas..........................................................................................................231
How do I add limits to my sum/integral?...........................................................................231
Brackets with matrices look ugly!......................................................................................231
How do I make a derivative?..............................................................................................232
Numbering equations..........................................................................................................232

Chapter 12
Working with Templates......................................................................................235
What is a template?.................................................................................................................236
Using a template to create a document....................................................................................236
Creating a template..................................................................................................................237
Creating a template from a document.................................................................................237
Creating a template using a wizard.....................................................................................238
Editing a template....................................................................................................................239
Adding templates with Extension Manager............................................................................241
Setting a default template........................................................................................................243
Setting a custom template as the default............................................................................243
Resetting the default to OOo’s in-built Default template...................................................243
Organizing templates...............................................................................................................243
viii

Getting Started Guide

Contents

Creating a template folder..................................................................................................244
Deleting a template folder..................................................................................................244
Moving a template..............................................................................................................244
Deleting a template.............................................................................................................244
Importing a template...........................................................................................................245
Exporting a template...........................................................................................................245

Chapter 13
Working with Styles:...........................................................................................247
What are styles?......................................................................................................................248
Why use styles?.......................................................................................................................249
Applying styles........................................................................................................................249
Using the Styles and Formatting window...........................................................................249
Using Fill Format mode......................................................................................................250
Using the Apply Style list...................................................................................................250
Assigning styles to shortcut keys........................................................................................251
Modifying styles......................................................................................................................252
Changing a style using the Style dialog..............................................................................253
Updating a style from a selection.......................................................................................253
Using AutoUpdate (paragraph and frame styles only)........................................................253
Updating styles from another document or template..........................................................253
Creating new (custom) styles..................................................................................................254
Creating a new style using the Style dialog........................................................................254
Creating a new style from a selection.................................................................................254
Dragging and dropping a selection to create a style...........................................................255
Copying and moving styles.....................................................................................................255
Using the Template Management dialog............................................................................255
Loading styles from a template or document.....................................................................257
Deleting styles.........................................................................................................................258

Chapter 14
Working with the Gallery....................................................................................259
What is the Gallery?................................................................................................................260
Inserting objects into a document............................................................................................261
Inserting objects as links.....................................................................................................261
Inserting an object as a background ...................................................................................262
Managing the Gallery..............................................................................................................262
Adding objects to the Gallery.............................................................................................262
Deleting objects from the Gallery.......................................................................................263
Adding a new theme to the Gallery....................................................................................263
Deleting a theme from the Gallery.....................................................................................264
Getting Started Guide

ix

Contents

Location of the Gallery and the objects in it...........................................................................264

Chapter 15
Using Fontwork...................................................................................................265
What is Fontwork?..................................................................................................................266
The Fontwork toolbars............................................................................................................266
Creating a Fontwork object.....................................................................................................266
Editing a Fontwork object.......................................................................................................267
Using the Fontwork toolbar................................................................................................268
Using the Formatting toolbar..............................................................................................269
Using menu options............................................................................................................272
Moving and resizing Fontwork objects...................................................................................273

Chapter 16
Creating Web Pages.............................................................................................275
Introduction.............................................................................................................................276
Inserting hyperlinks.................................................................................................................276
Editing hyperlinks...............................................................................................................278
Saving Writer documents as web pages..................................................................................278
Saving a document as a single web page............................................................................278
Saving a document as a series of web pages......................................................................278
Creating web pages using a Wizard....................................................................................279
Saving Calc spreadsheets as web pages..................................................................................283
Saving Impress presentations as web pages............................................................................283
Saving Draw documents as web pages....................................................................................287

Chapter 17
Getting Started with Macros...............................................................................289
Your first macro.......................................................................................................................290
Creating a simple macro.....................................................................................................290
Running the macro.............................................................................................................291
Viewing and editing the macro...........................................................................................292
Creating a macro.....................................................................................................................295
A complicated example......................................................................................................295
Running the macro quickly.................................................................................................298
Sometimes the macro recorder fails........................................................................................299
The dispatch framework.....................................................................................................299
How the macro recorder uses the dispatch framework.......................................................299
Other options......................................................................................................................300
Macro organization..................................................................................................................300
Where are macros stored?..................................................................................................302
x

Getting Started Guide

Contents

Downloading macros to import..........................................................................................303
How to run a macro.................................................................................................................304
Toolbar................................................................................................................................306
Menu item...........................................................................................................................306
Keyboard shortcuts.............................................................................................................306
Event...................................................................................................................................306
Extensions...............................................................................................................................308
Writing macros without the recorder.......................................................................................308
Finding more information.......................................................................................................309
Included material................................................................................................................309
Online resources.................................................................................................................309
Published material..............................................................................................................310

Appendix A
Keyboard Shortcuts.............................................................................................311
Introduction.............................................................................................................................312
Assigning shortcut keys...........................................................................................................312
Saving changes to a file......................................................................................................313
Loading a saved keyboard configuration............................................................................314
Resetting the shortcut keys.................................................................................................314
Running macros..................................................................................................................314
General shortcut keys for OpenOffice.org...............................................................................315
Keyboard shortcuts using the function keys............................................................................316
Shortcut keys in the Gallery....................................................................................................316
Shortcut keys in the New Theme area of the Gallery.........................................................317
Shortcut keys in the Gallery preview area..........................................................................317
Selecting rows and columns in a table....................................................................................317
Shortcut keys for drawing objects...........................................................................................318

Index......................................................................................................................319

Getting Started Guide

xi

Getting Started Guide

Chapter 1
What is OpenOffice.org?

What is OpenOffice.org?

What is OpenOffice.org?
OpenOffice.org is a freely available, full-featured office suite. This chapter describes:
•
•
•
•
•
•

Note

The components of OpenOffice.org
Some of the enhancements and new features in version 2
How OpenOffice.org compares with other office suites
How to get help
How OpenOffice.org is licensed
Answers to some common questions
Because someone else owns the trademark OpenOffice, the correct name for both
the open-source project and its software is OpenOffice.org.

OpenOffice.org (OOo) is both a software product and a community of volunteers that
produces and supports the software.
Everyone is free to redistribute OOo, thanks to its open source license (see “How is
OpenOffice.org licensed?” on page 13).
If you are new to OOo, its open source development, and the community that produces and
supports it, you should read this chapter.
OOo 2.0 was a major upgrade of an already feature-rich office suite. If you have used
previous versions of OOo, please look over the section “New features in version 2” on
page 7.

What does OpenOffice.org include?
The OpenOffice.org 2.x office suite includes the following components.
Writer (word processor)

Writer is a feature-rich tool for creating letters,
books, reports, newsletters, brochures, and other
documents. You can insert graphics and objects from
other components into Writer documents. Writer can
export files to HTML, XHTML, XML, Adobe’s
Portable Document Format (PDF), and several
versions of Microsoft Word files. It also connects to
your email client.
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Calc (spreadsheet)

Calc has all of the advanced analysis, charting and
decision-making features expected from a high-end
spreadsheet. It includes over 300 functions for
financial, statistical, and mathematical operations,
among others. The Scenario Manager provides “what
if” analyses. Calc generates 2-D and 3-D charts, which
can be integrated into other OOo documents. You can
also open and work with Microsoft Excel workbooks
and save them in Excel format. Calc can export
spreadsheets to Adobe’s PDF and to HTML.
Impress (presentations)

Impress provides all the common multimedia
presentation tools, such as special effects, animation,
and drawing tools. It is integrated with the advanced
graphics capabilities of OOo’s Draw and Math
components. Slideshows can be further enhanced with
Fontwork’s special effects text, as well as sound and
video clips. Impress is compatible with Microsoft’s
PowerPoint file format and can also save your work in
numerous graphics formats, including Macromedia
Flash (SWF).

Draw (vector graphics)

Draw is a vector drawing tool that can produce
everything from simple diagrams or flowcharts to 3-D
artwork. Its Smart Connectors feature allows you to
define your own connection points. You can use Draw
to create drawings for use in any of OOo’s other
components, and you can create your own clipart and
add it to the Gallery. Draw can import graphics from
many common formats and save them in over 20
formats including PNG, HTML, PDF, and Flash.
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Base (database)

Base provides tools for day-to-day database work
within a simple interface. It can create and edit forms,
reports, queries, tables, views, and relations, so that
managing a connected database is much the same as in
other popular database applications. Base provides
many new features, such as the ability to analyze and
edit relationships from a diagram view. Base
incorporates HSQLDB as its default relational database
engine. It can also use dBASE, Microsoft Access,
MySQL, or Oracle, or any ODBC- or JDBC-compliant
database. Base also provides support for a subset of
ANSI-92 SQL.
Math (formula editor)
2
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Math is OOo’s formula or equation editor. You can use
it to create complex equations that include symbols or
characters not available in standard font sets. While it
is most commonly used to create formulas in other
documents, such as Writer and Impress files, Math can
also work as a stand-alone tool. You can save formulas
in the standard Mathematical Markup Language
(MathML) format for inclusion in webpages and other
documents not created by OOo.

The advantages of OpenOffice.org
Here are some of the advantages of OpenOffice.org over other office suites:
•

•

Open source. You can distribute, copy, and modify the software as much as you wish,
in accordance with either of OOo’s Open Source licenses.

•

Cross-platform. OOo 2.x runs on several hardware architectures and under multiple
operating systems, such as Microsoft Windows, Mac OS X, Linux, and Sun Solaris.

•

•

4

No licensing fees. OOo is free for anyone to use and distribute at no cost. Many
features that are available as extra cost add-ins in other office suites (like PDF export)
are free with OOo. There are no hidden charges now or in the future.

Extensive language support. OOo’s user interface is available in over 40 languages,
and the OOo project provides spelling, hyphenation, and thesaurus dictionaries in over
70 languages and dialects. OOo also provides support for both Complex Text Layout
(CTL) and Right to Left (RTL) layout languages (such as Hindi, Hebrew, and Arabic).
Consistent user interface. All the components have a similar “look and feel,” making
them easy to use and master.
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•

Integration. The components of OpenOffice.org are well integrated with one another.
•

•

•

•

•

•

All the components share a common spelling checker and other tools, which are
used consistently across the suite. For example, the drawing tools available in
Writer are also found in Calc, with similar but enhanced versions in Impress and
Draw.
You do not need to know which application was used to create a particular file (for
example, you can open a Draw file from Writer).

Granularity. Usually, if you change an option, it affects all components. However,
OOo options can be set at a component level or even document level.
File compatibility. OOo includes PDF and Flash export capabilities, as well as
support for opening and saving files in many common formats including Microsoft
Office, HTML, XML, WordPerfect, and Lotus 123 formats.
No vendor lock-in. OOo 2.x uses OpenDocument, an XML (eXtensible Markup
Language) file format developed as an industry standard by OASIS (Organization for
the Advancement of Structured Information Standards). These files can easily be
unzipped and read by any text editor, and their framework is open and published.
You have a voice. Enhancements, software fixes, and release dates are communitydriven. You can join the community and affect the course of the product you use.

You can read more about OpenOffice.org, its mission, history, licensing, and other
organizational information here: http://www.openoffice.org/about.html

How does OpenOffice.org compare?
OpenOffice.org can match and exceed the feature set of competing office suites. The
following table lists the main components of OOo and compares them with their equivalents
in two leading office suites, Microsoft Office 2003 (MSO) and WordPerfect Office X3 (WP).
Function

1
2

OOo

MSO

WP

Word processor

Writer

Word®

WordPerfect® X3

Spreadsheet

Calc

Excel®

Quattro Pro® X3

Vector graphics

Draw

no

no

Presentation graphics

Impress

PowerPoint®

Presentations™ X3

Database

Base

Access® 1

Paradox® 2

Math or formula editor

Math

yes

no

Professional version only.
Professional and Student and Teacher editions only.
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Features
The following tables list some important features of OpenOffice.org and compare them with
two leading office suites, Microsoft Office 2003 (MSO) and WordPerfect X3 (WP).
Styles and formatting

1
2

Feature

OOo

MSO

WP

Navigator

yes

limited1

no

Styles and Formatting window

yes

yes

no

Keyboard support for paragraph styles

yes

yes

no

Support for page, frame, and list styles

yes

no

no

Word completion

yes

Excel only

no

2

Spelling and language proofing modules

70+

50+

Formula or equation tools

yes

yes

25
no

“Outline View” in Word offers a subset of the features of OOo's Navigator.
Requires an additional license for the the Multilingual User Interface Pack.

Interoperability
Feature

OOo

MSO

WP

PDF export capability

yes

yes1

yes

Flash export capability

yes

no

yes

XML export capability

yes

yes

yes

OpenDocument XML format

yes

no

no

Import/Export Microsoft Office files

yes

yes

yes

Import WordPerfect files

yes

yes

yes

Import Lotus 123 files

yes

yes

yes

Connect to external databases
(MySQL, Oracle, Access, etc.)

yes

yes

yes

Languages available (localizations)

40+

35+

30

Windows, Mac OS X,
Linux, Solaris

Windows
only2

Windows
only

yes

yes

no

Supported operating systems
Unicode language support
1
2

6

Requires additional third-party software, such as PDF Writer or PDF Converter.
Microsoft Office: Mac is not feature compatible with Microsoft Office 2003.
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3Programmability

Macros are programs that automate tasks and can be embedded in a document. The following
table lists the languages available for macro development in each office suite.
Language

OOo

MSO

WP

OpenBasic

VBA

VBA

Beanshell

yes

no

no

Java

yes

no

no

JavaScript

yes

no

no

Python

yes

no

no

Basic-derived language

Beyond simple macros, some office suites can be extended to include new features. This
capability usually takes the form of plug-ins. In the case of OpenOffice.org, it can also be
done through changes to the source code.
Feature

OOo

MSO

WP

C and C++

yes

yes

yes

Java

yes

no

no

Python

yes

no

no

Source code available!

yes

no

no

OOo

MSO

WP

Digital signatures

yes

yes

yes

Strong encryption

yes

yes

yes

Secure paths for macro execution

yes

yes

no

Security
Feature

New features in version 2
OpenOffice.org 2.x delivers hundreds of improvements and new features. Here are some of
the major enhancements.
•

•

Simplified installation. Installations are now performed by platform-native installers
with no need to use command-line switches (or flags) for multi-user installations. You
can also specify which version of Java (if any) is to be used by OOo from the
installation interface.
New database component. In the new stand-alone database component, you can
create forms, reports, queries, tables, views, and relations. OOo now includes
HSQLDB, a small, fast, relational database engine that supports a subset of ANSI-92
SQL, along with an easy-to-use interface. Additionally, it is now easier than ever to use
other databases (dBASE, MySQL, Oracle, among others).
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•

•

Native system theme integration. To further integrate OpenOffice.org with the
underlying operating system, all user interface elements (such as buttons and
scrollbars) have the same look as those used in other native applications for each
platform.

•

Digital signatures. Digital signatures provide authentication of the true author or
editor of a document. This feature also provides security with running macros.

•

Enhanced encryption. Implementation of the new XML (eXtensible Markup
Language) encryption algorithm offers additional document security.

•

•

•
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New file format. OOo 2.x uses the new OpenDocument XML file format
(standardized by OASIS, http://www.oasis-open.org/home/index.php) as its default file
format. This new file format is also used in StarOffice, IBM Workspace, and KOffice,
and will be used by other products in the future. OOo 2.x can still read and save files
in formats previously supported by OOo 1.x, including Microsoft Office formats.

Usability improvements. Redesigned toolbars are more usable and display only
selected default tools and related options. The usability of the Menus tab of the Tools
> Customize dialog has been improved. Several features have been renamed to
conform with common office suite terminology (for example, the “AutoPilot” is now a
“Wizard”).
Thumbnails. The new plug-in for the the native file explorer provides a thumbnail
preview of an OOo file. Some of the more common file system explorers that can use
this new feature are Nautilus (Gnome), Konqueror (KDE), and Microsoft Windows
Explorer.
Import and export filters
• Improved PDF export filter now includes PDF bookmarks, PDF notes, security,
and more.
•

Import and export of Microsoft Office 95 and Office 97 spin buttons and scrollbars
have been added to the Word filters.

•

The import filter for Microsoft PowerPoint documents now creates text objects
having font-independent line spacing enabled.

•

Enhanced export to HTML produces valid XHTML 1.0 Strict documents.
XHTML export has been enabled for Calc, Draw, and Impress.

•

You can now open Microsoft Office password-protected documents.

•

New import filters for WordPerfect and Lotus 123.

•

Send document as e-mail. OOo 2.x makes it easier to use your email client to send
the active document as an attachment.

•

Enhanced mail merge feature. Enhancements include better management of
databases and saving into one single file.

•

Drag and drop selections to create styles. Drag and drop a text selection into the
Styles and Formatting window to create a new paragraph style or character style.
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•

•

•

•

•

•

•

•

Form controls. Form controls can be embedded in all OOo documents that support a
form layer.
New keyboard shortcuts. You can now use the keyboard to perform the actions found
under Edit > Paste Special. Multiple selected sheets in a spreadsheet can be
deselected using the keyboard. Paragraph and other styles can be assigned to key
combinations.
Auto recovery of files and the workspace environment. The OOo Error Reporting
tool and the document recovery features have been combined. Now if OOo crashes, the
active documents are saved. You can recover the documents and send an error report.
Enhanced features in Calc. These enhancements include improved number
recognition, an improved Hyperlink function, conditional arrays, a greater selection of
predefined headers and footers, more options for defining how to print sheets, new
options for the DataPilot feature, and support for right-to-left languages.
Calc row limit increased. The number of spreadsheet rows has been increased to
65536, the same number of rows as Microsoft Excel.
Enhanced multimedia. The multimedia presentation model uses the W3C’s
Synchronized Multimedia Integration Language (SMIL) standard. Now Impress can
render nearly all of the Microsoft PowerPoint animation effects. Two new task panels
provide access to shape and slide transition effects.
Programmatic control of menu and toolbar items. Third-party developers can write
plug-ins to manipulate menu bar and toolbar layouts to their needs. Developers can
now insert, remove, and modify menu items, context menus, and toolbar items at
runtime.
Scripting framework. The scripting framework allows you to write macros in a
number of languages other than OOo Basic. You can assign these macros to menu
items, keyboard combinations, application and document events, form controls within
documents, and various objects within documents.

For a complete, detailed listing, go to the OpenOffice.org 2.0 Office Suite Guide to New
Features located at http://marketing.openoffice.org/2.0/featureguide.html#enduser

Minimum requirements
OpenOffice.org 2.x requires one of the following operating systems:
• Microsoft Windows 98, Windows ME, Windows 2000 (Service Pack 2 or higher),
Windows XP, Windows 2003, or Windows Vista
• GNU/Linux Kernel version 2.2.13 and glibc 2.2.0 or newer
• Mac OS X 10.3.x (10.3.5 recommended), Mac OS X 10.4.x, X11 required
• Solaris version 8 or higher
More operating systems will be supported in the future.
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Some OpenOffice.org features (wizards and the HSQLDB database engine) require that the
Java Runtime Environment (JRE) be installed on your computer. Although OOo will work
fine without Java support, some features will not be available. You can download the latest
version from http://www.java.com.
For a more detailed (and up-to-date) listing of requirements, see:
http://www.openoffice.org/dev_docs/source/sys_reqs_20.html.

Getting the software
You can get the OpenOffice.org installation package in any of these ways:
•

Download a copy from the project’s home page: http://www.openoffice.org.

•

Download a copy using the Peer to Peer client, BitTorrent. The instructions are here:
http://distribution.openoffice.org/p2p/.

•

•

Purchase a copy on a CD-ROM or other digital form from a third-party distributor. The
project maintains a listing of distributors; however, these distributors are not
connected with, nor endorsed by OpenOffice.org:
http://distribution.openoffice.org/cdrom/sellers.html.
The OpenOffice.org Porting Project has links to versions of the software that have
been, or are currently being, “ported” to run under various operating systems,
including natively under Mac OS X. http://porting.openoffice.org/index.html.

Installing the software
Information on installing and setting up OpenOffice.org on the various supported operating
systems is given here: http://download.openoffice.org/2.1.0/instructions.html
You can also download the more detailed Setup Guide (in several languages) from
http://documentation.openoffice.org/setup_guide2/index.html

How to get help
Help system
OOo comes with an extensive Help system. This is your first line of support for using OOo.
To display the full Help system, press F1 or select OpenOffice.org Help from the Help
menu. In addition, you can choose whether to activate tooltips, extended tips, and the Help
Agent (using Tools > Options > General).
If tooltips are enabled, place the mouse pointer over any of the icons to see a small box
(“tooltip”) with a brief explanation of the icon’s function. For a more detailed explanation,
select Help > What's This? and hold the pointer over the icon.
10
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The Help menu

Free online support
The OpenOffice.org community not only develops software, but provides free, volunteerbased support. Users of OOo can get comprehensive online support from community venues
such as newsgroups, forums, or mailing lists. There are also numerous websites run by users
that offer free tips and tutorials.
Free OpenOffice.org support
User Help – FAQ Project

FAQs, information, knowledge base.
http://user-faq.openoffice.org/new-faq/index.html

Users Mailing List

Free community support provided by a network of
hundreds of experienced users. You must be
subscribed to post messages.
To subscribe, send a blank email to
users-subscribe@openoffice.org
List archives are here:
http://www.openoffice.org/servlets/SummarizeList?
listName=users

Documentation Project

Templates, user guides, how-tos, and other
documentation. http://documentation.openoffice.org/

Native Language Project

Information, resources, and mail lists in your
language.
http://projects.openoffice.org/native-lang.html

Mac Support

Support for installing and using the Mac OS X (X11
based) port.
http://porting.openoffice.org/mac/support.html

The OpenOffice.org Forum

Extensive discussion forum for OpenOffice.org
issues from setup to advanced programming features.
http://www.oooforum.org/

OOo KnowledgeBase

A collection of questions and answers that users can
query. http://mindmeld.cybersite.com.au/

Read more about the support options for OpenOffice.org at:
http://support.openoffice.org/index.html
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Paid support and training
Alternatively, you can pay for support services. Service contracts can be purchased from a
vendor or consulting firm specializing in OpenOffice.org.
OOo is supported by Sun Microsystems, Inc. under the Sun Software Support program,
which includes two levels of support that cover extended business hours or around-the-clock
service for mission-critical deployments.
http://www.sun.com/service/support/software/openoffice/index.html
A list of independent consultants and the services they offer, listed alphabetically by region
and then by country, is provided on the OpenOffice.org website.
http://bizdev.openoffice.org/consultants.html

Other resources and addons
Several websites provide additional free resources and addons to enhance OpenOffice.org.
The following table lists a few of these websites.
Free OOo templates, artwork, addons, and other resources
OOExtras

Provides templates, samples, and macros in several
languages. http://ooextras.sourceforge.net/

OOoMacros

A repository for OOo macros and addons and
documentation about writing macros or extending
OOo. http://www.ooomacros.org/

Open Clip Art Library

An archive of clip art that can be used for free for
any use. http://www.openclipart.org/

OpenOffice.org Macro
Information

Andrew Pitonyak, the author of OpenOffice.org
Macros Explained, maintains this site which
provides extensive documentation on OOo's macro
capability. Many good referral links are also
provided: http://www.pitonyak.org/oo.php

A short history of OpenOffice.org
The OpenOffice.org project began when Sun Microsystems released the source code
(“blueprints”) for its StarOffice® software to the open source community in 2000. This
allowed Sun to use the technical expertise and rapid development times of an open-source
project in the development of its own software products. All recent versions of Sun’s
StarOffice use source code developed by the OpenOffice.org community. However, the
products do not provide exactly the same features due to the copyrights of third parties that
are not compatible with open-source licensing.
Read more about OpenOffice.org’s history and organization at: http://about.openoffice.org/
Information about StarOffice can be found at: http://www.sun.com/software/star/staroffice/
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How is OpenOffice.org licensed?
OpenOffice.org is distributed under the Open Source Initiative (OSI) approved Lesser
General Public License (LGPL).
The LGPL can be viewed on the OOo website at:
http://www.openoffice.org/licenses/lgpl_license.html
For more general information on OOo’s licensing, please refer to:
http://www.openoffice.org/license.html

What is “open source”?
The ideals of open-source software can be explained by the four essential rights, which are
embodied within the Free Software Foundation’s General Public License (GPL):
•

The right to use the software for any purpose.

•

Freedom to redistribute the software for free or for a fee.

•

Access to the complete source code of the program (that is, the “blueprints”).

•

The right to modify any part of the source, or use portions of it in other programs.

Another view of this philosophy comes from the Open Source Definiton:
“The basic idea behind open source is very simple: When programmers can read,
redistribute, and modify the source code for a piece of software, the software evolves.
People improve it, people adapt it, people fix bugs. And this can happen at a speed that, if
one is used to the slow pace of conventional software development, seems astonishing.”
For more information on Free and Open Source software, visit these websites:
Open Source Initiative (OSI): http://www.opensource.org
Free Software Foundation (FSF): http://www.gnu.org

Frequently asked questions
Is this software a “demo” version?

No, this is a fully functioning software suite.

May I distribute OOo to anyone?

Yes.

How many computers may I install it on?

As many as you like.

May I sell it?

Yes.

May I use OpenOffice.org in a business?

Yes.

Is OpenOffice available in my language?

OpenOffice.org has been translated (localized) into
over 40 languages, so your language probably is
supported. Additionally, there are over 70 spelling,
hyphenation, and thesaurus dictionaries available for
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languages, and dialects that do not have a localized
program interface. The dictionaries are available
from the OpenOffice.org website at:
http://lingucomponent.openoffice.org/download
_dictionary.html
How can you make it for free?

A large share of the development, and much of the
support for the project, is currently supplied or
sponsored by Sun Microsystems. There are also
many other people who work on OOo as volunteers.

What if I need technical support?

Read the section titled “How to get help”.

Who owns the software?

The copyright is shared by Sun Microsystems and all
the volunteers who have contributed.

Does that mean that they can take away
the software?

No. The licenses under which OOo is developed and
distributed can never be revoked, so it cannot be
taken away.

I am writing a software application. May I
use programming code from
OpenOffice.org in my program?

You may, within the parameters set in the LGPL.
Read the license:
http://www.openoffice.org/license.html

Why is my favorite feature from
StarOffice not available in
OpenOffice.org?

That feature is probably a third-party add-on that
Sun cannot distribute with OpenOffice.org.

Why do I need Java to run
OpenOffice.org? Is it written in Java?

OpenOffice.org is not written in Java; it is written in
the C++ language. Java is one of several languages
that can be used to extend OOo. The Java JDK/JRE
is only required for some features. The most notable
one is the HSQLDB relational database engine.
Note: Java is available at no cost. If you don't want
to use Java, you can still use nearly all of the
features of OOo.

How can I contribute to OpenOffice.org?

You can help with the development of OOo in many
ways, and you do not need to be a programmer. To
start, check out this webpage:
http://www.openoffice.org/contributing.html

What’s the catch?

There really is none; read the licenses:
http://www.openoffice.org/license.html
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Starting OOo from the system menu
Using the system menu is the most common way to launch OpenOffice.org. The system menu
is the standard menu from which most applications are started. On Windows, it is called the
Start menu. On GNOME, it is called the Applications menu. On KDE it is identified by the
KDE logo. On Mac OS X, it is the Applications menu.
When OpenOffice.org was installed, a menu entry was added to your system menu. The exact
name and location of this menu entry depends on the graphical user interface. This chapter
looks at Windows, GNOME and KDE on Linux, and Mac OS X. The concepts should easily
be applicable to another operating system.

Windows
On Windows, the OpenOffice.org menu is located in Programs > OpenOffice.org 2.x,
where “2.x” corresponds to the version number of OpenOffice.org. Figure 1 shows a typical
setup on Windows XP. Select OpenOffice.org Writer to start Writer with a blank document.

Figure 1: Starting OOo from the Windows XP Start menu
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Linux/GNOME
GNOME installations differ from one distribution to the next. Most modern distributions
come with OpenOffice.org already installed. You will find OpenOffice.org under
Applications > Office. See Figure 2.

Figure 2: Starting OOo from the GNOME Applications menu
Fedora/Red Hat Enterprise Linux comes with OpenOffice.org installed. On the GNOME
desktop, OOo can be found under Main Menu > Office. If you have installed a newer
version of OOo, you will find it under Main Menu > Office > More Office Applications.
If OOo was downloaded from the http://www.openoffice.org website, OOo is under
Applications > Other.
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Linux/KDE
On KDE, OpenOffice.org is installed in its own menu, called “Office” (see Figure 3).

Figure 3: Starting OOo from the KDE start menu
Some Linux distributions install OpenOffice.org in the Office submenu. Mandrake is such a
distribution. In this case, to launch Math (for example), choose Office > Word processors >
OpenOffice.org Math. Figure 4 illustrates this.
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Figure 4: Starting OOo Writer from Mandrake's KDE menu

Mac OS X
Go to the folder where you installed OpenOffice.org. You should see its icon in the
Applications folder (Figure 5). To start OpenOffice.org, double-click its icon.

Figure 5: Starting OpenOffice.org from the Mac Applications folder
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Starting from an existing document
You can start OOo automatically by double-clicking the filename of an OOo document in a
file manager such as Windows Explorer. The appropriate component of OOo will start and
the document will be loaded.

For Windows users
File associations are used to open certain types of files automatically with OpenOffice.org.
When installing OOo, you could choose to associate Microsoft Office file types with OOo. If
you chose to do this, then when you double-click on a .doc (Word) file, it opens in Writer; a
.xls (Excel) file opens in Calc, and a .ppt (Powerpoint) file opens in Impress.
If you did not associate the file types, then when you double-click on a Microsoft Word
document, it opens in Microsoft Word (if Word is installed on your computer), Excel files
open in Excel, and Powerpoint files open in Powerpoint.
You can use another method to open .doc files in OOo and save in the .doc format from OOo.
See Chapter 3 (File Management in OpenOffice.org) for more information.

Using the Quickstarter under Windows
The Quickstarter is an icon that is placed in the Windows system tray during system startup.
It indicates that OpenOffice.org has been loaded and is ready to use. (The Quickstarter loads
library .DLL files required by OOo, thus shortening the startup time for OOo components by
about half.) If the Quickstarter is disabled, see “Reactivating the Quickstarter” if you want to
enable it.

Using the Quickstarter icon
Right-click the Quickstarter icon in the system tray to open a pop-up menu from which you
can open a new document, open the Templates and Documents dialog, or choose an existing
document to open. (See Figure 6.) You can also double-click the Quickstarter icon to display
the Templates and Documents dialog.

Disabling the Quickstarter
To close the Quickstarter, right-click on the icon in the system tray, and then click Exit
Quickstarter on the pop-up menu. The next time the computer is restarted, the Quickstarter
will be loaded again.
To prevent OpenOffice.org from loading during system startup, deselect the Load
OpenOffice.org during system start-up item on the pop-up menu. You might want to do
this if your computer has insufficient memory, for example.
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Figure 6: Quickstarter popup menu

Reactivating the Quickstarter
If the Quickstarter has been disabled, you can reactivate it by selecting the Load
OpenOffice.org during system start-up checkbox in Tools > Options > OpenOffice.org >
Memory.

Using the Quickstarter under Linux
Some installations of OpenOffice.org under Linux have a Quickstarter that looks and acts
like the one described above for Windows (the checkbox on the Memory page is labeled
Enable systray quickstarter). The Linux Quickstarter is disabled in other installations, but
it will be operational in future releases.

Preloading OOo under Linux/KDE
In Linux/KDE, you can use KDocker to have OOo loaded and ready for use at startup.
KDocker is not part of OOo; it is a generic “systray app docker” that is helpful if you open
OOo often.

Starting from the command line
You may want to start OOo from the command line (using the keyboard instead of the
mouse). Why? Well, by using the command line, you have more control over what happens
when OOo is started. For example, using the command line, you can tell Writer to load a
document and print it immediately, or to start without showing the splash screen.
Note

Most users will never need to do this.
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There is more than one way to start OOo from the command line, depending on whether a
customized version or the standard download from the OpenOffice.org website has been
installed.
If you installed using the download on the OpenOffice.org website, you can start Writer by
typing at the command line:
soffice -writer
swriter

or

Writer will start and create a new document. Likewise, you can start other OOo components
from the command line:
Type of document

Component

Command-line option

Text

Writer

-writer

Spreadsheet

Calc

-calc

Drawing

Draw

-draw

Presentation

Impress

-impress

Formula

Math

-math

Web page

Writer

-web

To see a list of options you can use when starting Writer at the command line, type:
soffice -?
Below is a list of some of the more popular options.
Option

Description

-help

Get a complete list of options.

-nologo

Do not show the startup screen.

-show <odp-file>

Start presentation immediately.

-view <documents
...>

Open documents in viewer (read-only) mode.

-minimized

Start OOo minimized.

-norestore

Suppress restart/restore after fatal errors.

-invisible

No startup screen, no default document and no UI. This is
useful for third-party applications that use functionality
provided by OOo.

If you have a customized version of OOo (such as the one provided by Linux Mandrake or
Gentoo), you can start Writer by typing at the command line:
oowriter
Note
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Although the command syntax differs, the effect is identical: it starts OOo with an
empty Writer document.
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Opening files
To open an existing document, choose File > Open or click the Open File icon on the
Standard Toolbar or press Control+O.

The Open dialog appears. Figure 13 shows the Windows XP version of this dialog.

1. Select the file

2. Click Open

Figure 7. Open dialog in Windows XP
Choose the file and then click Open.
Note
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Under Microsoft Windows you can use either the OpenOffice.org Open and Save As
dialogs or the ones provided by Microsoft Windows. See “Using the Open and Save
As dialogs” on page 38.
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File formats
OpenOffice.org can import Microsoft Office files. However, at the time of writing, Microsoft
Office cannot import files in the OpenDocument format used by OOo. Plug-ins are
becoming available to allow Microsoft Office to read and write OpenDocument files, but if
you want to send a file to Microsoft Office users and be sure they can open it, save it in a
Microsoft Office format or in .rtf. Table 1 is a list for quick reference.
Table 1: Comparison of OpenDocument and Microsoft Office file types
OpenDocument type

Application

Extension

MS Office equiv

Text

Writer

.odt

.doc

Text Template

Writer

.ott

.dot

Master Document

Writer

.odm

.doc

Spreadsheet

Calc

.ods

.xsl

Spreadsheet Template

Calc

.ots

.xst

Drawing

Draw

.odg

N/A

Drawing Template

Draw

.otg

N/A

Presentation

Impress

.odp

.ppt

Presentation Template

Impress

.otp

.pot

Formula

Math

.odf

N/A

Chart

Chart

.odc

N/A

Database

Base

.odb

.mdb

Default file formats
OpenOffice.org saves files in the OpenDocument format by default unless told otherwise.
This default can be changed, for example, if you always want to save as Microsoft Office
files. To change the default file formats:
1) Go to Tools > Options > Load/Save > General. (See Figure 8.)
2) In the Default file format section of this page, choose a document type (for example,
“Text document”) and a file format from the Always save as list.
3) Repeat for each document type, as necessary.
4) Click OK to save your changes.
Notes

If the option “Warn when not saving in OpenDocument or default format” is checked
on the Options – Load/Save – General dialog (Figure 8), a warning dialog about
potential loss of formatting may be displayed. In most cases, no loss of formatting
will occur, so you may find this warning annoying and choose to disable it.
The Java Runtime Environment is required to use the mobile device filters for
AportisDoc (Palm), Pocket Word, and Pocket Excel.
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Figure 8. Choosing default formats for saving files

Opening text documents
In addition to OpenDocument formats (.odt, .ott, .oth, and .odm), Writer 2.x can open the
formats used by OOo 1.x (.sxw, .stw, and .sxg) and the following text document formats:
Microsoft Word 6.0/95/97/2000/XP) (.doc and .dot)
Microsoft Word 2003 XML (.xml)
Microsoft WinWord 5 (.doc)
StarWriter formats (.sdw, .sgl, and .vor)
AportisDoc (Palm) (.pdb)
Pocket Word (.psw)

WordPerfect Document (.wpd)
WPS 2000/Office 1.0 (.wps)
DocBook (.xml)
Ichitaro 8/9/10/11 (.jtd and .jtt)
Hangul WP 97 (.hwp)
.rtf, .txt, and .csv

When opening .htm or .html files (used for web pages), OpenOffice.org customizes Writer
for working with these files.

Opening spreadsheets
In addition to OpenDocument formats (.ods and .ots), Calc 2.x can open the formats used by
OOo 1.x (.sxc and .stc) and the following spreadsheet formats:
Microsoft Excel 97/2000/XP (.xls, .xlw, and .xlt)
Microsoft Excel 4.x–5.0/95 (.xls, .xlw, and .xlt)
Microsoft Excel 2003 XML (.xml)
Data Interchange Format (.dif)
dBase (.dbf)
.htm and .html files including Web page queries
Quattro Pro 6.0 (.wb2)
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Rich Text Format (.rtf)
Text CSV (.csv and .txt)
Lotus 1-2-3 (.wk1, .wks, and .123)
StarCalc formats (.sdc and .vor)
SYLK (.slk)
Pocket Excel (pxl)
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Opening gresentations
In addition to OpenDocument formats (.odp, .odg, and .otp), Impress 2.x can open the
formats used by OOo 1.x (.sxi and .sti) and the following presentation formats:
•
•
•

Microsoft PowerPoint 97/2000/XP (.ppt, .pps, and .pot)
StarDraw and StarImpress (.sda, .sdd, .sdp, and .vor)
CGM – Computer Graphics Metafile (.cgm)

Opening graphic files
In addition to OpenDocument formats (.odg and .otg), Draw 2.x can open the formats used by
OOo 1.x (.sxd and .std) and the following graphic formats:
BMP
DXF
EMF
EPS
GIF

JPEG, JPG
MET
PBM
PCD
PCT

PCX
PGM
PLT
PNG
PPM

PSD
RAS
SDA
SDD
SGF

SGV
SVM
TGA
TIF, TIFF
VOR

WMF
XBM
XPM

Opening formula files
In addition to OpenDocument Formula (.odf) files, Math 2.x can open the format used by
OOo 1.x (.sxm), StarMath, (.smf), and MathML (.mml) files.
When opening a Word document that contains an embedded equation editor object, if the
option for it is checked in Tools > Options > Load/Save > Microsoft Office, the object will
be automatically converted to an OpenOffice.org Math object.

Saving files
To save a new file:
1) Choose File > Save As.
2) When the Save As dialog appears, enter the file name and verify the file type (if
applicable).
To save an open document with the current file name, choose File > Save. This will
overwrite the last saved state of the file.

Password protection
To protect an entire document from being viewable without a password, use the option on the
Save As dialog to enter a password. This option is only available for files saved in
OpenDocument formats or the older OpenOffice.org 1.x formats.

Chapter 3 File Management in OpenOffice.org

27

Saving files

1) On the Save As dialog, select the checkbox beside Save with password, and then
click Save. You will receive a prompt:

2) Type the same password in the Password field and the Confirm field, and then click
OK. If the passwords match, the document is saved password protected. If the
passwords do not match, you receive the prompt to enter the password again.
Note

Passwords must contain a minimum of 5 characters. Until you have entered 5
characters, the OK button remains inactive.

Saving a document automatically
You can choose to have OpenOffice.org save files for you automatically. Automatic saving,
like manual saving, overwrites the last saved state of the file. To set up automatic file saving:
1) Choose Tools > Options > Load/Save > General. (See Figure 8.)
2) Mark Save AutoRecovery information every, and set the time interval.

Writer can save to these file formats
In addition to OpenDocument formats (.odt and .ott), Writer 2.x can save in these formats:
•
•
•
•
•
•
•
•
•
•
•
•
•
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OpenOffice.org 1.x Text Document(.sxw)
OpenOffice.org 1.x Text Document Template (.stw)
Microsoft Word 6.0, 95, and 97/2000/XP (.doc)
Microsoft Word 2003 XML (.xml)
Rich Text Format (.rtf)
StarWriter 3.0, 4.0, and 5.0 (.sdw)
StarWriter 3.0, 4.0, and 5.0 Template (.vor)
Text (.txt)
Text Encoded (.txt)
HTML Document (OpenOffice.org Writer) (.html and .htm)
DocBook (.xml)
AportisDoc (Palm) (.pdb)
Pocket Word (.psw)
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Note

The .rtf format is a common format for transferring text files between applications,
but you are likely to experience loss of formatting and images. For this reason, other
formats should be used.

Calc can save to these file formats
In addition to OpenDocument formats (.ods and .ots), Calc 2.x can save in these formats:
•
•
•
•
•
•
•
•
•
•
•
•
•

Note

OpenOffice.org 1.x Spreadsheet (.sxc)
OpenOffice.org 1.x Spreadsheet Template (.stc)
Microsoft Excel 97/2000/XP (.xls and .xlw)
Microsoft Excel 97/2000/XP Template (.xlt)
Microsoft Excel 5.0 and 95 (.xls and .xlw)
Microsoft Excel 2003 XML (.xml)
Data Interchange Format (.dif)
dBase (.dbf)
SYLK (.slk)
Text CSV (.csv and .txt)
StarCalc 3.0, 4.0, and 5.0 formats (.sdc and .vor)
HTML Document (OpenOffice.org Calc) (.html and .htm)
Pocket Excel (.pxl)
The Java Runtime Environment is required to use the mobile device filters for
AportisDoc (Palm), Pocket Word, and Pocket Excel.

Impress can save to these file formats
In addition to OpenDocument formats (.odp, .otp, and .odg), Impress 2.x can save in these
formats:
•
•
•
•
•

OpenOffice.org 1.x Presentation (.sxi)
OpenOffice.org 1.x Presentation Template (.sti)
Microsoft PowerPoint 97/2000/XP (.ppt and .pps)
Microsoft PowerPoint 97/2000/XP Template (.pot)
StarDraw, StarImpress (.sda, .sdd, and .vor)

Impress can also export to MacroMedia Flash (.swf) and any of the graphics formats listed
for Draw.

Chapter 3 File Management in OpenOffice.org

29

Saving files

Draw can save to these file formats
Draw can only save in the OpenDocument Drawing formats (.odg and .otg), the
OpenOffice.org 1.x formats (.sxd and .std) and StarDraw format (.sda, .sdd, and .vor).
However, Draw can also export to BMP, EMF, EPS, GIF, JPEG, MET, PBM, PCT, PGM,
PNG, PPM, RAS, SVG, SVM, TIFF, WMF, and XPM.

Writer/Web can save in these formats
HTML document (.html and .htm)
OpenOffice.org 1.0 HTML Template (.stw)
OpenOffice.org 2.x HTML Template (.oth)
StarWriter/Web 4.0 and 5.0 (.vor)
Text (OpenOffice.org Writer/Web) (.txt)
Text Encoded (OpenOffice.org Writer/Web) (.txt)

Exporting files
Export to XHTML, BibTeX, LaTeX, and Flash
OpenOffice.org can export files to XHTML.
In addition, OOo Writer can export to BibTeX (.bib) and LaTeX 2e (.tex). OOo Draw and
OOo Impress can export to Macromedia Flash (.swf).
To export to one of these formats, choose File > Export. On the Export dialog, then select
the required format in the File format list.

Export to PDF
OpenOffice.org can directly export to PDF. This industry-standard file format for file viewing
is ideal for sending the file to someone else to view using Acrobat Reader or other PDF
viewers.
You can export directly to PDF using a button on the toolbar
Export as PDF.

or by choosing File >

If you use File > Export as PDF, you are asked to enter the filename for the PDF file, and
then the PDF Options dialog (Figure 9) opens.
Note
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If you use the Export Directly as PDF button, you are asked to enter the filename
for the PDF file, but you cannot choose a page range, the image compression, or
other export options.
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PDF options
The PDF Options dialog has four pages (General, Initial View, User Interface, Security).
Make your selections, and then click Export.
General page of PDF Options dialog

On the General page (Figure 9), you can choose which pages to include in the PDF, the type
of compression to use for images (which affects the quality of images in the PDF), and other
options.

Figure 9: General page of PDF Options dialog
Range section
•
•

•

All: Exports the entire document.
Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single
pages, use the format 7;9;11 (pages 7, 9, and 11). You can also export a combination
of page ranges and single pages, by using a format like 3-6;8;10;12.
Selection: Exports whatever material is selected.

Images section
•

Lossless compression: Images are stored without any loss of quality. Tends to make
large files when used with photographs. Recommended for other images.
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•

JPEG compression: Allows for varying degrees of quality. A setting of 90% tends to
work well with photographs (small file size, little perceptible loss).

•

Reduce image resolution: Lower-DPI (dots per inch) images have lower quality.

Note

EPS images with embedded previews are exported only as previews. EPS images
without embedded previews are exported as empty placeholders.

General section
•

Tagged PDF: Includes special tags into the corresponding PDF tags. Some tags that
are exported are table of contents, hyperlinks, and controls. This option can increase
file sizes significantly.

•

Export notes: Exports notes in Writer and Calc documents as PDF notes.You may not
want this!

•

Export bookmarks: Exports headings as “bookmarks” (a table of contents list
displayed by some PDF readers, including Adobe Reader).

•

•

Create PDF form - Submit format: Choose the format of submitting forms from
within the PDF file. This setting overrides the control’s URL property that you set in
the document. There is only one common setting valid for the whole PDF document:
PDF (sends the whole document), FDF (sends the control contents), HTML, and
XML. Most often you will choose the PDF format.
Export automatically inserted blank pages: If selected, automatically inserted blank
pages are exported to the PDF. This is best if you are printing the PDF double-sided.
For example, books usually have chapters set to always start on an odd-numbered
(right-hand) page. When the previous chapter ends on an odd page, OOo inserts a
blank page between the two odd pages. This option controls whether to export that
blank page.

Initial View page of PDF Options dialog

On the Initial View page (Figure 10), you can choose how the PDF opens by default in a PDF
viewer. The selections should be self-explanatory.
User Interface page of PDF Options dialog

On the User Interface page (Figure 11), you can choose more settings to control how a PDF
viewer displays the file. Some of these choices are particularly useful when you are creating a
PDF to be used as a presentation or a kiosk-type display.
Window options section
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•

Resize window to initial page. PDF viewer resizes to fit the first page of the PDF.

•

Center window on screen. PDF viewer window is centered on the computer screen.

•

Open in full screen mode. PDF viewer opens full-screen instead of in a smaller
window.

•

Display document title. PDF viewer displays the document’s title in the title bar.
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Figure 10: Initial View page of PDF Options dialog

Figure 11: User Interface page of PDF Options dialog
User interface options section
•

Hide menubar. PDF viewer hides the menu bar.

•

Hide toolbar. PDF viewer hides the toolbar.

•

Hide window controls. PDF viewer hides other window controls.
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Transitions section

Includes Impress slide transition effects in the respective PDF effects.
Bookmarks section

Select how many heading levels are displayed as bookmarks, if “Export bookmarks” is
selected on the General page.
Security page of PDF Options dialog

As of OOo 2.0.4, PDF export includes options to encrypt the PDF (so it cannot be opened
without a password) and apply some digital rights management (DRM) features.

Figure 12: Security page of PDF Options dialog
•

•

With a permissions password set, the PDF can be opened by anyone, but its
permissions can be restricted. See Figure 12.

•

With both the open password and permission password set, the PDF can only be
opened with the correct password, and its permissions can be restricted.

Note
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With an open password set, the PDF can only be opened with the password. Once
opened, there are no restrictions on what the user can do with the document (for
example, print, copy, or change it).

Permissions settings are effective only if the user’s PDF viewer respects the settings.
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Figure 7 shows the pop-up dialog displayed when you click the Set open password button
on the Security page of the PDF Options dialog box.
After you set a password for permissions, the other choices on the Security page (shown in
Figure 12) become available. These selections should be self-explanatory.

Figure 13: Setting a password to encrypt a PDF

Deleting and renaming files
You can rename or delete files within the OpenOffice.org dialogs, just as you can in your
usual file manager. However, you cannot copy or paste files within the dialogs.

Renaming a file
To rename a file while using OpenOffice.org:
1) Choose File > Open and browse to the required file.
2) Right-click on the file name and choose Rename. The file name will be selected.
3) Typing replaces the selected name, or use a left or right arrow key to move the
insertion point to modify the existing name.

Deleting a file
To delete a file while using this dialog:
1) Right-click on the file name to display a context menu.
2) Click Delete, and you will get a confirmation dialog.
Note

Instead of Right-click > Delete, you can simply press the Delete key.
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File associations
File associations are used to open certain types of files automatically with OpenOffice.org.
You can choose to associate Microsoft Office files with OOo. If you do this, the files remain
as Microsoft Office files, but the icon for the files changes to the OOo icon, and doubleclicking on the icon opens the files in OOo. (You can still open the files in Microsoft Office
by starting MS Office and then choosing File > Open.)
When installing OOo, you are prompted to associate file types, as shown in Figure 14. If you
want to continue to open your Microsoft Office files in Office by double-clicking them, do
not check these boxes. (You can open MS Office files in OOo by starting OOo and then
choosing File > Open.)

Figure 14. Choosing file associations when installing OpenOffice.org
If during installation you chose not to have OpenOffice.org automatically open Microsoft
Word files, you can change this later.
1) In Windows, go to Settings > Add or Remove Programs. Scroll down to
OpenOffice.org 2.0 and click once on it. Two buttons should be visible: Change and
Remove, as shown in Figure 15. This may appear different on your system.
2) Click Change to start the Installation Wizard.
3) Continue through the Installation Wizard until you reach the page shown in Figure 14.
Select the file types you want OOo to open (put a mark in each checkbox) and click
OK.
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Figure 15. Changing the OOo installation on Windows XP

Creating new files
Different ways of creating a new document:
•

Use File > New and choose the type of document.

•

Use the arrow next to the New button on the main toolbar. A menu of choices (Figure
16) drops down; select the type of document to be created.

Figure 16. The New menu from the toolbar
•

Use a “Quick start” program. For example, the Microsoft Windows version of
OpenOffice.org has a Quickstart icon
in the system tray. See Chapter 2 (Starting
OpenOffice.org) for more information on the Quickstart icon.

•

Press Control+N on the keyboard.

•

Use File > Wizards for some types of documents. (See Figure 17.)
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Figure 17. Creating a file using a Wizard

Using the Open and Save As dialogs
If you are using Microsoft Windows, you can choose whether to use the OpenOffice.org
Open and Save As dialogs or the ones provided by Windows. To view or change which type
of dialog OpenOffice.org uses:
1) Choose Tools > Options > OpenOffice.org > General.
2) Select the Use OpenOffice.org dialogs checkbox.
This section discusses the OpenOffice.org Open and Save As dialogs. See Figures 18 and 19
for examples of these dialogs.
The three buttons in the top right of the OOo Open dialog (Figure 18) are, from left to right:
•

Go Up One Level in the folder (directory) hierarchy. This is a long-click button if you
want to go up higher than just one level.

•

Create New Folder.

•

View Menu.

For OpenOffice.org documents that have been saved with more than one version, use the
version drop-down to select which version you wish to open in read-only mode.
Note
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For Microsoft Office documents, only the current version can be opened.
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Figure 18. The OOo Open dialog, showing some of the file formats that can be opened
Use the Files of type field to specify the type of file to be opened or the format of the file to
be saved.
The Read-only checkbox opens the file for reading and printing only. Consequently, most of
the toolbars disappear, and most menu options are disabled. An Edit File button is displayed
on the Function Toolbar to open the file for editing.
It is possible to open files from the web using URLs.
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Figure 19. The OpenOffice.org Save As dialog, showing some of the Save formats

Digital signing of documents
To sign a document digitally, you need a personal key, the certificate. A personal key is stored
on your computer as a combination of a private key, which must be kept secret, and a public
key, which you add to your documents when you sign them. You can get a certificate from a
certification authority, which may be a private company or a governmental institution.
When you apply a digital signature to a document, a kind of checksum is computed from the
document’s content plus your personal key. The checksum and your public key are stored
together with the document.
When someone later opens the document on any computer with a recent version of
OpenOffice.org, the program will compute the checksum again and compare it with the
stored checksum. If both are the same, the program will signal that you see the original,
unchanged document. In addition, the program can show you the public key information from
the certificate. You can compare the public key with the public key that is published on the
web site of the certificate authority.
Whenever someone changes something in the document, this change breaks the digital
signature.
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On Windows operating systems, the Windows features of validating a signature are used. On
Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are
used. For a more detailed description of how to get and manage a certificate, and signature
validation, see “Using Digital Signatures” in the OOo Help.
To sign a document:
1) Choose File > Digital Signatures.
2) If you have not saved the document since the last change, a message box appears.
Click Yes to save the file.
3) After saving, you see the Digital Signatures dialog. Click Add to add a public key to
the document.
4) In the Select Certificate dialog, select your certificate and click OK.
5) You see again the Digital Signatures dialog, where you can add more certificates if you
want. Click OK to add the public key to the saved file.
A signed document shows an icon
the certificate.

in the status bar. You can double-click the icon to view
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Chapter 4
Menus and Toolbars
Using and customizing those common to all
OpenOffice.org components

Menus

Menus
The Menu bar (Figure 20) is located across the top of the screen, just below the Title bar.
The main menu selections are File, Edit, View, Insert, Format, Table, Tools, Window, and
Help. When you choose one of the menus, a submenu drops down to show other options.

Figure 20. Menu bar
•

File contains commands that apply to the entire document such as Open, Save, and
Export as PDF.

•

Edit contains commands for editing the document such as Undo and Find & Replace.

•

View contains commands for controlling the display of the document such as Zoom and
Web Layout.

•

Insert contains commands for inserting elements into your document such as Header,
Footer, and Picture.

•

Format contains commands, such as Styles and Formatting and AutoFormat, for
formatting the layout of your document.

•

Table shows all commands to insert and edit a table in a text document.

•

Tools contains functions such as Spellcheck, Customize, and Options.

•

Window contains commands for the display window.

•

Help contains links to the Help file, What’s This help, and information about the version
of OpenOffice.org you have installed.

Customizing the menu font
If you want to change the menu font from that supplied by OOo to the system font for your
operating system, do this:
1) Choose Tools > Options > OpenOffice.org > View.
2) Check Use system font for user interface.
3) Click OK.
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Customizing menu content
It is possible to customize menus in OpenOffice.org. To customize menus:
1) Choose Tools > Customize.
2) On the Customize dialog, pick the Menus tab (Figure 21).
3) In the Save In drop-down list, choose whether to save this changed menu for the
application (for example, Writer) or for a selected document.
4) In OpenOffice.org <name of the program (example: Writer)> Menus, select the
menu you want to customize in the Menu drop-down list.
5) You can customize each menu by clicking on the Menu or Modify buttons.
6) You can add commands in a menu by clicking on the Add button.
7) You can create a new menu by clicking on the New button.

Figure 21. The Menus tab of the Customize dialog
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Toolbars
The top toolbar (default position) is called the Standard toolbar. The Standard toolbar is
consistent across the OpenOffice.org applications.
The second toolbar across the top (default location) is the Formatting toolbar. It is a contextsensitive bar which shows the relevant tools in response to the cursor’s current position or
selection. For example, when the cursor is on a graphic, the Formatting bar provides tools for
formatting graphics; when the cursor is in text, the tools are for formatting text.
Standard toolbar
Formatting toolbar

Floating toolbars
Writer includes several additional context-sensitive toolbars, whose defaults appear as
floating toolbars in response to the cursor’s current position or selection. For example, when
the cursor is in a table, a floating Table toolbar appears, and when the cursor is in a numbered
or bullet list, the Bullets and Numbering toolbar appears. You can dock these toolbars to the
top, bottom, or side of the window, if you wish (see “Moving toolbars” on page 47).

Long-click buttons and tear-off toolbars
Buttons with a small black triangle will display
submenus, tear-off toolbars, and other ways of
selecting things with a long click, depending on the
button.
Figure 28 shows the Paste submenu.
Figure 23 shows a tear-off toolbar from the Drawing
toolbar.

Figure 22: Example of a submenu

The tear-off toolbars can be floating or docked along an edge of the screen or in one of the
existing toolbar areas. To move a floating tear-off toolbar, drag it by the title bar. See
“Moving toolbars” on page 47.
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Click here and drag

Toolbar tears off and floats

Figure 23: Example of a tear-off toolbar

Displaying or hiding toolbars
To display or hide toolbars, choose View > Toolbars, then click on the name of a toolbar in
the list. An active toolbar shows a checkmark beside its name. Tear-off toolbars are not listed
in the View menu.

Moving toolbars
To move a docked toolbar, place the mouse pointer over the toolbar handle, hold down the
left mouse button, drag the toolbar to the new location, and then release the mouse button.
To move a floating toolbar, click on its title bar and drag it to a new location. shows
examples.
Handle of docked toolbar

Figure 24: Moving a docked toolbar
Title bar of floating toolbar

Figure 25: Moving a floating toolbar
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Customizing a toolbar
There are three main ways to get to the toolbar customization dialog:
•

On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.

•

Choose View > Toolbars > Customize from the menu bar.

•

Choose Tools > Customize from the menu bar. On the Toolbars tab (Figure 26), choose
the toolbars you want to modify and click the Toolbar or Modify button.

Figure 26. The Toolbars tab of the Customize window
Note
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There is no in-built tool button editor. To use a custom icon, save it to the
{install path}/share/config/symbol directory in *.bmp format. OOo
automatically searches this directory for new icons each time the Customize Buttons
dialog is opened. Custom icons must be 16 x 16 or 26 x 26 pixels in size and cannot
contain more than 256 colors.
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Creating a new toolbar
To create a new toolbar:
1) Choose Tools > Customize > Toolbars from the menu bar.
2) Click New. This will create a toolbar called “New Toolbar1”.
3) Customize the toolbar as above.

Using dockable/floating windows and
toolbars
Toolbars and some windows, such as the Navigator and the Styles and Formatting window,
are dockable. You can move, re-size or dock them to an edge.
To dock a window or toolbar, do one of the following:
•

•

Click on the title bar of the floating window and
drag it to the side until you see the outline of a
box appear in the main window (see Figure 27),
then release the window. This method depends
on your system’s window manager settings, so
it may not work for you.
Hold down the Control key and double-click on
a vacant part of the floating window to dock it
in its last position. If that does not work, try
double-clicking without using the Control key.

To undock a window, hold down the Control key and
double-click on a vacant part of the docked window.
Note

The Styles and Formatting window can
also be docked or undocked by using
Control+double-click on the gray area next
to the icons at the top of the window.

Figure 27: Docking a window

Using the Navigator
The Navigator displays all objects contained in a document. It provides a very convenient
way to move around a document and find items in it. The Navigator button is located on the
Standard Toolbar.
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The Navigator (Figure 25) displays lists of Headings, Tables, Bookmarks, Graphics, Text
frames, and other items. Click the + sign by any of the lists to display the contents of the list.
If you only want to see the content in a certain category, highlight the category and click the
Content View icon.

Content View icon

Figure 28. The Navigator
Note

The Navigator looks somewhat different in a master document. See Chapter 13
(Working with Master Documents) in the Writer Guide for more details.

The Navigator helps you to reach objects quickly. Double-click on the object in the Navigator
to jump directly to that object’s location in the document, as shown in Figure 24.

Figure 29. Using the Navigator to jump quickly to a heading in Writer
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Arranging chapters using the Navigator
You can arrange chapters and move headings in a Writer document by using the Navigator.
1) Click the Content View icon.
2) Click on the heading in question.
3) Drag the heading to a new location on the Navigator or click the heading in the
Navigator list, then click Promote Chapter or Demote Chapter.
Demote
Chapter
Promote
Chapter
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Chapter 5
Setting up OpenOffice.org
Choosing Options to Suit the Way You Work

Choosing options that affect all of OOo

Choosing options that affect all of OOo
This section covers some of the settings that apply to all the components of OOo. For
information on settings not discussed here, see the online help.
1) Click Tools > Options. The list in the left-hand box varies depending on which
component of OOo is open. The illustrations in this chapter show the list as it appears
when no document is open. (For example, when a Writer document is open, additional
options for OpenOffice.org Writer and OpenOffice.org Writer/Web appear on the list.)
2) Click the + sign to the left of OpenOffice.org in the left-hand section. A list of
subsections drops down.
Note

The Back button has the same effect on all pages of the Options dialog. It resets the
options to the values that were in place when you opened OpenOffice.org.

User Data options
Because OOo’s revision features mark your changes and comments with the name or initials
stored in User Data, you will want to ensure that your name and initials appear there. To do
this:
1) In the Options dialog, click OpenOffice.org > User Data.
2) Fill in the form on the OpenOffice.org User Data page (Figure 30), or delete any
existing incorrect information.

Figure 30. Filling in user data
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General options
1) In the Options dialog, click OpenOffice.org > General.
2) On the OpenOffice.org – General page (Figure 31), the options are as described below.

Figure 31. Setting general options for OpenOffice.org
Help - Tips

When Help Tips are active, one or two words will appear when you hover the cursor over an
icon or field on the main OOo window. This setting also affects the display of notes: if both
Help Tips and Extended Tips are turned off, then you will not see the contents of a note when
you hover the cursor on the note.
Help - Extended tips

When Extended tips are active, a brief description of the function of a particular icon or menu
command, or a field on a dialog appears when you hover the cursor on that item.
Help Agent

To turn off the Help Agent (similar to Microsoft’s Office Assistant), deselect this checkbox.
To restore the default Help Agent behavior, click Reset Help Agent.
Help formatting

High contrast is an operating system setting that changes the system color scheme to improve
readability. To display Help in high contrast (if your computer’s operating system supports
this), choose one of the high-contrast style sheets from the list.
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Open/Save dialogs

To use the standard Open and Save dialogs for your operating system, deselect the Use
OpenOffice.org dialogs checkbox. When this checkbox is selected, the Open and Save
dialogs supplied with OpenOffice.org will be used. See Chapter 3 (File Management) more
about the OOo Open and Save dialogs.
Document status

Choose whether printing a document counts as changing the document. If this option is
selected, then the next time you close the document after printing, the print date is recorded
in the document properties as a change and you will be prompted to save the document again,
even if you did not make any other changes.
Year (two digits)

Specifies how two-digit years are interpreted. For example, if the two-digit year is set to
1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as
1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is,
1/1/20 is interpreted as 1/1/2020.

Memory options
1) In the Options dialog, click OpenOffice.org > Memory.
2) On the OpenOffice.org – Memory dialog (Figure 32):
•

•

More memory can make OpenOffice.org faster and more convenient (for example,
more undo steps require more memory); but the trade-off is less memory available
for other applications and you could run out of memory altogether.
To load the Quickstarter (an icon on the desktop or in the system tray) when you
start your computer, select the checkbox near the bottom of the dialog. This makes
OpenOffice.org start faster; the trade-off is OOo uses some memory even when not
being used. This option (called “Enable systray quickstarter”) is disabled in some
Linux installations.

Figure 32. Choosing Memory options for the OpenOffice.org applications
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View options
The choices of View options affect the way the document window looks and behaves.
1) In the Options dialog, click OpenOffice.org > View.
2) On the OpenOffice.org – View page (Figure 33), set the options to suit your personal
preferences. Some options are described below.

Figure 33. Choosing View options for the OpenOffice.org applications
User Interface – Scaling

If the text in the help files and on the menus of the OOo user interface is too small or too
large, it can be changed by specifying a scaling factor. Sometimes a change here can have
unexpected results, depending on the screen fonts available on your system. It does not affect
the actual font size of the text.
User Interface – Icon size and style

The first box specifies the display size of toolbar icons (small, large or automatic); the
Automatic option uses the icon size setting for your operating system. The second box
specifies the icon set (theme); here the Automatic option uses an icon set compatible with
your operating system and choice of desktop: for example, KDE or Gnome on Linux.
User Interface – Use system font for user interface

If you prefer to use the system font (the default font for your computer and operating system),
instead of the font provided by OOo, for the user interface, select this checkbox.
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User interface – Screen font antialiasing

(Not available in Windows, so not shown in Figure 33.) Select this checkbox to smooth the
screen appearance of text. Enter the smallest font size to apply antialiasing.
Menu – icons in menus

Select this option if you want icons as well as words to be visible in menus.
Font Lists - Show preview of fonts

When you select this option, the font list looks like Figure 34, left, with the font names
shown as an example of the font; with the checkbox deselected, the font list shows only the
font names, not their formatting (Figure 34, right). The fonts you will see listed are those that
are installed on your system.

Figure 34. (Left) Font list showing preview; (Right) Font list without preview
Font Lists - Show font history

When you select this option, the last five fonts you have assigned to the current document are
displayed at the top of the font list.
3D view

These options are for use with Draw and Impress. For more information, see the online help
or other documentation on these applications.
Mouse

Use these options to choose how the mouse is positioned in newly opened dialogs and to
select the function of the middle mouse button.

Print options
Set the print options to suit your default printer and your most common printing method. You
can change these settings at any time, either through this dialog or during the printing process
(by clicking the Options button on the Print dialog).
1) In the Options dialog, click OpenOffice.org > Print.
2) On the OpenOffice.org – Print dialog (Figure 35), look at the Printer warnings section
near the bottom.
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3) Here you can choose whether to be warned if the paper size or orientation specified in
your document does not match the paper size or orientation available for your printer.
Having these warnings turned on can be quite helpful, particularly if you work with
documents produced by people in other countries where the standard paper size is
different from yours.
Tip

If your printouts are coming out incorrectly placed on the page or chopped off at the
top, bottom, or sides, or the printer is refusing to print, the most likely cause is page
size incompatibility.

Figure 35. Choosing general printing options to apply to all OOo components

Path options
You can change the location of files associated with, or used by, OpenOffice.org to suit your
working situation. In a Windows system, for example, you might want to store documents by
default somewhere other than My Documents.
1) In the Options dialog, click OpenOffice.org > Paths.
2) To make changes, select an item in the list shown in Figure 36 and click Edit. On the
Select Paths dialog (not shown), add or delete folders as required, and then click OK
to return to the Options dialog. Note that many items have at least two paths listed:
one to a shared folder (which might be on a network) and one to a user-specific folder
(normally on the user’s personal computer).
Tip

You can use the entries in the OpenOffice.org – Paths dialog to compile a list of
files, such as those containing AutoText, that you need to back up or copy to another
computer.
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Figure 36. Viewing the paths of files used by OpenOffice.org

Color options
In the OpenOffice.org – Colors dialog (Figure 37), you can specify colors to use in OOo
documents. You can select a color from a color table, edit an existing color, or define new
colors. These colors will then be available in color selection palettes in OOo.

Figure 37. Defining colors to use in color palettes in OOo
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Font options
You can define replacements for any fonts that might appear in your documents. If you
receive from someone else a document containing fonts that you do not have on your system,
OpenOffice.org will substitute fonts for those it does not find. You might prefer to specify a
different font from the one the program chooses.
1) In the Options dialog, click OpenOffice.org > Fonts.
2) On the OpenOffice.org – Fonts dialog (Figure 38):
•
•

•

Select the Apply Replacement Table checkbox.
Select or type the name of the font to be replaced in the Font box. (If you do not
have this font on your system, it will not appear in the drop-down list in this box,
so you need to type it in.)
In the Replace with box, select a suitable font from the drop-down list of fonts
installed on your computer.

3) The checkmark to the right of the Replace with box turns green. Click on this
checkmark. A row of information now appears in the larger box below the input boxes.
Select the checkboxes under Always and Screen.
4) In the bottom section of the dialog, you can change the typeface and size of the font
used to display source code such as HTML and Basic (in macros).

Figure 38. Defining a font to be substituted for another font
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Security options
Use the OpenOffice.org – Security page (Figure 39) to choose security options for saving
documents and for opening documents that contain macros.

Figure 39. Choosing security options for opening and saving documents

Appearance options
Writing, editing, and page layout are often easier to do when you can see as much as possible
of what is going on in your document. You may wish to make visible such items as text,
table, and section boundaries (in Writer documents), page breaks in Calc, and grid lines in
Draw or Writer. In addition, you might prefer different colors (from OOo’s defaults) for such
items as note indicators or field shadings.
On the OpenOffice.org – Appearance page (Figure 40), you can specify which items are
visible and the colors used to display various items.
1) In the Options dialog, click OpenOffice.org > Appearance.
2) To show or hide items such as text boundaries, select or deselect the checkboxes next
to the names of the items.
To change the default colors for items, click the down-arrow in the Color Setting
column by the name of the item and select a color from the pop-up box.
3) To save your color changes as a color scheme, click Save, type a name in the Scheme
box; then click OK.
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Figure 40. Showing or hiding text, object, and table boundaries

Accessibility options
Accessibility options include whether to allow animated graphics or text, how long help tips
remain showing, some options for high contrast display, and a way to change the font for the
user interface of the OpenOffice.org program (see Figure 41).
Accessibility support relies on Sun Microsystems Java technology for communications with
assistive technology tools. See “Java options“ on page 64. The “Support assistive technology
tools” option is not shown on all OOo installations. See “Assistive Tools in OpenOffice.org”
in the Help for other requirements and information.

Figure 41. Choosing accessibility options
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1) In the Options dialog, click OpenOffice.org > Accessibility.
2) Select or deselect the options as required.

Java options
If you install or update a Java Runtime Environment (JRE) after you install OpenOffice.org,
or if you have more than one JRE installed on your computer, you can use the Java options
page (Figure 42) to choose the JRE for OOo to use.
If you are a system administrator, programmer, or other person who customizes JRE
installations, you can use the Parameters and Class Path pages (reached from the Java page)
to specify this information.
1) In the Options dialog, click OpenOffice.org > Java.
2) If you do not see anything listed in the middle of the page, wait a few minutes while
OOo searches for JREs on the hard disk.
3) If OOo finds one or more JREs, it will display them there. You can then select the Use
a Java runtime environment checkbox and (if necessary) choose one of the JREs
listed.

Figure 42. Choosing a Java runtime environment

Online Update options
On the Online Update page (not shown here), you can choose whether and how often to have
OOo check the OOo website for program updates.
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Choosing options for loading and saving
documents
You can set the Load/Save options to suit the way you work.

General Load/Save options
1) If the Options dialog is not already open, click Tools > Options. Click the + sign to
the left of Load/Save.
2) Choose Load/Save > General.
Most of the choices on the Options – Load/Save – General dialog (Figure 43) are familiar to
users of other office suites. Some items of interest are described below.

Figure 43. Choosing Load and Save options
Load user-specific settings with the document

When you save a document, certain settings are saved with it. For example, your choice (in
the options for OOo Writer) of how to update links is affected by the Load user-specific
settings option. Some settings (printer name, data source linked to the document) are always
loaded with a document, whether or not this checkbox is selected.
If you select this option, these document settings are overruled by the user-specific settings of
the person who opens it. If you deselect this option, users’ personal settings do not overrule
the settings in the document.
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Edit document properties before saving

When you select this option, the Document Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save As).
Save AutoRecovery information every

Note that AutoRecovery in OpenOffice.org overwrites the original file. If you have also
chosen Always create backup copy, the original file then overwrites the backup copy. If
you have this set, recovering your document after a system crash will be easier; but
recovering an earlier version of the document may be harder.
Size optimization for XML format (no pretty printing)

OpenOffice.org documents are XML files. When you select this option, OOo writes the XML
data without indents and line breaks. If you want to be able to read the XML files in a text
editor in a structured form, deselect this option.
Default file format

If you routinely share documents with users of Microsoft Word, you might want to change the
Always save as attribute for text documents in the Standard file format section to one of the
Word document types.

VBA Properties Load/Save options
1) Choose Load/Save > VBA Properties.
2) On the Options – Load/Save – VBA Properties dialog (Figure 44), you can whether to
keep any macros in MSOffice documents that are opened in OOo.
•

If you choose Save original Basic code, the macros will not work in OOo but
are retained if you save the file into Microsoft Office format.

•

If you choose Load Basic code to edit, the changed code is saved in an OOo
document but is not retained if you save into an MSOffice format.

Figure 44. Choosing Load/Save VBA Properties
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Microsoft Office Load/Save options
1) Choose Load/Save > Microsoft Office.
2) On the Options – Load/Save – Microsoft Office dialog (Figure 45), you can choose
what to do when importing and exporting Microsoft Office OLE objects (linked or
embedded objects or documents such as spreadsheets or equations).
Select the [L] checkboxes to convert Microsoft OLE objects into the corresponding
OpenOffice.org OLE objects when a Microsoft document is loaded into OOo
(mnemonic: “L” for “load”).
Select the [S] checkboxes to convert OpenOffice.org OLE objects into the
corresponding Microsoft OLE objects when a document is saved in a Microsoft format
(mnemonic: “S” for “save”).

Figure 45. Choosing Load/Save Microsoft Office options

HTML compatibility Load/Save options
Choices made on the Load/Save – HTML Compatibility dialog (Figure 46) affect HTML
pages imported into OpenOffice.org and those exported from OOo.
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Figure 46. Choosing HTML compatibility options

Choosing language settings
You may need to do several things to set the language settings to what you want:
•

Install the required dictionaries

•

Change some locale and language settings

•

Choose spelling options

Install the required dictionaries
OOo 2.0 automatically installs several dictionaries with the program. To add other
dictionaries, use File > Wizards > Install new dictionaries. An OOo document will open
with links to different languages that you can install. Follow the prompts to install them.

Change some locale and language settings
You can change some details of the locale and language settings that OOo uses for all
documents, or for specific documents.
1) In the Options dialog, click Language Settings > Languages.
2) On the right-hand side (as shown in Figure 47), change the Locale setting, Default
currency, and Default languages for documents as required. In the example, English
(Australia) has been chosen as the locale setting, and the Australian dollar (AUD) for
the default currency. Although an English (Australia) dictionary exists, the English
(UK) dictionary has been selected in the Default languages for documents.
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Figure 47. Choosing language options
3) If you want the language (dictionary) setting to apply to the current document only,
instead of being the default for all new documents, select the checkbox labelled For
the current document only.
4) If necessary, select the checkboxes to enable support for Asian languages (Chinese,
Japanese, Korean) and support for CCTL (complex text layout) languages such as
Hindi, Thai, Hebrew, and Arabic. If you choose either of these checkboxes, the next
time you open this dialog, you will see some extra choices under Language Settings, as
shown in Figure 48. These choices (Searching in Japanese, Asian Layout, and
Complex Text Layout) are not discussed here.
5) Click OK to save your changes and close the dialog.

Figure 48. Extra language settings when enhanced language support options are selected
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Choose spelling options
To choose the options for checking spelling:
1) In the Options dialog, click Language Settings > Writing Aids.
2) In the Options section of the Language Settings – Writing Aids dialog (Figure 49),
choose the settings that are useful for you. Some considerations:
•

•

If you do not want spelling checked while you type, deselect Check spelling as
you type and select Do not mark errors. (To find the second item, scroll down in
the Options list.)
If you use a custom dictionary that includes words in all uppercase and words with
numbers (for example, AS/400), select Check uppercase words and Check words
with numbers.

•

Check special regions includes headers, footers, frames, and tables when checking
spelling.

•

Here you can also check which user-defined (custom) dictionaries are active by
default, and add or remove dictionaries, by clicking the New or Delete buttons.

Figure 49. Choosing languages, dictionaries, and options for checking spelling

Internet options
Use the Internet Options pages to define search engines and save proxy settings for use with
OpenOffice.org.
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If you are using a Netscape or Mozilla browser (such as Firefox), you can enable the Mozilla
Plug-in so you can open OOo files in your browser, print them, save them, and work with
them in other ways.
If you are using a Unix or Linux based operating system (including Mac OS X), an additional
page of E-mail options is available, where you can specify the e-mail program to use when
you send the current document as e-mail (Figure 50).

Figure 50: Internet options, showing E-mail page available to Linux users

Controlling OOo’s AutoCorrect functions
Some people find some or all of the items in OOo’s AutoCorrect function annoying because
they change what you type when you do not want it changed. Many people find some of the
AutoCorrect functions quite helpful; if you do, then select the relevant checkboxes. But if
you find unexplained changes appearing in your document, this is a good place to look to find
the cause.
To open the AutoCorrect dialog, click Tools > AutoCorrect. (You need to have a document
open for this menu item to appear.)
In Writer, this dialog has five tabs, as shown in Figure 51. In other components of OOo,
where the dialog has only four tabs, the contents of the Options tab is as shown in Figure 52.
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Figure 51. The AutoCorrect dialog in Writer, showing the five tabs and some of the choices

Figure 52. The AutoCorrect dialog in Calc, showing four tabs and the Options choices
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Chapter 6
Getting Started with Writer
OpenOffice.org's Word Processor

What is Writer?

What is Writer?
Writer is the word processor component of OpenOffice.org (OOo). In addition to the usual
features of a word processor (spell checking, thesaurus, hyphenation, autocorrect, find and
replace, automatic generation of tables of contents and indexes, mail merge and others),
Writer provides these important features:
•

Templates and styles

•

Powerful page layout methods, including frames, columns, and tables

•

Embedding or linking of graphics, spreadsheets, and other objects

•

Built-in drawing tools

•

Master documentsf

•

Change tracking during revisions

•

Database integration, including a bibliography database

•

Export to PDF, including bookmarks

•

And many more

These features are covered in detail in the Writer Guide.

The Writer interface
The main Writer workspace is shown in Figure 53. The menus and toolbars are described in
Chapter 4 (Menus and Toolbars). Other features of the Writer interface are covered in this
chapter.

Menu bar

Standard toolbar

Formatting toolbar

Status bar

Figure 53: The main Writer workspace in Print Layout view
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Changing document views
Writer has several ways to view a document: Print Layout, Web Layout, Full Screen, and
Zoom. To access these choices, go to the View menu. The only document view option with a
submenu is Zoom.

Creating a new document
You can create a new, blank document in Writer in several ways:
•

Press the Control+N keys. A new empty document opens. If you already have a
document open, the new document appears in a new window.

•

Use File > New > Text Document. The result is the same as pressing the Control+N
keys.

•

Click the New button on the main toolbar

.

Creating a document from a template
You can use templates to create new documents in Writer. Templates serve as the foundation
of a series of documents, making sure they all have a similar layout. For example, all the
chapters in this book are based on the same template. By doing this, all the chapters look
alike; they have the same headers and footers, use the same fonts, and so on.
Unfortunately, a brand-new OpenOffice.org installation does not contain many templates. It is
possible to add new templates to your installation and use them for new documents. This is
explained in Chapter 12 (Working with Templates). Many more templates can be
downloaded from the Internet.
Once you have templates on your system, you can create new documents based on them by
using File > New > Templates and Documents. This opens a window where you can choose
the template you want to use for your document.
The example shown in Figure 54 uses a template called “book” in the My Templates folder.
Select it, then click Open. A new document is created based on the formats defined in the
template.
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Figure 54. Creating a document from a template

Saving a document
Save Writer documents the same way you save other documents. For more information, see
Chapter 3 (File Management in OpenOffice.org).

Saving as a Microsoft Word document
You may need to share your documents with other people who do not use OOo, but use
Microsoft Word instead. Most versions of Microsoft Word cannot read or write OOo files,
although filters are becoming available. Fortunately, OOo can read and write Word files. To
save a document as a Microsoft Word file:
1) First save your document in OOo’s format (.odt). If you do not, any changes you made
since the last time you saved will only appear in the Microsoft Word version of the
document.
2) Then click File > Save As. The Save As window (Figure 55) appears.
3) In the Save as type drop-down menu, select the type of Word format you need. Click
Save.
From this point on, all changes you make to the document will occur only in the Microsoft
Word document. You have actually changed the name of your document. If you want to go
back to working with the OOo version of your document, you must open it again.
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Tip

To have OOo save documents by default in the Microsoft Word file format, go to
Tools > Options > Load/Save. In the section named Default file format, under
Document Type, select Text Document, then under Always save as, select the
preferred file format. See also “Choosing options for loading and saving documents”
in Chapter 5 (Setting up OpenOffice.org).

Figure 55. Saving a file in Microsoft Word format

Working with text
Working with text (selecting, copying, pasting, moving) in Writer is similar to working with
text in any other program. OOo also has some convenient ways to select items that are not
next to each other, move paragraphs quickly, and paste unformatted text.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 56) using the mouse:
1) Select the first piece of text.
2) Hold down the Control key and use the mouse to select the next piece of text.
3) Repeat as often as needed.
4) Now you can work with the selected text (copy it, delete it, change the style, or
whatever).
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Note

Macintosh users: substitute the Command key when instructions in this chapter say
to use the Control key.

To select nonconsecutive items using the keyboard:
1) Select the first piece of text. (For more information about keyboard selection of text,
see the topic “Navigating and selecting with the keyboard” in the Help.)
2) Press Shift+F8. This puts Writer in “ADD” mode. The word ADD appears on the
status bar.
3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold
down the Shift key and select the next piece of text.
4) Repeat as often as needed.
5) Now you can work with the selected text.
6) Press Esc to exit from this mode.

Figure 56: Selecting items that are not next to each other

Cutting, copying, and pasting text
Cutting and copying text in Writer is similar to cutting and copying text in other applications.
You can use the mouse or the keyboard for these operations.
Cut: Use Edit > Cut or the keyboard shortcut Control+X or the Cut icon on the
toolbar.
Copy: Use Edit > Copy or the keyboard shortcut Control+C or the Copy icon.
Paste: Use Edit > Paste or the keyboard shortcut Control+V or the Paste icon.
If you simply click on the Paste icon, any formatting the text has (such as bold or italics) is
retained. To make the pasted text take on the formatting of the surrounding text where it is
being pasted, click the triangle to the right of the Paste icon and select Unformatted text
from the menu (Figure 57).
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Figure 57: Paste menu

Moving paragraphs quickly
1) Put the cursor anywhere in the paragraph.
2) Press and hold the Control key and then press the up-arrow or down-arrow key.
The paragraph will move to before the previous paragraph or after the next paragraph in your
document. To move more than one paragraph at a time, select at least part of both paragraphs
before pressing the Control+arrow keys.
If you are using the Solaris operating system, the key combination is Control+AltGr+arrow
keys.
Tip

If your paragraphs suddenly jump from one place to another, the most likely reason
is that you have accidentally pressed one of these key combinations.

Finding and replacing text and formatting
Writer has a Find and Replace feature that automates the process of searching for text inside a
document. In addition to finding and replacing words and phrases, you can:
•

Use regular expressions (wildcards) to fine-tune a search (see the Help for details).

•

Find and replace specific formatting (see the Writer Guide for more information).

•

Find and replace paragraph styles (see the Writer Guide for more information).

To display the Find & Replace dialog (Figure 58), use the keyboard shortcut Control+F or
select Edit > Find & Replace.
1) Type the text you want to find in the Search for box.
2) To replace the text with different text, type the new text in the Replace with box.
3) You can select various options such as matching the case, matching whole words only,
or doing a search for similar words. See below for some other choices.
4) When you have set up your search, click Find. To replace text, click Replace instead.
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Figure 58: Expanded Find & Replace dialog
Tip

Caution

If you click Find All, OOo selects all instances of the search text in the document.
Similarly, if you click Replace All, OOo will replace all matches.
Use Replace All with caution; otherwise, you may end up with some hilarious (and
highly embarrassing) mistakes. A mistake with Replace All might require a manual,
word by word, search to fix.

Inserting special characters
A “special” character is one not found on a standard English keyboard. For example, © ¾ æ ç
ñ ö ø ¢ are all special characters. To insert a special character:
1) Place the cursor where you want the character to appear.
2) Click Insert > Special Character to open the Special Characters window (Figure 59).
3) Select the characters you wish to insert, in order, then click OK. The selected
characters are shown in the lower left of the dialog. As you select a character, it is
shown on the lower right, along with its numerical code.
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Note

Different fonts include different special characters. If you do not find a particular
special character, try changing the Font selection.

Figure 59: The Special Characters window, where you can insert special characters.
Tips

Notice that the characters selected appear in the bottom-left corner of the window.

Setting tab stops and indents
The horizontal ruler shows both the default tab stops and any that you have defined. To set
the measurement unit and the spacing of default tab stops, go to Tools > Options >
OpenOffice.org Writer > General.
You can also set or change the measurement unit by right-clicking on the ruler to open a list
of units, as shown in Figure 60. Click on one of them to change the ruler to that unit.

Figure 60: Ruler showing default tab stops
Double-click on a part of the ruler that is not between the left and right indent icons to open
the Indents & Spacing page of the Paragraph dialog. To fine-tune tab stop settings, doubleclick anywhere between the left and right indent icons on the ruler itself to open the Tabs
page of the Paragraph dialog.
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Checking spelling
Writer provides a spelling checker, which can be used in two ways.
AutoSpellcheck checks each word as it is typed and displays a wavy red line under any
misspelled words. Once the word is corrected, the line disappears.
To perform a separate spelling check on the document (or a text selection), click the
Spellcheck button. This checks the document or selection and opens the Spellcheck
dialog if any misspelled words are found.
Here are some more features of the spelling checker:
•

You can change the dictionary language (for example, to Spanish, French or German)
on the Spellcheck dialog.

•

You can add a word to the dictionary. Click Add in the Spellcheck dialog and pick the
dictionary to add it to.

•

•

The Options dialog of the Spellcheck tool has a number of different options such as
whether to check uppercase words and words with numbers. It also allows you to
manage custom dictionaries, that is, add or delete dictionaries, and add or delete words
in a dictionary.
On the Font page of the Paragraph Styles dialog, you can set paragraphs to be checked
in a specific language (different from the rest of the document). See Chapter 7
(Working with Styles) in the Writer Guide for more information.

Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings and typing errors,
which it corrects automatically. For example, “hte” will be changed to “the”. Select Tools >
AutoCorrect to open the AutoCorrect dialog. There you can define which strings of text are
corrected and how. In most cases, the defaults are fine.
Tip

•

To stop Writer from replacing a specific spelling, use Tools > AutoCorrect >
Replace, highlight the word pair and click Delete.

•

To add a new spelling to correct, type it into the Replace and With boxes and click
New.

•

See the different pages of the dialog box for the wide variety of other options available
to fine-tune AutoCorrect.

Tip
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AutoCorrect is turned on by default. To turn it off, uncheck Format > AutoFormat
> While Typing.

AutoCorrect can be used as a quick way to insert special characters. For example,
(c) will be autocorrected to ©. You can add your own special characters.
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Using word completion
If Word Completion is enabled, Writer tries to guess which word you are typing and offers to
complete the word for you. To accept the suggestion, press Enter. Otherwise continue typing.
Tip

Many people prefer not to use Word Completion. If you do not want to use it, select
Tools > AutoCorrect > Word Completion and uncheck Enable Word Completion.

You can customize word completion from the Tools > AutoCorrect > Word Completion
page:
•

Add (append) a space automatically after an accepted word.

•

Show the suggested word as a tip (hovering over the word) rather than completing the
text as you type.

•

Change the maximum number of words remembered for word completion and the
length of the smallest words to be remembered.

•

Delete specific entries from the word completion list.

•

Change the key that accepts a suggested entry—the options are Right arrow, End key,
Return (Enter), and Space bar.

Note

Automatic word completion only occurs after you type a word for the second time
in a document.

Using AutoText
AutoText allows you to assign text, tables, graphics and other items to a key combination.
For example, rather than typing “Senior Management” every time you use that phrase, you
might just type “sm” and press F3. Or you can save a formatted Note (like the one on this
page) as AutoText and then insert a copy by typing “note” and pressing F3.
To assign some text to an AutoText shortcut:
1) Type the text into your document.
2) Select the text so it is highlighted.
3) Select Edit > AutoText (or press Control+F3).
4) Enter a name for your shortcut. Writer will suggest a one-letter shortcut, which you
can change.
5) Click the AutoText button on the right and select New (text only) from the menu.
6) Click Close to return to your document.
Tip

If the only option under the AutoText button is Import, either you have not entered
a name for your AutoText or there is no text selected in the document.
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AutoText is especially powerful when assigned to fields. See Chapter 14 (Working with
Fields) in the Writer Guide for more information.

Inserting dashes and non-breaking spaces
You can insert a dash by using the Special Characters window or by using AutoCorrect. For
more about AutoCorrect, see “Controlling OOO’s AutoCorrect functions” in Chapter 5
(Setting up OpenOffice.org) and “Using AutoCorrect” on page 82 in this chapter.
–

is an en-dash; that is, a dash the width of the letter “n” in the font you are using. It is
U+2013 (scroll down to the General Punctuation section in the Special Characters
window). To enter an en-dash using AutoCorrect, type at least one character, a space, two
hyphens, another space, and at least one more letter, then a space. The two hyphens will
be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. It is
U+2014. To enter it using AutoCorrect, type at least one character, two hyphens, and at
least one more character, then a space. The two hyphens will be replaced by an em-dash.
To insert a non-breaking space (to keep characters together, for example in a telephone
number), press Control+Space on the keyboard.

Formatting text
Using styles
Styles are central to using Writer efficiently. Styles enable you to easily format your
document consistently, and to change the format with minimal effort. A style is a named set
of formatting options. Writer defines several types of styles, for different types of elements:
characters, paragraphs, pages, frames, and lists. For information on the advantages of styles,
and how to use them, see Chapter 13 (Working with Styles) in this book The use of styles is
described in detail in Chapter 6 (Introduction to Styles) and Chapter 7 (Working with Styles)
in the Writer Guide.

Formatting paragraphs
You can apply many formats to paragraphs using the buttons on the Formatting toolbar.
Figure 61 shows the Formatting toolbar as a floating toolbar, customized to show only the
buttons for paragraph formatting.
Tip
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It is highly recommended that you use paragraph styles rather than manually
formatting paragraphs, especially for long or standardized documents.
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1

2

3 4

1 Open Styles and
Formatting window
2 Apply Style
3 Align Left
4 Centered

5
6
7
8
9

5

6

7

8 9

Align Right
Justified
Line Spacing: 1
Line Spacing: 1.5
Line Spacing: 2

10 11 12 13 14

10
11
12
13
14

Numbering On/Off
Bullets On/Off
Decrease Indent
Increase Indent
Paragraph format dialog

Figure 61: Formatting toolbar, showing buttons for paragraph formatting
Figure 62 shows examples of the different alignment options.

Figure 62: Different text alignment options

Formatting characters
You can apply many formats to characters using the buttons on the Formatting toolbar. Figure
63 shows the Formatting toolbar as a floating toolbar, customized to show only the buttons
for character formatting.
Tip

1

It is highly recommended that you use character styles rather than manually
formatting characters.

2

3

1 Open Styles and
Formatting window
2 Apply Style
3 Font Name
4 Font Size

5 Bold
6 Italic
7 Underline
8 Superscript
9 Subscript

4

5

6 7

8

9

10 Increase Font
11 Reduce Font
12 Font Color
13 Highlighting
14 Background Color

10 11

12

13

14

15

15 Open Character
Format dialog

Figure 63: The Formatting toolbar, showing buttons for character formatting
Tip

To remove manual formatting, select the text and click Format > Default
Formatting, or right-click and select Default Formatting from the pop-up menu.
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Autoformatting
You can set Writer to automatically format parts of a document according to the choices made
on the Options page of the AutoCorrect dialog (Tools > AutoCorrect > Options).
Tip

If you notice unexpected formatting changes occurring in your document, this is the
first place to look for the cause.

Some common unwanted or unexpected formatting changes include:
•

•

Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal
signs (===) on a line and then press Enter, the paragraph is replaced by a horizontal
line as wide as the page. The line is actually the lower border of the preceding
paragraph.
Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star
(*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A
numbered list is created when you type a number followed by a period (.), followed by
a space or tab at the beginning of a paragraph. Automatic numbering is only applied to
paragraphs formatted with the Default, Text body or Text body indent paragraph styles.

To turn autoformatting on or off, go to Format > AutoFormat and select or delete the items
on the submenu.

Creating numbered or bulleted lists
There are several ways to create numbered or bulleted lists:
•

Use autoformatting, as described above.

•

Use list (numbering) styles, as described in Chapter 7 (Working with Styles) in the
Writer Guide.

•

Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure
61). This method is described here.

To produce a numbered or bulleted list, select the paragraphs in the list, and then click the
appropriate icon on the toolbar.
Note

It is a matter of personal preference whether you type your information first, then
apply Numbering/Bullets, or apply them as you type.

Using the Bullets and Numbering toolbar

You can create nested lists (where one or more list items has a sublist under it, as in an
outline) by using the buttons on the Bullets and Numbering toolbar (Figure 64). You can
move items up or down the list, or create subpoints, and even change the style of bullets. Use
View > Toolbars > Bullets and Numbering to see the toolbar.
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1

1
2
3
4
5
6
7

2

3

4

5

6

7

8

Bullets On/Off
Numbering On/Off
Numbering Off
Up One Level
Down One Level
Move Up (One Level) with Subpoints
Move Down (One Level) with Subpoints

9 10 11 12 13 14

8
9
10
11
12
13
14

Insert Unnumbered Entry
Move Up
Move Down
Move Up with Subpoints
Move Down with Subpoints
Restart Numbering
Bullets and Numbering

Figure 64: Bullets and Numbering toolbar

Hyphenating words
To turn automatic hyphenation of words on or off:
1) Press F11 to open the Styles and Formatting window (Figure 65).
2) On the Paragraph Styles page of the Styles and Formatting window, right-click on
Default in the list and select Modify.

Figure 65: Modifying the Default style
3) On the Paragraph Style dialog, go to the Text Flow page (see Figure 66).
4) Under Hyphenation, select or deselect the Automatically checkbox. Click OK to
save.
Note

Turning on hyphenation for the Default paragraph style affects all other paragraph
styles that are based on Default. You can individually change other styles so that
hyphenation is not active; for example, you might not want headings to be
hyphenated. Any styles that are not based on Default are not affected.
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Figure 66: Turning on automatic hyphenation
You can also set hyphenation choices through Tools > Options > Language Settings >
Writing Aids. In Options, near the bottom of the dialog, scroll down to the find the
hyphenation settings (see Figure 67).

Figure 67: Setting hyphenation options
Notes

Hyphenation options set on the Writing Aids dialog are effective only if
hyphenation is turned on through paragraph styles.
Choices on the Writing Aids dialog for “characters before line break” and
“characters after line break” override settings in paragraphs styles for “characters at
line end” and “characters at line begin”. This is a bug.

To enter a conditional hyphen inside a word, press Control+minus sign. The word is
hyphenated at this position when it is at the end of the line, even if automatic hyphenation for
this paragraph is switched off.
To insert a non-breaking hyphen, press Control+Shift+minus sign.

Undoing and redoing changes
To undo the most recent change, press Control+Z, or click the Undo icon
Standard toolbar, or select Edit > Undo from the menu bar.

on the

The Edit menu shows the latest change that can be undone, as shown in Figure 68.
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Figure 68: Edit > Undo last action
Click the small triangle to the right of the Undo icon to get a list of all the changes that can
be undone (Figure 69). You can select multiple changes and undo them at the same time.

Figure 69: List of actions that can be undone
After changes have been undone, Redo becomes active. To redo a change, select Edit >
Redo, or press Control+Y or click on the Redo icon
. As with Undo, click on the
triangle to the right of the arrow to get a list of the changes that can be reapplied.
To modify the number of changes OpenOffice.org remembers, select Tools > Options >
OpenOffice.org > Memory and change Undo number of steps. Be aware that asking OOo
to remember more changes consumes more computer memory.

Tracking changes to a document
You can use several methods to keep track of changes made to a document.
1) Make your changes to a copy of the document (stored in a different folder, or under a
different name, or both), then use Writer to combine the two files and show the
differences. Click Edit > Compare Document. This technique is particularly useful if
you are the only person working on the document, as it avoids the increase in file size
and complexity caused by the other methods.
2) Save versions that are stored as part of the original file. However, this method can
cause problems with documents of non-trivial size or complexity, especially if you
save a lot of versions. Avoid this method if you can.
3) Use Writer’s change marks (often called “redlines” or “revision marks”) to show
where you have added or deleted material, or changed formatting. Later, you or
another person can review and accept or reject each change.
Tip

Not all changes are recorded. For example, changing a tab stop from align left to
align right, and changes in formulas (equations) or linked graphics are not recorded.
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Recording changes
See Chapter 2 (Setting up Writer) in the Writer Guide for instructions on setting up how
changes will be displayed.
1) To begin tracking (recording) changes, click Edit > Changes > Record.
To show or hide the display of changes, click Edit > Changes > Show.
Tip

Hover the mouse pointer over a marked change; you will see a Help Tip showing the
type of change, the author, date, and time of day for the change. If Extended Tips are
enabled, you will also see any comments recorded for this change.

2) To enter a comment on a marked change, place the cursor in the area of the change and
then click Edit > Changes > Comment. (See Figure 70.) In addition to being
displayed as an extended tip, the comment is also displayed in the list in the Accept or
Reject Changes dialog.
You can move from one marked change to the next by using the arrow buttons. If no
comment has been recorded for a change, the Text field is blank.
3) To stop recording changes, click Edit > Changes > Record again.

Figure 70: Inserting a comment during change recording

Inserting notes
To insert a note that is not associated with a recorded change:
1) Place the cursor at the text you want to comment on, then click Insert > Note.
2) On the Insert Note dialog (Figure 71), type your note. Click Author to insert your
initials and the date and time.
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Figure 71: Inserting a note
To view a note, move the mouse pointer over the note marker (displayed as a small yellow
rectangle). Writer displays the note in a Tip above the text. You can also double-click on the
note to see it inside the Edit Note dialog. If you have trouble viewing or selecting notes this
way, you can use the Navigator instead: expand the list of notes, select the one you want,
right-click on it, and select Edit to display the Edit Note dialog.
The Edit Note dialog looks much like the Insert Note dialog, with the addition of forward and
back arrow buttons if the document contains more than one note.
Tip

You can change the color of the note marker using the Tools > Options >
OpenOffice.org > Appearance dialog.

Accepting or rejecting changes and comments
1) Click Edit > Changes > Accept or Reject. The Accept or Reject Changes dialog
(Figure 72) opens.
2) When you select a change in the dialog, the actual text is highlighted in the document,
so you can see what the editor changed.
3) Click Accept or Reject to accept or reject the selected change. You can also click
Accept All or Reject All if you do not want to review the changes individually.
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Figure 72: The List tab of the Accept or Reject Changes dialog
Changes that have not yet been accepted or rejected are displayed in the list. Accepted
changes are removed from the list and appear in the text without any marking.
To show only the changes of certain people, or only the changes made on specific days, or
various other restrictions, use the Filter tab on the Accept or Reject Changes dialog. After
specifying the filter criteria, return to the List tab to see those changes that meet your criteria.

Formatting pages
Writer provides several ways for you to control page layouts:
•

Page styles

•

Columns

•

Frames

•

Tables

•

Sections

For more information, see Chapter 4 (Formatting Pages) in the Writer Guide.
Tip
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Page layout is usually easier if you show text, object, table, and section boundaries
in Tools > Options > OpenOffice.org > Appearance, and paragraph ends, tabs,
breaks, and other items in Tools > Options > OpenOffice.org Writer >
Formatting Aids.
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Which layout method to choose?
The best layout method varies depending on what the final document should look like and
what sort of information will be in the document. Here are some examples.
For a book similar to this user guide, with
one column of text, some figures without
text beside them, and some other figures
with descriptive text, use page styles for
basic layout, and tables to place figures
beside descriptive text when necessary.

For an index or other document with two
columns of text, where the text continues
from the left-hand column to the right-hand
column and then to the next page, all in
sequence (also known as “snaking columns”
of text), use page styles (with two columns).
If the title of the document (on the first
page) is full-page width, put it in a singlecolumn section.
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Items
formated
as a table

Title is in
a singlecolumn
section

Basic
layout is
in two
columns
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For a newsletter with complex layout, two
or three columns on the page, and some
articles that continue from one page to some
place several pages later, use page styles for
basic layout. Place articles in linked frames
and anchor graphics to fixed positions on
the page if necessary.

This is a
header on
the first
page only
This frame
is linked to
a frame on
another
page
These
frames are
not linked
to other
frames

For a document with terms and translations
to appear side-by-side in what appear to be
columns, use a table to keep items lined up,
and so you can type in both “columns”.
This is a
borderless
table.
Each pair of
words is in a
separate
row, and
each word is
in a cell of
the table.

Creating headers and footers
A header is an area that appears at the top of a page. A footer appears at the bottom of the
page. Information, such as page numbers inserted into a header or footer, displays on every
page of the document with that page style.
To insert a header, click Insert > Header > Default (or the page style, if not Default) as
shown in Figure 73.
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Figure 73: Inserting headers and footers
Other information such as document titles and chapter titles is often put into the header or
footer. These items are best added as fields. That way, if something changes, the headers and
footers are updated automatically. Here is one common example.
To insert the document title into the header:
1) Click File > Properties > Description and enter a title for your document.
2) Add a header (Insert > Header > Default).
3) Place the cursor in the header part of the page.
4) Select Insert > Fields > Title. The title should appear on a gray background (which
does not show when printed and can be turned off).
5) To change the title for the whole document, go back to File > Properties >
Description.
Fields are covered in detail in Chapter 14 (Working with Fields) in the Writer Guide.
For more about headers and footers, see Chapter 4 (Formatting Pages) and Chapter 6
(Introduction to Styles) in the Writer Guide.

Numbering pages
To automatically number pages:
1) Insert a header or footer, as described in “Creating headers and footers” on page 94.
2) Place the cursor in the header or footer where you want the page number to appear and
click Insert > Fields > Page Number.

Including the total number of pages
To include the total number of pages (as in “page 1 of 12”):
1) Type the word “page” and a space, then insert the page number as above
2) Press the spacebar once, type the word “of” and a space, then click Insert > Fields >
Page Count.
Chapter 6 Getting Started with Writer

95

Numbering pages

Note

The Page Count field inserts the total number of pages in the document, as shown
on the Statistics page of the document’s Properties window (File > Properties). If
you restart page numbering anywhere in the document, then the total page count
may not be what you want. See Chapter 4 (Formatting Pages) in the Writer Guide
for more information.

Restarting page numbering
Often you will want to restart the page numbering at 1, for example on the page following a
title page or a table of contents. In addition, many documents have the “front matter” (such as
the table of contents) numbered with Roman numerals and the main body of the document
numbered in Arabic numerals, starting with 1.
You can restart page numbering in two ways.
Method 1 (recommended):
1) Place the cursor in the first paragraph of the new page.
2) Click Format > Paragraph.
3) On the Text Flow page of the Paragraph dialog (Figure 66 on page 88), in the Breaks
section, select Insert and then With Page Style and specify the page style to use.
4) Specify the page number to start from, and then click OK.
Tip

Method 1 is also useful for numbering the first page of a document with a page
number greater than 1. For example, you may be writing a book, with each chapter
in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with
page 25 and Chapter 3 with page 51.

Method 2:
1) Insert > Manual break.
2) By default, Page break is selected on the Insert Break dialog (Figure 74).

Figure 74: Restarting page numbering after a manual page break
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3) Choose the required page Style.
4) Select Change page number.
5) Specify the page number to start from, and then click OK.

Changing page margins
You can change page margins in two ways:
•

Using the page rulers—quick and easy, but does not have fine control.

•

Using the Page Style dialog—can specify margins to two decimal places.

Note

If you change the margins using the rulers, the new margins affect the page style and
will be shown in the Page Style dialog the next time you open it.

To change margins using the rulers:
1) The gray sections of the rulers are the margins (see Figure 75). Put the mouse cursor
over the line between the gray and white sections. The pointer turns into a doubleheaded arrow.
2) Hold down the left mouse button and drag the mouse to move the margin.

Figure 75: Moving the margins
Tip

The small arrows on the ruler are used for indenting paragraphs. They are often in the
same place as the page margins, so you need to be careful to move the margin marker,
not the arrows. Place the mouse pointer between the arrows and, when the pointer
turns into a double-headed arrow, you can move the margin (the indent arrows will
move with it).

To change margins using the Page Style dialog:
1) Right-click anywhere on the page and select Page from the pop-up menu.
2) On the Page page of the dialog, type the required distances in the Margins boxes.

Chapter 6 Getting Started with Writer

97

Getting Started Guide

Chapter 7
Getting Started with Calc
OpenOffice.org's Spreadsheet

What is Calc?

What is Calc?
Calc is the spreadsheet component of OpenOffice.org (OOo). You can enter data, usually
numerical data, in a spreadsheet and then manipulate this data to produce certain results.
Alternatively you can enter data and then use Calc in a ‘What If...’ manner by changing some
of the data and observing the results without having to retype the entire spreadsheet or sheet.

Spreadsheets, sheets, and cells
Calc works with elements called spreadsheets. Spreadsheets consist of a number of
individual sheets, each containing a block of cells arranged in rows and columns.
These cells hold the individual elements—text, numbers, formulas etc.—which make up the
data to be displayed and manipulated.
Each spreadsheet can have many sheets and each sheet can have many individual cells. Each
sheet in Calc can have a maximum of 65,536 rows and a maximum of 245 columns (A
through IV). This gives 16,056,320 individual cells per sheet.

Parts of the main Calc window
When Calc is started, the main window looks similar to .
Menu Bar

Formatting
Toolbar
Active Cell

Title Bar

Standard Toolbar

Formula Bar
Column Headers

Active Cell
Indicator
Row Headers

Figure 76: Parts of the Calc window
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Formula bar
On the left of the Formula bar (see Figure 77) is a small text box, called the Name box, with
a letter and number combination in it, such as D7. This is the column letter and row number,
called the cell reference, of the current cell.

Function Wizard
Function Button

Name box

Sum Button

Figure 77. Formula Bar
To the right of the Name box are the Function Wizard, Sum, and Function buttons.
Clicking the Function Wizard button opens a dialog from which you can search through a
list of available functions. This can be very useful, because it also shows how the functions
are formatted.
The Sum button inserts a formula into the current cell that totals the numbers in the cells
above, or to the left if there are no numbers above, the current cell.
The Function button inserts an equals sign into the selected cell and the Input Line, thereby
setting the cell ready to accept a formula.
When you enter data into a cell, the Sum and Equals buttons change to Cancel and Accept
buttons
.
The contents of the current cell (data, formula, or function) are displayed in the Input Line,
the remainder of the Formula bar. You can edit the cell contents of the current cell in the
Input Line, or you can do that in the current cell. To edit inside the Input Line area, left-click
the appropriate part of the Input Line area, then type your changes. To edit within the current
cell, double-click the cell.

Individual cells
The main section of the screen displays the individual cells in the form of a grid, with each
cell being at the intersection of a particular column and row.
At the top of the columns and at the left-hand end of the rows are a series of gray boxes
containing letters and numbers. These are the column and row headers. The columns start at
A and go on to the right and the rows start at 1 and go on down.
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Sheet tabs
At the bottom of the grid of cells are the sheet tabs (see Figure 78). These tabs enable access
to each individual sheet, with the visible, or active, sheet having a white tab.
Clicking on another sheet tab displays that sheet and its tab turns white. You can also select
multiple sheet tabs at once by holding down the Control key while you click the names.

Figure 78. Sheet tabs

File management
Starting new spreadsheets
A new spreadsheet can be opened regardless of which other component of OOo you are using
at the time. For example, a new spreadsheet can be opened from Writer or Draw.
•
•

•

From the menu bar—Click File and then select New > Spreadsheet.
From the toolbar—Use the New Document
button on the Standard toolbar.
Click the drop-down arrow for a choice of what type of document to open (text
document, spreadsheet, and so on). Click the button itself to create a new document of
the type that is currently open (if a spreadsheet is open, a new spreadsheet document
will be created).
From the keyboard—If you already have a spreadsheet open, you can press Control+N
to open a new spreadsheet.

Opening existing spreadsheets
A spreadsheet can also be opened no matter what component of OOo you are in.
•

From the menu bar—Click File and then select Open.

•

From the toolbar—Click the Open button

•

From the keyboard—Use the key combination Control+O.

on the Standard toolbar.

Each of these options displays the Open dialog, where you can locate the spreadsheet that you
want to open.

Saving spreadsheets
Spreadsheets can be saved in three ways.
•
102

From the menu bar—Click File and then select Save.
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•

From the toolbar—Click on the Save button

on the Function bar.

•

From the keyboard—Use the key combination Control+S.

If the spreadsheet has not been saved previously, then each of these actions will open the
Save As dialog. Here you can specify the spreadsheet name and the location in which to save
the spreadsheet.

Navigating within spreadsheets
Going to a particular cell
Using the mouse

Place the mouse pointer over the cell and left-click.
Using a cell reference

Click on the little inverted black triangle just to the right of the Name box (Figure 77). The
existing cell reference will be highlighted. Type the cell reference of the cell you want to go
to and press Enter. Or just click into the Name box, backspace over the existing cell reference
and type in the cell reference you want.
Using the Navigator

Click on the Navigator button
in the Standard toolbar (or press F5) to display the
Navigator. Type the cell reference into the top two fields, labeled Column and Row, and press
Enter. In Figure 79 the Navigator would select cell F5.

Figure 79. Calc Navigator
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Moving from cell to cell
In the spreadsheet, one cell, or a group of cells, normally has a darker black border. This
black border indicates where the focus is (see Figure 80).

Figure 80. (Left) One selected cell and (right) a group of selected cells
Using the Tab and Enter keys
•

Pressing Enter or Shift+Enter moves the focus down or up, respectively.

•

Pressing Tab or Shift+Tab moves the focus right or left, respectively.

Using the cursor keys

Pressing the cursor keys on the keyboard moves the focus in the direction of the arrows.
Using Home, End, Page Up and Page Down
•

Home moves the focus to the start of a row.

•

End moves the focus to the column furthest to the right that contains data.

•

Page Down moves the display down one complete screen and Page Up moves the
display up one complete screen.

•

Combinations of Control and Alt with Home, End, Page Down, Page Up, and the
cursor keys move the focus of the current cell in other ways.

Tip
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Holding down Alt+Cursor key resizes a cell.
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Moving from sheet to sheet
Each sheet in a spreadsheet is independent of the others though they can be linked with
references from one sheet to another. There are three ways to navigate between different
sheets in a spreadsheet.
Using the keyboard

Pressing Control+PgDn moves one sheet to the right and pressing Control+PgUp moves one
sheet to the left.
Using the mouse

Clicking one of the Sheet Tabs (see Figure 78) at the bottom of the spreadsheet selects that
sheet.
If you have a lot of sheets, then some of the sheet tabs may be hidden behind the horizontal
scroll bar at the bottom of the screen. If this is the case, then the four buttons at the left of the
sheet tabs can move the tabs into view. Figure 81 shows how to do this.
Move to the first sheet
Move left one sheet
Move right one sheet
Move to the last sheet
Sheet tabs

Figure 81. Sheet tab arrows
Notice that the sheets here are not numbered in order. Sheet numbering is arbitrary – you can
name a sheet as you wish.
Note

The sheet tab arrows that appear in Figure 81 only appear if you have some sheet
tabs that can not be seen. Otherwise they will appear faded as in Figure 78.

Selecting items in a sheet or spreadsheet
Selecting cells
Cells can be selected in a variety of combinations and quantities.
Single cell

Left-click in the cell. The result will look like the left side of Figure 80. You can verify your
selection by looking in the Name box.
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Range of contiguous cells

A range of cells can be selected using the keyboard or the mouse.
To select a range of cells by dragging the mouse:
3) Click in a cell.
4) Press and hold down the left mouse button.
5) Move the mouse around the screen.
6) Once the desired block of cells is highlighted, release the left mouse button.
To select a range of cells without dragging the mouse:
1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.
To select a range of cells without using the mouse:
1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select the rest of the range.
The result of any of these methods will look like the right side of Figure 80.
Tip

You can also directly select a range of cells using the Name box. Click into the
Name box as described in “Using a cell reference” on page 103. To select a range of
cells, enter the cell reference for the upper left hand cell, followed by a colon (:),
and then the lower right hand cell reference. For example, to select the range that
would go from A3 to C6, you would enter A3:C6.

Range of non-contiguous cells

1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.
3) Hold down the Control key and click or click-and-drag to select a range.
4) Repeat as necessary.

Selecting columns and rows
Entire columns and rows can be selected very quickly in OOo.
Single column or row

To select a single column, click on the column identifier letter (see Figure 76).
To select a single row, click on the row identifier number (see Figure 76).
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Multiple columns or rows

To select multiple columns or rows that are contiguous:
1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.
To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Control key.
3) Click on all of the subsequent columns or rows while holding down the Control key.
Entire sheet

To select the entire sheet, click on the small box between the A column header and the 1 row
header. You can also use the keyboard to select the entire sheet by pressing Control+A.

Select All

Figure 82. Select All box

Working with columns and rows
Inserting columns and rows
Columns and rows can be inserted in several different way and quantities.
Single column or row

A single column or row can be added using the Insert menu:
1) Select the column or rows where you want the new column or row inserted.
2) Select either Insert > Column or Insert > Row.
Note

When you insert a single new column, it is inserted to the left of the highlighted
column. When you insert a single new row, it is inserted above the highlighted row.

A single column or row can also be added using the mouse:
1) Select the column or row where you want the new column or row inserted.
2) Right-click the header.
3) Select Insert Row or Insert Column.
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Multiple columns or rows

Multiple columns or rows can be inserted at once rather than inserting them one at a time.
1) Highlight the required number of columns or rows by holding down the left mouse
button on the first one and then dragging across the required number of identifiers.
2) Proceed as for inserting a single column or row above.

Deleting columns and rows
Columns and rows can be deleted individually or in groups.
Single column or row

A single column or row can only be deleted by using the mouse:
1) Select the column or row to be deleted.
2) Right-click on the column or row header.
3) Select Delete Column or Delete Row from the pop-up menu.
Multiple columns or rows

Multiple columns or rows can be deleted at once rather than deleting them one at a time.
1) Highlight the required number of columns or rows by holding down the left mouse
button on the first one and then dragging across the required number of identifiers.
2) Proceed as for deleting a single column or row above.

Working with sheets
Like any other Calc element, sheets can be inserted, deleted and renamed.

Inserting new sheets
There are many ways to insert a new sheet. The first step for all of the methods is to select the
sheets that the new sheet will be inserted next to. Then any of the following options can be
used.
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•

Click on the Insert menu and select Sheet, or

•

Right-click on its tab and select Insert Sheet, or

•

Click into an empty space at the end of the line of sheet tabs (see Figure 83).
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Click here to insert
a new sheet

Figure 83. Inserting a new sheet
Each method will open the Insert Sheet dialog (Figure 84). Here you can select whether the
new sheet is to go before or after the selected sheet and how many sheets you want to insert.
If you are inserting only one sheet, there is the opportunity to give the sheet a name.

Figure 84. Insert Sheet dialog

Deleting sheets
Sheets can be deleted individually or in groups.
Single sheet

Right-click on the tab of the sheet you want to delete and select Delete from the pop-up
menu.
Multiple sheets

To delete multiple sheets, select them as described earlier, right-click on one of the tabs and
select Delete from the pop-up menu.
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Renaming sheets
The default name for the a new sheet is “SheetX”, where X is a number. While this works for
a small spreadsheet with only a few sheets, it becomes awkward when there are many sheets.
To give a sheet a more meaningful name, you can:
•

Enter the name in the name box when you create the sheet, or

•

Right-click on a sheet tab and select Rename Sheet from the pop-up menu and replace
the existing name with a better one.

Note

Sheet names must start with either a letter or a number; other characters including
spaces are not allowed. Aside from the first character of the sheet name, allowed
characters are letters, numbers, spaces, and the underline character. Attempting to
rename a sheet with an invalid name will produce an error message.

Viewing Calc
Freezing rows and columns
Freezing locks a number of rows at the top of a sheet or a number of columns on the left of a
sheet or both. Then when scrolling around within the sheet, any frozen columns and rows
remain in view.
Figure 85 shows some frozen rows and columns. The heavier horizontal line between rows 3
and 14 and the heavier vertical line between columns C and H denote the frozen areas. Rows
4 through 13 and columns D through G have been scrolled off the page. Because the first
three rows and columns are frozen into place, they remained.
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Figure 85. Frozen rows and columns
You can set the freeze point at one row, one column, or both a row and a column as in Figure
85.
Freezing single rows or columns

1) Click on the header for the row below where you want the freeze or for the column to
the right of where you want the freeze.
2) Select Window > Freeze.
A dark line will appear to indicate where the freeze is put.
Freezing a row and a column

1) Click into the cell that is immediately below the row you want frozen and immediately
to the right of the column you want frozen.
2) Select Window > Freeze.
You will see two lines appear on the screen, a horizontal line above this cell and a vertical
line to the left of this cell. Now as you scroll around the screen everything above and to the
left of these lines will remain in view.
Unfreezing

To unfreeze rows or columns, select Window > Freeze. The checkmark by Freeze will
vanish.
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Splitting the window
Another way to change the view is by splitting the window—otherwise known as splitting the
screen. The screen can be split either horizontally or vertically or both. This allows you to
have up to four portions of the sheet in view at any one time.
Why would you want to do this? Imagine you have a large sheet and one of the cells has a
number in it which is used by three formulas in other cells. Using the split screen technique,
you can position the cell containing the number in one section and each of the cells with
formulas in the other sections. Then you can change the number in the cell and watch how it
affects each of the formulas.

Figure 86. Split screen example
Splitting the screen horizontally

To split the screen horizontally:
1) Move the mouse pointer into the vertical scroll bar, on the right-hand side of the
screen, and place it over the small button at the top with the black triangle.

Split screen bar

Figure 87. Split screen bar on vertical scroll bar
2) Immediately above this button you will see a thick black line (Figure 87). Move the
mouse pointer over this line and it will turn into a line with two arrows.
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3) Hold down the left mouse button and a grey line will appear, running across the page.
Drag the mouse downwards and this line will follow.
4) Release the mouse button and the screen will split into two views, each with its own
vertical scroll bar.
Notice in Figure 86, the ‘Beta’ and the ‘A0’ values are in the upper part of the window and
other calculations are in the lower part. You may scroll the upper and lower parts
independently. Thus you can make changes to the Beta and A0 values and watch their affects
on the calculations in the lower half of the window.
You can also split the window vertically as described below—with the same results, being
able to scroll both parts of the window independently. With both horizontal and vertical
splits, you have four independent windows to scroll.
Splitting the screen vertically

To split the screen vertically:
1) Move the mouse pointer into the horizontal scroll bar at the bottom of the screen and
place it over the small button on the right with the black triangle.

Split screen bar

Figure 88: Split bar on horizontal scroll bar
2) Immediately to the right of this button you will see a thick black line (Figure 88).
Move the mouse pointer over this line and it will turn into a line with two arrows.
3) Hold down the left mouse button and a grey line will appear, running up the page.
Drag the mouse to the left and this line will follow.
4) Release the mouse button and the screen will be split into two views, each with its
own horizontal scroll bar.
Note

Splitting the screen horizontally and vertically at the same time will give four
views, each with its own vertical and horizontal scroll bars.

Removing split views
•

Double-click on each split line, or

•

Click on and drag the split lines back to their places at the ends of the scroll bars, or

•

Select Window > Split. This will remove all split lines at the same time.

Tip

You can also split the screen using a menu command. Click in a cell that is
immediately below and immediately to the right of where you wish the screen to be
split, and choose Window > Split.
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Entering numbers
Select the cell and type in the number using either the top row of the keyboard or the numeric
keypad.
To enter a negative number, type a minus (–) sign in front of it or enclose it in brackets ( ).
By default numbers are right-aligned and negative numbers have a leading minus symbol.

Entering text
Select the cell and type the text. Text is left-aligned by default.

Entering numbers as text
If a number is entered in the format 01481, Calc will drop the leading 0. To preserve the
leading zero, in the case of telephone area codes for example, precede the number with an
apostrophe, like this: '01481. However, the data is now regarded as text by Calc. Formulas
and functions will treat the entry like any other text entry, which typically results in it being a
zero in a formula, and being ignored in a function.
Note

When entering an apostrophe to allow a leading zero to be displayed, the apostrophe
will not be visible in the cell after the Enter key is pressed only if the apostrophe is
a plain apostrophe (not a “smart quote” apostrophe). The type of apostrophe is
selected by choosing Tools > Autocorrect > Custom Quotes. The selection of the
apostrophe type will affect Calc and Writer. If “smart quotes” are selected for
apostrophes, the apostrophe will remain visible in the cell after pressing Enter.

Tip

Numbers can have leading zeros and be regarded as numbers (as opposed to text) if
the cell is formatted appropriately. Right-click on the cell and choose Format Cells
> Numbers. Adjust the leading zeros setting to add leading zeros to numbers.

Entering dates and times
Select the cell and type the date or time. You can separate the date elements with a slant (/) or
a hyphen (–) or use text such as 10 Oct 03. Calc recognizes a variety of date formats. You can
separate time elements with colons such as 10:43:45.
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Calc offers a powerful and highly configurable printing system. Many different details can be
selected to print or not to print. The order the sheets will print in can be specified, as well as
their size. Particular rows or columns can be specified to print on all sheets and the print
range can be specified.

Printing a spreadsheet
To print a spreadsheet either to a printer or a file, choose File > Print. The Print dialog
(Figure 89) allows printer settings to be changed. What to print can be set quickly here: the
whole document, specific sheets or a group of selected cells. The number of copies, and
whether to collate the copies, are also set in this dialog. Choose OK to start printing.

Figure 89. The Print dialog

Print options
Printer options can be set for the current document only or for all spreadsheets. To select for
the current document, on the Print dialog, click the Options button in the bottom left. To set
print options permanently, go to Tools > Options > OpenOffice.org Calc > Print. The
dialog boxes for both are very similar. See Figure 90.
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Selecting sheets to print
One or more sheets can be selected for printing. This can be useful if you have a large
spreadsheet with multiple sheets and only want a certain sheet to print. An example would be
an accountant recording costs over time where there was one sheet for each month. If only the
November sheet were to be printed, this is the procedure to follow.
1) Select the November sheet. (If more than one sheet is to be printed, hold down the
Control key as you click on each sheet tab.)
2) Choose File > Print and select Options.
Note

The Options button is different from the Properties button. Properties deals with
the settings of the printer, whereas Options deals with OOo’s settings.

3) Check the Print only selected sheets checkbox. Click OK.

Figure 90. Printer Options dialog

Adjusting the print range
Printing rows or columns on every page
If a sheet will be printed on multiple pages, certain rows or columns can be set up to repeat
on each printed page.
As an example, if the top two rows of the sheet as well as column A need to be printed on all
pages, do the following:
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1) Choose Format > Print Ranges > Edit Print Range.
2) The Edit Print Ranges dialog (Figure 82) appears. Click on - none - to the left of the
Rows to repeat area, and change it to - user defined -.
3) In the text entry box in the center, type in the rows to repeat. For example, to repeat
rows one and two, type $1:$2. (Or alternatively, click in cell A1 and drag to cell A2.)
4) Columns can also repeat; click on - none - to the left of the Columns to repeat area,
and change it to - user defined -.
5) In the text entry box in the center, type in the columns to repeat. For example, to
repeat column A, type $A. (Or alternatively, click in cell A1.)
6) Click OK.

Figure 91. Edit Print Ranges dialog
Note

The entire range of the rows to be repeated does not need to be selected. Just
selecting one cell in each row will work.

Defining a print range
By default, if no print range has been defined, the entire contents of the worksheet will be
printed. Optionally, a print range can be defined. Use this option to modify or set a defined
print range. This could be useful if, in a large spreadsheet, only a specific area of data needs
to be printed.
To define a print range:
1) Highlight the range of cells that comprise the print range.
2) Choose Format > Print Ranges > Define Print Range.
The page break lines will display on screen.
Note

You can check the print range by using File > Page Preview. OOo will only
display the cells in the print range.
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Adding to the print range
After defining a print range, you can add more cells to it. This allows you to print multiple,
non-contiguous areas of the same sheet, while not printing the whole sheet. Once you have
defined a print range:
1) Highlight the range of cells that should be added to the print range.
2) Choose Format > Print Ranges > Add Print Range.
This will add the extra cells to the print range.
The page break lines will no longer show up on the screen.
Note

The additional print range will print as a separate page, even if both ranges are
on the same sheet.

Removing a print range
It may become necessary to remove a defined print range, for example if the whole sheet
needs to be printed at a later time.
To remove the print range, choose Format > Print Ranges > Clear Print Range.
This will remove all defined print ranges on the sheet.
After the print range is removed, the default page break lines will appear on the screen.
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Chapter 8
Getting Started with Draw
OpenOffice.org’s Vector Drawing Component

What is Draw?

What is Draw?
Draw is a vector graphics drawing program. It offers a series of powerful tools that enable
you to quickly create all sorts of graphics. Vector graphics store and display an image as
vectors (two points and a line) rather than a collections of pixels (dots on the screen). Vector
graphics allow for easier storage and scaling of the image.
Draw is perfectly integrated into the OpenOffice.org suite, and this makes exchanging
graphics with all components of the suite very easy. For example, if you create an image in
Draw, reusing it in a Writer document is as simple as copying and pasting. You can also work
with drawings directly from within Writer and Impress, using a subset of the functions and
tools from Draw.
Draw’s functionality is very extensive and complete. Although it was not designed to rival
high-end graphics applications, Draw possesses more functions than the majority of drawing
tools that are integrated into office productivity suites.
A few examples of drawing functions might whet your appetite: layer management, magnetic
grid point system, dimensions and measurement display, connectors for making organization
charts, 3D functions enabling small three-dimensional drawings to be created (with texture
and lighting effects), drawing and page style integration, and Bézier curves, to name a few.
This chapter introduces some of Draw’s features, but it does not attempt to cover all of the
them. See the Draw Guide and the application Help for more information.

The Workplace
The main components of the Draw interface are shown in Figure 92.
The large area in the center of the window is where the drawings are made. It is surrounded
by toolbars and information areas. You can vary the number and position of the visible tools,
so your setup may look a bit different. For example, many people put the main Drawing
toolbar on the left-hand side of the workspace, not at the bottom as shown here.

Toolbars
The various Draw toolbars can be displayed or hidden according to your needs.
To display or hide the toolbars, click View > Toolbars. On the menu that appears, choose
which toolbars you want to display.
You can also select the buttons that you wish to appear on the corresponding toolbar. On the
View > Toolbars menu, select Customize, click on the Toolbars tab, select the toolbar you
want to change, and then select the desired buttons for that toolbar. Each toolbar has a
different list of buttons. See Chapter 4 (Menus and Toolbars) for more information.
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Figure 92. Initial Draw window
Many toolbar buttons are marked with a small arrow beside the button. The arrow indicates
that this button has additional functions. Click the arrow and a submenu or floating toolbar
appears, showing its additional functions (see Figure 93).
Click and drag this
area to make the
toolbar floating

Figure 93 An arrow next to a button indicates additional functions
You may wish to keep this submenu displayed on your screen, but in a different position. You
can make a submenu into a floating toolbar. To do so, click the area at the top of the
submenu, drag it across the screen, and then release the mouse button. Floating toolbars can
be docked on an edge of the screen or within one of the existing toolbar areas at the top of the
screen, as described in Chapter 4.
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Note

Most buttons marked with the small arrow can become floating toolbars. The floating
toolbar capability is common to all components of the OpenOffice.org suite.

Click the arrow on the title bar of a floating toolbar to display additional functions (see
Figure 94).

Figure 94. An arrow on a floating toolbar indicates additional functions
The tools available in the various toolbars are explained in the following sections.

Standard toolbar
The Standard toolbar looks like this:

It is the same for all parts of OpenOffice.org.

Line and Filling toolbar
The Line and Filling toolbar lets you modify the main properties of a drawing object. See
page 137 for details.

If the selected object is text, the toolbar changes to the one shown below, which is similar to
the Formatting toolbar in Writer.
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Drawing toolbar
The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary
functions for drawing various geometric and freehand shapes and organizing them on the
page.

Color Bar
To display the Color Bar, use View > Toolbars > Color Bar. The toolbar then appears at the
bottom of the workspace.

This toolbar lets you rapidly choose the color of the objects in your drawing. The first box in
the panel corresponds to Invisible (no color).
The default color palette can be changed using Format > Area, as shown in Figure 95.
Choose the tab marked Colors.

Figure 95. Changing the color palette
If you click on the Load Color List button (circled), the file selector asks you to choose a
palette file (bearing the file extension .soc). Several palettes are supplied as standard with
OpenOffice.org. For example, web.soc is a color palette that is particularly adapted to
creating drawings that are going to appear in web pages, because the colors will be correctly
displayed on workstations with screens displaying at least 256 colors.
The color selection box also lets you individually change any color by modifying the
numerical values in the fields provided to the right of the color palette. You can click on Edit
to display a dialog (shown in Figure 96), making the choice of colors easier.
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Color schemes

Figure 96. Defining color schemes
You can use the color schemes known as CMYK (Cyan, Magenta, Yellow, Black), RGB
(Red, Green, Blue) or HSB (Hue, Saturation, Brightness).

Options toolbar
The Options toolbar lets you activate or deactivate various drawing aids. The Options toolbar
is not displayed unless it is first selected. To display it, select View > Toolbars > Options.
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Using the grid
The snap tools are divided into three groups: the grid, snap lines, and snap points.
Draw provides a grid of points to which objects can be snapped. Click on the Display Grid
button in the Options toolbar to display the grid, and then click on the Snap to Grid button to
activate it. The work area will be filled with a grid, as shown in Figure 97. This grid will not
be printed or appear in exported files, such as a PDF.
When the grid is active, shapes can be positioned easily by using the dots as a guide. In the
following example, the objects are positioned exactly on the dots in the grid.

Figure 97: With snap to grid, objects align
to the grid precisely.
The spacing between the dots is defined in the Grid options dialog under the Drawing area of
the OOo options (Tools > Options > OpenOffice.org Draw > Grid).

Figure 98. Setting grid options
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In the dialog shown in Figure 98, you can set the following parameters:
•

Vertical and horizontal spacing of the dots in the grid. You can also change the unit of
measurement used in the general Draw options (Tools > Options > OpenOffice.org
Draw > Grid > General).

•

The resolution is the size of the squares or rectangles in the grid. If the resolution is
Horizontal 1cm, Vertical 2cm, the grid consists of rectangles 2cm high and 1cm wide.

•

Subdivisions are additional points that appear along the sides of each rectangle or
square in the grid. Objects snap to subdivisions as well as to the corners of the grid.

•

The pixel (pix element) size of the snap area defines how close you need to bring an
object to a snap point or line before it will snap to it.

The default grid dots are light gray, which can be very hard to see. To improve visibility, go to
Tools > Options, then OpenOffice.org > Appearance (Figure 99).

Figure 99: Changing the grid color
Under Custom colors, scroll down until you see Drawing / Presentation. Then set the Grid
color to a darker color like black.

Rulers
You should see rulers on the upper and left-hand sides of the workspace (see Figure 100).
These show the size of the objects on the page. The rulers show the location of the mouse
cursor, to help you position objects more precisely. The rulers also are used to manage handle
points and capture lines that make positioning objects easier.
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Figure 100. Rulers in a drawing
The page margins in the drawing area are also represented on the rulers. You can change the
margins directly on the rulers by dragging them with the mouse. To modify the units of
measurement of the rulers, right-click on one of the rulers. The two rulers can have different
units.

Status Bar
The Status Bar is located at the bottom of the screen. The middle part of this area (shown
below) is particularly relevant to the Draw module.

The sizes are given in the current unit (not to be confused with the ruler units). This unit is
defined in Tools > Options > OpenOffice.org Draw > General, where you can also change
the scale of the page. Another way to change the scale is to double-click on the number
shown in the status bar.

The basic drawing shapes
Draw provides a wide range of shapes, located in palettes accessed from the Drawing
Toolbar. This chapter describes only a few of the basic shapes; see the Draw Guide for a
complete description of the shapes available. These shapes include rectangles and squares;
circles, ellipses, and arcs; 3D objects; curves; lines and arrows; text; and connectors.

Drawing a straight line
Let’s start by drawing the simplest of shapes: a straight line. Click on the Line button on the
Drawing Toolbar
and place the mouse cursor at the point where you wish to start drawing.
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Drag the mouse while keeping the button pressed down. Let go of the mouse button when
you want to stop drawing the line. A blue or green handle point will appear at each end of the
line, showing that this is the currently selected object. The colors depend on the default
selection mode (they will be green for simple selection and blue when in point edit mode).

Figure 101: Drawing a straight line
Hold down the Shift key while drawing the segment to force the line to be drawn at a multiple
of 45° from the horizontal.
Hold down the Control key (Ctrl in PCs) to toggle temporarily your settings for Snap to Grid.
Hold down the Alt key to draw the line symmetrically from the start point (the line extends
out to both sides of the start point equally). This lets you draw straight lines by starting from
the middle of the line.
The line you draw will have the default attributes (such as color and line type). To change the
line attributes, click on the line to select it and then use the tools in the Line and Filling
toolbar; or for more control, right-click on the line and choose Line to open the Line dialog.

Drawing a rectangle
Drawing rectangles is similar to drawing straight line segments, except that you use the
Rectangle button
from the Drawing Toolbar. The (imaginary) line drawn with the mouse
corresponds to the diagonal of the rectangle.
Starting point

Figure 102: Drawing a rectangle
Hold down the Shift key to draw a square. Hold down the Alt key to draw a rectangle starting
from its center. To combine the effects, hold down both the Shift and Alt keys simultaneously.
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Drawing a circle or ellipse
To draw an ellipse or circle, use the Ellipse Button
from the Drawing Toolbar (a circle is
simply an ellipse where the two axes are the same length). The ellipse drawn is the largest
ellipse that would fit inside the (imaginary) rectangle drawn with the mouse.
Starting point

Figure 103: Drawing an ellipse
There are three other ways to draw an ellipse or circle:
•

Hold down the Shift key while drawing to force the ellipse to be a circle.

•

Hold down the Alt key to draw a symmetrical ellipse or circle from the center instead
of dragging corner to corner.

•

Hold down the Ctrl key while drawing to snap the ellipse or circle to grid lines.

Note

If you first press (and hold) the Control key before clicking on any of these buttons
(Line, Rectangle, Ellipse, or Text), the chosen object appears directly on the page
with a default size, shape, and color. All of these can then be changed.

Writing text
Use the Text tool
to write text and select the font, color, size, and other attributes. Click
on an empty space in the workspace to write the text at that spot or drag an area to write
inside the dragged frame. Press Enter to drop to the next line.
When you have finished typing text, click outside the text frame. Double-click on the text at
any time to edit it.
When you type text, the upper toolbar includes the usual paragraph attributes: indents, first
line, and tab stops.
You can change the style of all or part of the text. The Styles and Formatting window also
works here (select Format > Styles and Formatting or press F11 to launch), so you can
create Graphics styles that you can reuse for other text frames. Graphics styles affect all of
the text within a text frame. To style parts of the text, use direct formating with the toolbar.
Text frames can also have fill colors, shadows, and other attributes, just like any other Draw
object. You can rotate the frame and write the text at any angle. These options are available
by right-clicking on the object.
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Use the Callout tool, located on the Drawing toolbar, to create callouts (also known as
captions or figure labels).
If you double-click on an object or press F2 (or the Text icon in the Drawing toolbar) when
an object is selected, text is written in the center of the object and remains within the object.
Nearly any kind of object contains such an additional text element. These texts have slight
differences to those in text frames concerning position and hyphenation.

Using connectors
Connectors are a type of line or arrow whose ends stick to glue points on other objects. When
you move the other object, the connector moves with it. Draw has a range of advanced
connector functions. You can change connector types using the context menu.
Connectors are particularly useful for making organizational charts. You can reorganize the
blocks of your chart and all the connected objects stay connected.
Glue points are different from handles (the small blue or green squares around an object).
Use the handles to move or resize an object; use the glue points to attach connectors to an
object.

Selection modes
There are three selection modes: moving and changing size, rotating, and editing points.
The default mode for selecting objects depends on whether the Points button on the Drawing
toolbar is active (appears lit)

or not inactive (appears dark or dimmed)

.

When the Points button is not active, the default mode is for selections to be moved or
changed in size; these selections are indicated by small green squares.

When the Points button is active, the default mode is for selections to be edited; these
selections are indicated by blue squares. Some objects will have one or more extra handles,
which are larger or colored differently. This is explained in more detail in the Draw Guide.
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Selections for rotating objects are indicated by small red circles and a symbol representing
the center of rotation. To choose these selections, click on the Effects drop-down button
from the Drawing toolbar.

Changing the selection mode
To go from one mode to another, you can do one of the following:
If necessary, toggle the Points button on the Drawing toolbar to switch from the simple
selection mode to the Points mode
(Points).

. You can also use the keyboard shortcut F8

Choose the Effects drop-down button from the Drawing toolbar
Rotation mode for a selected object.

to activate the

By choosing the Rotation Mode after Clicking Object button
from the Options bar,
you can cycle through normal and rotation modes just by clicking on the object. This can
be more convenient than clicking the object, then clicking the Rotate button from the
Drawing Toolbar.

Selecting objects
Direct selection
To select an object, the easiest way is to click directly on it. For objects that are not filled, you
have to click directly on the object's outline to select it.

Selection by framing
You can select several objects by dragging a large rectangle around
the objects with the select button, as shown.
For an object to be selected, it must be entirely within the rectangle.
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Selecting hidden objects
When objects are located behind others, they can still be selected. To select an object that is
covered by another object, hold down the Alt key and click the object. To select an object that
is covered by several objects, hold down the Alt key and click through the objects until you
reach the required underlying object. To cycle through the objects in reverse order, hold down
the Alt+Shift keys when you click. To help in making accurate selections, you can check the
number and type of the selected objects, shown at the left of the status bar.
Note

There may be some variation in the use of the Alt key on different operating systems.

To select an object that is covered by another object using the keyboard, press Tab to cycle
through the objects. To cycle through the objects in reverse order, press Shift+Tab.
The easiest method is to use the Tab key to cycle through the objects, stopping at the object
you wish to select. (This may not be practical if you have a large number of objects in your
drawing.) When you click on your selected object, its outline will appear briefly through the
objects on top of the selected object.
In the illustration below, the square located beneath the circle was selected in this way (the
circle was made transparent in order to see the square).

Arranging objects
In a complex drawing, you may have objects stacked up, one on top of the other. To rearrange
stacked objects, use either of these methods:
•

Select one of the stacked objects and then click Modify > Arrange and select the
appropriate Bring Forward or Send Backward options.

•

Right-click the object and select Arrange from the pop-up menu, then select the
appropriate Bring Forward or Send Backward options.

Draw also provides tools for aligning multiple objects; details are given in the Draw Guide.

Selecting several objects
To select or deselect several objects one by one, press the Shift key and click on the various
objects to be selected or deselected.
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Moving and dynamically adjusting an object’s
size
There are several ways of moving or changing the size of an object. The method described
here will be called dynamic in the sense that it is carried out using the mouse.
When you dynamically change an object, remember to check the central area of the status bar
at the bottom of your screen. This area shows detailed information about the ongoing
manipulation. For example, during a resizing manipulation, you will see the following
information displayed. This information changes when the mouse is moved.
Object position

Object dimensions

Current proportional page size

Dynamic movement of objects
To move an object, select it and then click within the object’s border and hold down the left
mouse button while moving the cursor. To drop the object at its new location, let go of the
mouse button. During movement, the shape of the object appears as dotted lines to help with
its repositioning.

Dynamic size modification of objects
To change the size of an object (or group of selected objects) with the mouse, you need to
move one of the handles located around the selection. As shown in the following illustration,
the outline of the resulting new object appears as a dotted line.

The results will differ depending on which handle you use. If you choose a corner handle,
you will resize the object along two axes at the same time. If you use a side handle, the
objects will only be resized along one axis.
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Note

If you press the Shift key at the same time as you carry out the resizing operation,
the size change will be carried out symmetrically with respect to the two axes; this
enables you to keep the aspect (height/length) ratio of the object.

Special effects
With Draw, you can apply many special effects to objects and groups of objects. This section
describes a few of these effects. Others include distorting, shadows, and transparency. See the
Draw Guide for examples of the many effects available.

Rotation
Rotating an object lets you move the object around an axis. To do this dynamically, use the
red handles, as you do when changing the size of the object.
Note

Rotation works in a slightly different way for 3D objects because the rotation occurs
in 3D space and not in one plane. See also the Draw Guide regarding rotation when
Edit Points mode is active.

To rotate an object (or a group of objects), drag the red corner handle points of the selection
with the mouse. The mouse cursor takes the shape of an arc of a circle with an arrow at each
end. A dotted outline of the object being rotated appears and the current angle of rotation is
dynamically shown in the status bar.
Rotations are made about an axis which is displayed as a small symbol. You can move the
axis of rotation with the mouse, as shown below.

Axis of
rotation

If you hold down the Shift key during the rotation, the operation will be carried out in
increments of 15°.

Inclination
To incline or slant an object, use the red handles located on one of the edges of the selected
object. The inclination axis is shown as the nearest handle to the opposite edge.
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As with rotation, you can set the inclination to occur as steps of 15° by pressing the Shift key
while moving the handle.

Duplication
This function duplicates a given shape while enabling you to change the options applied to
the duplicates. The result of a duplication is a new group.
To start duplication, click on an object (or on a group of selected objects), then choose Edit >
Duplicate. The dialog shown in Figure 102 appears.
You can choose:
•

The number of copies.

•

The displacement along the X and Y axes between two copies.

•

The angle of rotation between two copies.

•

The change in size between each copy.

•

The colors of the start and end copies.

Figure 104: Duplicating an object
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The options above applied to a blue rectangle produce the following result:

Cross-fading
Cross-fading transforms a shape from one form to another, with OpenOffice.org handling all
of the intermediate transitions. The result is a new group of objects.
To carry out a cross-fade, select both objects (hold the Shift key while selecting each object in
turn) and then choose Edit > Cross-fading The following dialog appears.

Here is an example of its use.
We start with two shapes...
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...and carry out the cross-fade to obtain the
following drawing.
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Editing objects
To change an object’s attributes (such as color and border width), you can use the Line and
Filling toolbar or the right-click menu.
If the Line and Filling toolbar is not visible, you can display it using View > Toolbars > Line
and Filling. From here you can edit the most common object attributes. You can also open
the Line dialog by clicking on the
icon and the Area dialog by clicking on the
icon to
see more options.

1 Styles and Formatting
2 Line
3 Arrow Style

4 Line Style
5 Line Width
6 Line Color

7
Area
8–9 Area Style / Filling
10 Shadow

When an object is selected, you can right-click on the object to bring up a context menu
(Figure 101). The entries with an arrow contain a submenu.

Figure 105: Right-click on a selected object to see the context menu.
Most often the property you want to change is the line’s style (solid, dashed, invisible), its
color or width. These options are all available from the Line and Filling toolbar. You can also
edit these properties from the Line dialog. You can also define new line and arrow styles (see
the Draw Guide for details).
The OOo term for the inside of an object is Area fill. The area fill of an object can be a
uniform color, a gradient, or an image. Most often you will want to use one of the standard
fill options, whether it is a color, a gradient, or an image. These options are all available from
the Line and Filling toolbar. You can also define new area fills (see the Draw Guide).
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Inserting pictures from other sources
You can add pictures from several sources:
•

The Gallery—see Chapter 14 (Working with the Gallery)

•

Directly from a scanner (Insert > Picture > Scan)

•

Images created by another program, including photographs from a digitial camera
(Insert > Picture > From File)

Draw provides tools for working with bitmap images such as photographs: the Picture toolbar
and the bitmap image management palette. See the Draw Guide for details and examples.

Exporting objects and files
To save a Draw image in a foreign format, use File > Export. Draw can save to many graphic
file formats, as listed in Chapter 3 (File Management).
You can also export Draw files to HTML, PDF, or Flash. PDF export is the same as for any
part of OpenOffice.org, as described in Chapter 3 (File Management). Flash export creates a
.swf file.
HTML export uses a conversion wizard that creates as many web pages as there are pages in
your Draw document. You can optionally choose to display the pages in frames with a
navigator and can set an index page. For more information, see Chapter 16 (Creating Web
Pages: Saving Documents as HTML Files).
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Getting Started with Impress
OpenOffice.org's Presentations

What is Impress?

What is Impress?
Impress is OpenOffice.org’s slide show (presentations) program. You can create slides that
contain many different elements, including text, bulleted and numbered lists, tables, charts,
clip art, and a wide range of graphic objects. Impress also includes a spelling checker, a
thesaurus, prepackaged text styles, and attractive background styles.
This chapter includes instructions, screenshots, and helpful hints to guide you through the
Impress environment while designing the easier presentations. Although more difficult
designs are mentioned throughout this chapter, explanations for creating them are in the
Impress Guide. If you have a working knowledge of how to create slide shows, we
recommend you use the Impress Guide for your source of information.
Note

To use Impress for more than very simple slide shows requires some knowledge of
the elements which the slides contain. Slides containing text use styles to determine
the appearance of that text. Slides containing objects are created the same way that
drawings are created in Draw. For this reason, we recommend that you also study
Chapter 8 (Getting Started with Draw) and Chapter 13 (Working with Styles).

Creating a new presentation
This section describes how to set up a new presentation. The settings selected here are
general: they apply to all the slides. The section “Working with slides” on page 153 explains
how to apply settings to specific slides. These explanations can also apply to some of the
general settings.

Planning a presentation
The first thing to do is to decide what you are going to do with the presentation. For example,
putting a group of digital photos together in a presentation requires very little planning.
However, using a presentation to increase the knowledge of others about your topic requires
much more planning.
Note

This chapter has been put into presentation form and is available for download from
http://oooauthors.org/en/authors/user_howtos/Simple_Presentation.odp. It was
developed by using the steps in this chapter.

You need to ask and answer many questions before you begin creating a presentation. If you
are not acquainted with creating presentations, the answers will be more general. Those who
have created a variety of presentations in the past will want to have more specific answers.
Who is to see the presentation? How will it be used? What is the subject matter? What should
be in its outline? How detailed should the outline be? Will an audio file be played? Is
animation desirable? How should the transition between slides be handled? These are some
of the many questions that should be asked, answered, and written down before creating the
presentation. Sound and animation are more advanced topics and are explained in the
Impress Guide.
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Again, it is not always necessary at this point to have specific answers to every question.
Making an outline is extremely important. You may already know exactly what some of the
slides will contain. You may only have a general idea of what you want on some of the slides.
That is alright. You can make some changes as you go. Change your outline to match the
changes you make in your slides.
The important part is that you have a general idea of what you want and how to get it. Put
that information on paper. That makes it much easier to create the presentation.

Starting the Presentation Wizard
You can start Impress in either of two ways:
•

Click the triangle to the right of the New Icon and select Presentation from the
drop-down menu.

•

Choose File > New > Presentation from the menu bar.

When you start Impress, the Presentation Wizard appears (Figure 106).
Tip

If you do not want the wizard to start every time you launch Impress, select the Do
not show this wizard again checkbox.

Figure 106. Using the Presentation Wizard to choose the type of presentation
3) Select Empty Presentation under Type. It creates a presentation from scratch.
Tip

Leave the Preview checkbox selected, so templates, slide designs, and slide
transitions appear in the preview box as you choose them.
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Note

From Template uses a template design already created as the basis for a new
presentation. The wizard changes to show a list of available templates. Choose the
template you want.
Open Existing Presentation continues work on a previously created presentation.
The wizard changes to show a list of existing presentations. Choose the presentation
you want.
Both of these options are covered in the Impress Guide.

4) Click Next. The Presentation Wizard step 2 appears. Figure 107 shows the Wizard as it
appears if you selected Empty Presentation at step 1. If you selected From Template,
an example slide is shown in the Preview box.

Figure 107. Selecting a slide design using the Presentation Wizard
5) Choose a design under Select a slide design. The slide design section gives you two
main choices: Presentation Backgrounds and Presentations. Each one has a list of
choices for slide designs. If you want to use one of these other than <Original>, click it
to select it.
The types of Presentation Backgrounds are shown in Figure 107. By clicking an item,
you will see a preview of the slide design in the Preview window. Impress contains
three choices under Presentations: <Original>, Introducing a New Product, and
Recommendation of a Strategy.
•
•
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<Original> is for a blank presentation slide design.
Both Introducing a New Product and Recommendation of a Strategy have their
own prepackaged slide designs. Each design appears in the Preview window
when its name is clicked.
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Note

Introducing a New Product and Recommendation of a Strategy are prepackaged
presentation templates. They can be used to create a presentation by choosing From
template in the first step (Figure 106).

6) Select how the presentation will be used under Select an output medium. Most often,
presentations are created for computer screen display. Select Screen.
7) Click Next. The Presentation Wizard step 3 appears (Figure 108).

The Effect option creates transitions between all the
slides in the presentation. Select No Effect for no
transition effect. Transitions can be added and changed
later. For more information, see “Working with slides”
later in this chapter.

Figure 108. Selecting a slide transition effect and speed
8) Choose the desired option from the Effect drop-down menu.
Tip

You might want to accept the default values for both Effect and Speed unless you
are skilled at doing this. Both of these values can be changed later while working
with Slide transitions and animations. These two are explained in more detail later
in this chapter.

9) Select the desired speed for the transition between the different slides in the
presentation from the Speed drop-down menu. Medium is a good choice for now.
10)Click Create. A new presentation is created.
Note

If you selected From template on step 1 of the Wizard, the Next button will be active
on step 3 and other pages will be available. These pages are not described here.
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Formatting a presentation
Now comes the part where you put your presentation together based upon your outline. This
is done using the Main window of Impress (Figure 109). We will first describe the purpose of
each part of this window. Afterwards, we will describe how to use them in putting your
presentation together.

Slides pane

Workspace

Tasks pane

Figure 109: Main window of Impress

Main window of Impress
The Main window has three parts: the Slides pane, Workspace, and Tasks pane. The Slides
pane contains thumbnail pictures of the slides. You can select an individual slide and perform
other operations. The Workspace is where most of the work is done to create individual
slides. The Tasks pane contains a group of four tasks which affect styles, the layout,
animation, and transitions between slides in your presentation.
Tip

You can remove either the Slides pane or Task pane from view by clicking the x to
close it like any other window, or by using View > Slide Pane or View > Task
Pane. To restore the Slide or Task panes, select View >Slide Pane or View > Task
Pane respectively.

Slides pane

The Slides pane contains the thumbnail pictures of the slides in your presentation. They are in
the order they will be shown in a default presentation. Clicking a slide selects it and places it
in the Workspace.
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Several additional operations can be performed on one or more slides in the Slides pane:
•

Add new slides at any place within the presentation after the first slide.

•

Mark a slide as hidden so that it will not be shown as part of the slide show.

•

Delete a slide from the presentation if it is no longer needed.

•

Rename a slide.

•

Copy or move the contents of one slide to another (copy and paste, or cut and paste,
respectively).

It is also possible to perform the following operations, although there are more efficient
methods than using the Slides pane.
•

Change the slide transition following the selected slide or after each slide in a group of
slides.

•

Change the sequence of slides in the presentation.

•

Change the slide design. (A window opens allowing you to load your own design.)

•

Change slide layout for a group of slides simultaneously. (This requires using the
Layouts section of the Tasks pane.)

Workspace

The Workspace has five tabs: Normal, Outline, Notes, Handout, and Slide Sorter. These
five tabs are called View Buttons (Figure 110). There are also many toolbars which can be
used to create a slide. View > Toolbars shows a list of what is available. The Workspace
section is below the View Buttons. This is where you put the various parts of your selected
slide together.

Figure 110: View Buttons
Each view is designed to make completing certain tasks easier.
•

•

•

Normal view is the main view for creating individual slides. Use this view to format
and design and to add text, graphics, and animation effects. Many of the other sections
in this chapter describe how to create and edit slides in Normal view. Additional
information is available in the Impress Guide.
Outline view shows topic titles, bulleted lists, and numbered lists for each slide in
outline format. Use this view to rearrange the order of slides, edit titles and headings,
rearrange the order of items in a list, and add new slides.
Notes view lets you add notes to each slide that are not seen when the presentation is
shown. Just click on the words “Click to add notes” and begin typing. You can resize
the notes text box using the green resizing handles and move it by placing the pointer
on the border, then clicking and dragging. Changes can also be made in the text style
using the F11 key.
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•

•

Slide Sorter view shows a thumbnail of each slide in order. Use this view to rearrange
the order of slides, produce a timed slide show, or add transitions between selected
slides.
Handout view lets you print your slides for a handout. You may choose one, two, three,
four, or six slides per page from Task pane > Layouts. This choice determines how
many thumbnails are visible. You can rearrange the thumbnails in this view by simply
dragging and dropping them.

Task pane

The Task pane has four sections:
•

Tip

•

•

•

Master Pages: Here you define the Page Style you will be using for your presentation.
Impress contains five prepackaged Master Pages (slide masters). One of them—
Default—is blank, and the rest have a background.
Press F11 to open the Styles and Formating window, where you can modify the
styles used in any slide master to suit your purpose. This can be done at any time.

Layout: Twenty prepackaged layouts are shown. You can choose the one you want, use
it as it is or modify it to your own requirements. At present it is not possible to create
custom layouts.
Custom Animation: A variety of animations for selected elements of a slide are listed.
Animation can be added to a slide, and it can also be changed or removed later.
Slide Transition: Fifty-six transitions are available, including No Transition. You can
select the transition speed (slow, medium, fast). You can also choose between an
automatic or manual transition, and how long you want the selected slide to be shown
(automatic transition only).

Building a presentation
This process begins with the decision as to what basic characteristics you want all the slides
to have. These characteristics determine which slide master you will use for your slides and
what modifications if any you will make to it.
Choosing a slide master

A Slide Master is a slide with a specified set of characteristics which is used as the beginning
point for creating other slides. These characteristics include the background, objects in the
background, formatting of any text used, and any background graphics.
Note

Impress uses three interchangeable terms for this one concept. Master slide, slide
master, and master page all refer to a slide that is used to create other slides. This
chapter and the Impress Guide, however, use only the term slide master.

For a simple presentation, there is normally only one Master Page. All slides are created by
adding elements to the Master Page. Another Master Page can be used for some of the slides
if so desired.
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If you decide later that the Master Page you chose does not meet your needs, you can still
choose a different Master Page, or you can change parts of your Master Page. All the slides
which apply this Master Page will be changed the same way.
Tip

As you are developing your slide master and then succeeding slides, use F5 or F9
regularly to see what the slide you are working on looks like full screen. Then use
the Esc key to return to your work of creating your slide show. You can spot
problems sooner and easier this way.

You should first determine the styles you want to use for your presentation. There are five
prepackaged slide masters, found in the Master Pages section of the Task pane (Figure 111).
Pick the one that comes closest to what you want. We look at how to make changes in the
slide master later.

Default

Dark Blue &
Orange

New Product

Subtle
Accents

Strategy
Recommendation

Figure 111: Available slide master
Note

The Default Master Page is a blank slide with specific Outline styles. The other
four Master Pages contain designs as well as specific Outline styles.

To see what is possible to do, look at how the prepackaged Master Pages were made. To do
this, select View > Master > Master Slide to open the Master Pages section. Since the
Default Master Page is blank, consider only the other four available Master Pages.
Tip

View > Master > Master Slide allows you to make changes in the slide master.
Whatever changes are made to the slide master will be made on all the slides of the
presentation.
View > Normal allows you to work only on individual slides, but none of these
changes will change the slide master on which the slide is based.

The first two steps to building a presentation are: Select the slide master which comes closest
to meeting your needs, and save the presentation. Then you need to modify the slide master.
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Caution

Remember to save frequently while working on the presentation, to prevent any loss
of information should something unexpected occur. You might also want to activate
the AutoRecovery function (Tools > Options > Load/Save > General). Make sure
Save AutoRecovery information every is selected and that you have entered a
number of minutes. (Set the value between 5 and 10 minutes.)

Make changes to the slide master you have chosen by selecting View > Master > Master
Slide. Most of this is done using styles. F11 opens the Styles and Formating window. The
Presentation Styles icon should already be selected, if it is not, select it now. Fourteen styles
are listed, and all can be modified, but no new styles can be added. To change any of these
styles, right-click the style name and choose Modify from the pop-up menu.
Tip

When you select View > Master >Master Slide, the Master View toolbar (Figure
112) also opens. See the Impress Guide for instructions on the use of this toolbar.

Figure 112: Master View toolbar
The following Presentation styles are available.
1) Background styles:
•

None means all slide backgrounds will be white.

•

Color allows you to select your own background color.

•

•

•

Notes
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Gradient has 15 prepackaged backgrounds. The increments between one color and
the other is automatically set by default, but you can set it manually if you desire.
New gradients can be created, using Format > Area > Gradient (tab).
Hatching has 10 prepackaged patterns. More can be created using Format > Area
> Hatching (tab). A background color can be added to the hatching.
Bitmap has 20 prepackaged patterns. More bitmaps can be added to this list if they
are one of the graphic formats OOo recognizes. (See the note below.) Use Format
> Area > Bitmaps. Use the Import button to locate the bitmap and give it a name.
Using F11 and selecting Bitmaps from Background styles, you should see your
imported bitmap at the bottom of the list.
Tools > Options > OpenOffice.org > Colors allows you to create your own custom
colors. Once you create a color this way, it will be listed in the selection of colors
available for the background.
For information on creating new gradients, hatching, and bitmaps, see the Impress
Guide.
To see all of the graphic formats OOo will accept as a bitmap, select Format >
Area > Bitmaps. Click Import. File types contains the entire list of acceptable
graphic formats.
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2) Background objects style: Use this to set the characteristics of all objects you add to
the slide master. Make any changes you need. Remember to use F5 after making a
change to make sure that is what you want. Using the Esc key afterwards will return
you to your work.
Note

Just like Paragraph and Character styles in Writer, Background objects styles can be
overridden by applying manual formating. So it is possible to have two background
objects with different formating.
The use of background objects requires a knowledge of OOo’s Draw component
and is beyond the scope of this chapter.

3) Notes: If you want to have notes attached to your slides, right-click the Notes style,
select Modify, and set the formating you want your notes to have. Make sure you
make the font size large enough to be readable. Just remember that this formatting will
be applied to the note of every slide using the same slide master. The bottom part of
the Notes window contains an example of what any of your choices looks like.
Note

At the present time, you cannot view your notes while you are running a slide show.
Notes can be included in a printed handout of the slide show.

4) Outline 1 through Outline 9: These styles set the formatting for each level of text in the
text boxes of the slides. All of these have default values that are fairly good. You
would probably want to leave most if not all of these values as they are. Since in a
simple presentation, only one slide master is used, any changes made will affect all
slides containing the affect style. For example, five slides have text with the Outline 2
style. When you change the Outline 2 font size from 20 to 18, this change will be made
on all five slides to every paragraph using the Outline 2 style.
5) Title and Subtitle: Set these styles the same way you set the styles for Outline 1
through Outline 9. Most of these styles work very well as they are. The parts that you
might want to change are the Font, Typeface, Font size, and Font color (Font Effects
tab).
6) When you are finished making your changes, use View > Normal. Or, you could click
Close Master View in the Master View toolbar.
Creating the first slide

The first slide is normally the Title Page. Decide which of the layouts (Figure 113) will suit
your purposes for your first slide. It is good practice to keep it rather simple. Some suitable
layouts are Title Slide (also contains a section for a subtitle), or Title Only slide. The rest of
the layouts seem to be better suited for later slides in the presentation, or for more complex
presentations.
Note

For very simple presentations, you may not need a title; for example, if the
presentation is simply a group of pictures put together for someone to see. But in
most cases, you will need to use the title as the first slide.

Chapter 9 Getting Started with Impress

149

Formatting a presentation

Figure 113: Choosing a slide layout
Adding elements to the Title Page

All the suggested layouts contain a title section at their top. To create the title, click the
phrase Click to add title. Type the title. Adjustments to the formating of the title can be done
by using the F11 key, right-clicking the Title style, and selecting Modify from the pop-up
menu.
If you are using the Title Slide layout slide, click the phrase Click to add text to add a subtitle.
Make any adjustments in the formating you desire. Do this the same way as if you are
changing the title formating: use the F11 key, right-click the Subtitle style, select Modify
from the pop-up menu, and make your changes. Click OK to apply your changes to the
subtitle.
The Title, Object layout slide can also be used. To do this requires knowledge of how to move
and resize graphic images (objects). Insert the object as an OLE Object. To do so:
1) Double-click the graphic.
2) Select Create from file and click OK.
Caution

Choose Link to file only if you are going to keep the presentation and the file in the
same directory in which they were originally saved. Otherwise, you may not be able
to access your OLE Objects from your slide show when you need them.

3) Click Search to browse to the file’s location. Select the file, and click Open. Then
click OK.
4) Resize and center the object to fit the slide as needed.
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Inserting additional slides
The steps for inserting additional slides are basically the same as for selecting the title page.
It is a process that has to be repeated for each individual slide. Since you are going to be
using only one slide master, your only concern right now is the Layouts section of the Tasks
pane on the right.
First, you should insert all of the slides your outline indicates you will need. Only after this
should you begin adding special effects such as custom animation and slide transitions.
(These are covered in the next section.)
Step 1: Insert a new slide. This can be done in a variety of ways. Take your pick.
•

Insert > Slide.

•

Right-click on the present slide, and select New Slide from the context menu.

•

Click the Slide icon in the Presentation toolbar (Figure 114).

Figure 114: Presentation toolbar
Step 2: Select the layout slide that bests fits your needs.
If your slide consists only of a title with a graphic, chart, or spreadsheet, inserting it as an
OLE Object is the simplest. But be advised, doing this for a chart or spreadsheet is not
simple. This is an advanced technique.
Step 3: Modify the elements of the slide. At this stage, the slide consists of everything
contained in the Master page as well as the chosen layout slide. This includes removing
unneeded elements, adding needed elements (pictures and OLE Objects), and inserting text.
Caution

Changes to any of the prepackaged layouts can only be made using View > Normal
which is the default. Attempting to do this by modifying a slide master will result in
an error message. (The slide master is modified using View > Master > Master
Slide.)

1) Remove any element on the slide you do not need (Figure 115).
a) Click the element to highlight it. (The green squares show it is highlighted.)
b) Press the Delete key to remove it.
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Figure 115: Deleting an element of a slide
Tip

Sometimes you will accidentally select the wrong layout slide. You can at any time
click the correct layout slide and continue your work.

2) Add any elements to the slide you do need.
a) Adding pictures to the clipart frame:
●

Double-click the picture within the frame.

●

Browse to the location of the picture.

●

Select the picture and click Open.

●

Resize the picture as necessary. Follow the directions in the Caution note
below.

b) Adding pictures from graphic files to places other than the clipart frame:
●

Insert > Picture > From File.

●

Browse to the graphic file, select it, and click Open.

●

Move the picture to its location.

●

Resize the picture if necessary.

c) Adding OLE Objects is an advanced technique covered in the Impress Guide.
Caution

When resizing a graphic, right-click the picture. Select Position and Size from the
pop-up menu. Make sure Keep ratio is selected. Then adjust the height or width to
the size you need. (As you adjust one dimension both dimensions will change.)
Failure to do so will cause the picture to become distorted.

3) Adding text to a slide: If the slide contains text, click the phrase Click to add an
outline in the text frame. Type the text into the text frame.
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Note

Text in the slide is in an outline format: each level is indented more than the
previous level as you move from level 1 to level 10.

a) To change Outline Levels as you type, use the left and right arrow buttons (Figure
116).
•

The left arrow changes it to the previous Outline Level (level 3 to level 2 for
example).

•

The right arrow changes to the next Outline Level (level 2 to level 3 for
example).

Figure 116: Text moving arrows
b) To change the order of the paragraphs (lines), use the up and down arrow buttons.

Note

•

The up arrow moves the paragraph higher in the text.

•

The down arrow moves the paragraph lower in the text.

Moving text around usually requires using a combination of these keys. For
example, a paragraph needs to be moved higher and its Outline level needs to be
changed to a lower level (closer to 1) or a higher level (closer to 10).

Step 4: To create additional slides repeat steps 1–3.

Working with slides
This is the time to review the entire presentation and answer some questions. Run the slide
show at least once before answering them. You might want to add some questions of your
own.
1) Are the slides in the correct order? If not, some of them will need to be moved.
2) Would an additional slide make a particular point clearer? The slide needs to be
created.
3) Would some custom animations help some of the slides? (Advanced technique)
4) Should some of the slides have a different slide transition than others? The transition
of these slides should be changed.
5) Do some of the slides seem unnecessary? Delete the slide or slides after checking if
they are indeed unnecessary.
Caution

If one or more slides seems to be unnecessary, hide the slide or slides, and view the
slide show a few more times to make sure. To hide a slide, right-click the slide in
the Slides pane. Select Hide Slide in the pop-up menu. Do not delete a slide until
you have done this, otherwise you may have to create that slide again.
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Once you have answered these and your own questions, you should made the necessary
changes. This is done the easiest in the Slide Sorter view and will be explained there. If you
need one or more new slides, create them using the steps listed in “Inserting additional
slides” on page 151.
Custom animations

If you know how to add a custom animation to a slide, do it now. This is an advanced
technique and is explained in the Impress Guide.
Slide transitions

Your first slide show should probably have the same slide transition for all slides. Setting
Advance slide to On mouse click is the default and a simple setting. If you want each slide to
be shown for a specific amount of time, click Automatic after and enter the number of
seconds. Click Apply to all slides.
Tip

The Slide transition section has a very useful choice: Automatic preview. Select its
checkbox. Then when you make any changes in a slide transition, the new slide,
including its transition effect, is previewed in the workspace area.

Changes that can be made to slide transitions:
1) Apply to selected slides has a list of slide transitions.
a) Make sure Automatic preview is checked.
b) Click one of the members of the Apply to selected slides list.
c) Watch the effects of this slide transition.
d) Select the slide transition you want.
2) Modify transition has two drop down lists.
•

Select the Speed: slow, medium, and fast.

•

Select a Sound from the list if you want one.

3) Once you have made your selections, if any, click Apply to all slides to give all slides
the same transition.
4) Play and Slide Show are used to play one or more slides in the presentation.

Tip
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•

Clicking Play has the same effect as having Automatic Preview checked (ticked): a
single slide is shown along with its slide transition.

•

Slide Show begins the slide show at the selected slide and continues until the end.
If you want to use this button to play the entire slide show, click the top slide in the
Slides pane. Then click Slide Show in the Slides transitions section of the Task pane.
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Workspace
You already know about the first view of Workspace: Normal. All of your work so far has
been done in that view, one slide at at time. These other views of Workspace allow you to
perform other tasks.
Normal

There are two ways to place a slide in the Slide Design area of the Normal view: clicking the
slide thumbnail in the Slides pane, or using the Navigator. To open the Navigator, click the
Navigator button in the Standard Toolbar (Figure 117). To select a slide, scroll down the
Navigator list until you find it and the double-click it.

Figure 117: Navigator button
Note

One of the purposes of naming the slides is to match them with the outline you
created in the beginning. Another purpose is to help find a particular slide that you
want to change using the Navigator.

Outline

The Outline view (Figure 118) contains all of the slides of the presentation in their numbered
sequence. Only the text in each slide is shown. Slide names are not included.

Slide Icon

Figure 118: Moving slides in Outline view
The Outline view serves at least two purposes.
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1) Making changes in the text of a slide:
•

You can add and delete the text in a slide just as you would in the Normal view.

•

You can move the paragraphs of text in the selected slide up or down by using the
up and down arrows (Figure 116).

•

You can change the Outline Level for any of the paragraphs in a slide using the left
and right arrows.

2) The slides can be compared with your outline. If you notice from your outline that
another slide is needed, you can return to the Normal view to create the slide. Then
return to reviewing all the slides against your outline in the Outline view.
•

If a slide is not in the correct sequence, you can move it to its proper place.
•

Click the slide icon of the slide you are moving.

•

Drag and drop it where you want it.

Notes

The Notes view is used to add notes to a slide. At the present time, they are not visible to the
person running the slide show. They can be printed out as part of a handout, but this is not an
easy task.
To add notes to a slide:
1) Click the Note tab in the Workspace (Figure 119).

Figure 119: Note view
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2) Select the slide to which you will add notes.
•

Double-click the slide in the Slide pane, or

•

Double-click the slide's name in the Navigator.

3) Type the notes in the text box below the slide.
Slide Sorter

Slide Sorter view contains all of the slide thumbnails (Figure 120). This view allows the
selection of multiple slides for the purpose of changing the order. It is also possible to work
on one slide at a time.

Figure 120: Slide Sorter view
Change the number of slide per row if desired.
1) Check View > Toolbars > Slide View to make the Slide view toolbar (Figure 121)
visible.
Figure 121: Slide View toolbar
2) Adjust the number of slides.
3) When you have adjusted the number of slide per row, View > Toolbars > Slide View
will remove this toolbar from view.
To move a slide in a presentation in the Slide Sorter:
1) Click the slide. A thick black border is drawn around the selected slide.
2) Drag and drop it to the location you want.
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•

As you move the slide, a black vertical line appears to one of the sides of the slide.

•

Drag the slide until this black vertical line is located where you want the slide.

To select a group of slides:
1) Click the number of the first slide.
2) Hold down the left mouse button.
3) Drag the cursor to the last slide thumbnail. A dashed outline of a rectangle forms as
you drag the cursor through the slide thumbnails. Make sure the rectangle includes all
the slides you want to select.
To move a group of slides:
1) Select the group.
2) Drag and drop the group to their new location. The same vertical black line appears to
show you where the group of slides will go.
Note

Selection of a group of slides works in a rectangular fashion. For example: slides 1,
2 ,3, 5, 6, and 7 can be selected, but slides 1, 2, 5, 6, and 7 can not.

You can work with slides in the Slide Sorter view just as you can in the Slide pane. To make
changes, right-click a slide and do the following using the pop-up menu:
•

Add a new slide after the selected slide.

•

Delete the selected slide.

•

Change the Slide Layout.

•

Change the Slide Transition.
a) For one slide, click the slide to select it. Then add the desired transition.
b) For more than one slide, select the group of slides and add the desired transition.

•

Hide the selected slide. It will not be shown in the slide show.

•

Copy and paste a slide.

•

Cut and paste a slide.

Handouts

This view is for setting up the layout of your slide for a printed handout. Layout contains five
choices: one, two, three, four, and six slides per page (Figure 122). If you want to include
slide notes with your handout, consult the Impress Guide. This involves advanced techniques.
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Figure 122: Handout layouts
To print a handout:
1) Select the slides using the Slide Sorter. (Use the steps listed in selecting a group of
slides on page 158.)
2) Select File > Print or press Control+P.
3) Select Options in the bottom left corner.
4) Check Handout and click OK.
5) Select Print Range.
6) Click OK in the Print window.
Note

By selecting a single slide, it is possible to print it and any notes it contains. Printing
the entire presentation and all of its notes is beyond the scope of this document.

Running the presentation
To run the slide show, do one of the following:
•

Click Slide Show > Slide Show.

•

Click the Slide Show button (Figure 123).

Figure 123: Presentation Toolbar
•

Press F5 or F9 to start a slide show.

If the slide transition is Automatic after x seconds, let the slide show run by itself.
If the slide transition is On mouse click, do one of the following to move from one slide to
the next.
•

Use the arrow keys on the keyboard to go to the next slide or to go back to the
previous one.

•

You can also click the mouse to move to the next slide.

•

Press the spacebar on the keyboard to advance to the next slide.

To exit the slide show at any time including at the end, press the Esc key.
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Chapter 10
Getting Started with Base
OpenOffice.org’s Database Component

Introduction

Introduction
A data source, or database, is a collection of pieces of information that can be accessed or
managed by OpenOffice.org (OOo). For example, a list of names and addresses is a data
source that could be used for producing a mail merge letter. A shop stock list could be a data
source managed through OOo.
Note

OpenOffice.org uses the terms “Data Source” and “Database” to refer to the same
thing, which could be a database such as MySQL or dBase or a spreadsheet or text
document holding data.

This chapter covers creating a database, showing what is contained in a database and how the
different parts are used by OOo. It also covers using the Base component of OOo to register
other data sources. A data source can be a database, spreadsheet, or text document.
Data sources are only introduced in this chapter. For more detailed information about the use
of databases, see the Database Guide.
Note

OOo Base uses the HSQL database engine. All of the files created by this engine are
kept in one zipped file. The database forms are included in this zipped file.

A database consists of a number of fields that contain the the individual pieces of data. Each
table of the database is a group of fields. When creating a table, you also determine the
characteristics of each field in the table. Forms are for data entry into the fields of one or
more tables associated with the form. They can also be used for viewing fields from one or
more tables associated with the form. A query creates a new table from the existing tables
based upon how you create the query. A report organizes the information of the fields of a
query in a document according to your requirements.
Caution

The database in OOo requires Java Runtime Environment (JRE). If you do not have
it on your computer, you can download it from www.java.com and install it
following the instructions on the site. It should be Java 5.0 or higher. In OOo, use
Tools > Options > OpenOffice.org > Java to register Java.
Window’s version of JRE can not be used, while there are other versions that can.

Base creates relational databases. This makes it fairly easy to create a database in which the
fields of the database have relationships with each other.
For example: Consider a database for a library. It will contain a field for the names of the
authors and another field for the names of the books. There is an obvious relationship
between the authors and the books they have written. The library may contain more than one
book by the same author. This is what is known as a one-to-many relationship: one author
and more than one book. Most if not all the relationships in such a database are one-to-many
relationships.
Consider an employment database for the same library. One of the fields contains the names
of the employees while others contain the social security numbers, and other personal data.
The relationship between the names and social security is one-to-one: only one social security
number for each name.
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If you are acquainted with mathematical sets, a relational database can easily be explained in
terms of sets: elements, subsets, unions, and intersections. The fields of a database are the
elements. The tables are subsets. Relationships are defined in terms of unions and
intersections of the subsets (tables).
To explain how to use a database, we will create one for automobile expenses. In the process,
we will be explaining how a database work.

Creating a database
The first step in creating a database is to ask yourself many questions. Write them down, and
leave some space between the questions to later write the answers. At least some of the
answers should seem obvious after you take some time to think.
You may have to go through this process a few times before everything becomes clear in your
mind and on paper. Using a text document for these questions and answers makes it easier to
move the questions around, add additional questions, or change the answers.
Here are some of the questions and answers I developed before I created a database for
automobile expenses. I had an idea of what I wanted before I started, but as I began asking
questions and listing the answers, I discovered that I needed additional tables and fields.
What are the fields going to be? My expenses divided into three broad areas: fuel purchases,
maintenance, and vacations. The annual cost for the car’s license plate and driver’s license
every four years did not fit into any of these. It will be a table of its own: license fees.
What fields fit the fuel purchases area? Date purchased, odometer reading, fuel cost, fuel
quantity, and payment method fit. (Fuel economy can be calculated with a query.)
What fields fit the maintenance area? Date of service, odometer reading, type of service, cost
of service, and next scheduled service of this type (for example, for oil changes list when the
next oil change should be). But it would be nice if there was a way to write notes. So, a field
for notes was added to the list.
What fields fit the vacations area? Date, odometer reading, fuel (including all the fields of the
fuel table), food (including meals and snacks), motel, total tolls, and miscellaneous. Since
these purchases are made by one of two bank cards or with cash, I want a field to state which
payment type was used for each item.
What fields fit into the food category? Breakfast, lunch, supper, and snacks seem to fit. Do I
list all the snacks individually or list the total cost for snacks for the day? I chose to divide
snacks into two fields: number of snacks and total cost of snacks. I also need a payment type
for each of these: breakfast, lunch, supper, and total cost of snacks.
What are the fields that are common to more than one area? Date appears in all of the areas
as does odometer reading and payment type.
How will I use this information about these three fields? While on vacation, I want the
expenses for each day to be listed together. The date fields suggest a relationship between the
vacation table and the dates in each of these tables: fuel and food, This means that the date
fields in these tables will be linked as we create the database.
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The type of payment includes two bank cards and cash. So, we will create a table with a field
for the type of payment and use it in list boxes in the forms.
Tip

While we have listed fields we will create in the tables of the database, there is one
more field that may be needed in a table: the field for the primary key. In some
tables, the field for the primary key has already been listed. In other tables such as
the payment type, an additional field for the primary key must be created.

Creating a new database
New
icon

Figure 124: Creating a new database
To create a new database, click the arrow next to the New icon. In the drop-down menu,
select Database (Figure 124). This opens the Database Wizard. You can also open the
Database Wizard using File > New > Database.
The first step of the Database Wizard has one question with two choices: Create a new
database or Connect to an existing database. For this example, select Create a new
database and then click Next.
The second step has two questions with two choices each. The default choice for the first
question is Yes, register the database for me and the default choice for the second question
is Open the database for editing. Make sure these choices are selected and click Finish.
Note

If the database is not registered, it will not be accessible to the other OOo components
such as Writer and Calc. If the database is registered, other components can access it.

Save the new database with the name Automobile. This opens the Automobile –
OpenOffice.org Base window. Figure 125 shows part of this window.
Tip

Caution
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Every time the Automobile database is opened, the Automobile – OpenOffice.org
Base window opens. Changes can then be made to the database. The title for this
window is always (database name) – OpenOffice.org.
As you create a database, you should save your work regularly. This means more than
just saving what you have just created. You must save the whole database as well.
For example, when you create your first table, you must save it before you can close
it. If you look at the Save icon in the Standard toolbar at the top after closing the
table, it will be active. Click the Save icon, and this icon will be grayed out again.
Not only the table has been saved, but it also been made a part of the database.
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Creating database tables
Note

In a database, a table stores information for a group of things we call fields. For
example, a table might hold an address book, a stock list, a phone book or a price
list. A database can have from one to several tables.

To work with tables, click the Tables icon in the Database list, or use Alt+a. The three tasks
that you can perform on a table are in the Task list (see Figure 125).

Figure 125: Creating tables
Using the Wizard to create a table
Caution

Every table requires a Primary key field. (What this field does will be explained
later.) We will use this field to number our entries and want that number to
automatically increase as we add each entry.

Since none of the fields we need for our Automobile database are contained in any of the
wizard tables, we will create a simple table using the wizard that has nothing to do with our
database. This section is an exercise in explaining how the Wizard works.
The Wizard permits the fields of the table to come from more than one suggested table. We
will create a table with fields from three different suggested tables in the Wizard.
Click Use Wizard to Create Table. This opens the Table Wizard.
Note

A field in a table is one bit of information. For example, in a price list table, there
might be one field for item name, one for the description and a third for the price .
More fields may be added as needed.

Chapter 10 Getting Started with Base

165

Creating a database

Step 1: Select fields.
You have a choice of two categories of suggested tables: Business and Personal. Each
category contains its own suggested tables from which to choose. Each table has a list of
available fields. We will use the CD-Collection Sample table in the Personal category to
select the fields we need.
1) Category: Select Personal. The Sample Tables drop down list changes to a list of
personal sample tables.
2) Sample Tables: Select CD-Collection. The Available fields window changes to a list of
available fields for this table.
3) Selected Fields: Using the > button, move these fields from the Available fields
window to the Selected fields window in this order: CollectionID, AlbumTitle, Artist,
DatePurchased, Format, Notes, and NumberofTracks.
4) Selected Fields from another sample table. Click Business as the Category. Select
Employees from the dropdown list of sample tables. Use the > button to move the
Photo field from the Available fields window to the Selected fields window. It will be
at the bottom of the list directly below the NumberofTracks field.
5) If a mistake is made in the order as listed above, click on the field name that is in the
wrong order to highlight it. Use the Up or Down arrow on the right side of the
Selected Fields list (see Figure 126) to move the field name to the correct position.
Click Next.

Add/Remove

Move

Figure 126: Order of fields
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Caution

Below the Selected Fields list are two buttons: one with a +, and one with a –.
These buttons are used to add or to remove fields from the Selected Fields list. Be
careful when using these buttons until well acquainted with how to create tables
(Figure 126).

Step 2: Set field types and formats.
In this step you give the fields their properties. When you click a field, the information on the
right changes. You can then make changes to meet your needs. (See Figure 127.) Click each
field, one at a time, and make the changes listed below.

Figure 127: Changing field types
Note

If any of these fields requires an entry, set Entry required to Yes. If Entry required is
set to Yes, this field must have something in it. For example if FirstName has Entry
required set to Yes, having an entry with the first name missing will not be allowed.
In general, only set Entry required to Yes if something must always be put in that
field. By default, Entry required is set to No.

•

CollectionID: Change AutoValue from No to Yes.

•

AlbumTitle:

Note

•

Entry required: If all of your music is in albums, change Entry required to Yes.
Otherwise, leave Entry required as No.

•

Length: Unless you have an album title that exceeds 100 characters in length
counting the spaces, do not change the length.

In Base the maximum length of each field must be specified on creation. It is not
easy to change this later, so if in doubt specify a greater length. Base uses VCHAR
as the field format for text fields. This format only uses the actual number of
characters in a field up to the limit set. So, a field containing 20 characters will only
use space for 20 characters even if the limit is set at 100. So, two album titles
containing 25 and 32 characters respectively will use space for 25 and 32 characters
and not 100 characters.

•

Artist: Use the Default setting. And since music has authors, set Entry Required to Yes.

•

Date Purchased: Length: default setting. Entry required should be No. (You may not
know the date.)

•

Format: Only change the Entry Required setting: from No to Yes.
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•

Notes: No changes are required.

•

NumberofTracks: Change the Field Type to Tiny Integer[TINYINT]. Your allowable
number of tracks will be 999.

•

Photo: Use the default settings. When you have finished, click Next.

Note

Each field also has a Field Type. In Base the field type must be specified. These types
include text, integer, date and decimal. If the field is going to have general information
in it (for example a name or a description) then you want to use text. If the field will
always contain a number (for example a price) the type should be decimal or another
appropriate numerical field. The wizard picks the right field type, so to get an idea of
how this works, see what the wizard has chosen for different fields.

Step 3: Set primary key.
1) Create a primary key should be checked.
2) Select option Use an existing field as a primary key.
3) In Fieldname drop down list, select CollectionID .
4) Check Auto value if it is not already checked.
5) Click Next.
Note

A primary key uniquely identifies an item (or record) in the table. For example, you
might know two people called “Randy Herring” or three people living at the same
address and the database needs to distinguish between them.
The simplest method is to assign a unique number to each one: number the first person
1, the second 2 and so on. Each entry has one number and every number is different,
so it is easy to say “record ID 172”. This is the option chosen here: CollectionID is
just a number assigned automatically by Base to each record of this table.
There are more complex ways of doing this, all answering the question “How do I
make sure that every single record in my database can be uniquely identified?”

Step 4: Create the table.
1) If desired, rename the table at this point. If you rename it, make the name meaningful
to you. For this example, make no changes.
2) Leave the option Insert data immediately checked.
3) Click Finish to complete the table wizard. Close the window created by the table
wizard. You are now back to the main window of the database with the listing of the
tables, queries, forms, and reports.
Creating a table by copying an existing table

If you have a large collection of music, you might want to create a table for each type of
music you have. Rather than creating each table from the wizard, you can make a copy of the
original table. Each table can be named according to the type of music contained in it.
Possible names could include Classical, Pop, Country and Western, and Rock among others.
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1) Click on the Tables icon in the Database pane to see the existing tables.
2) Right-click on the CD-Collection table icon. Select Copy from the context menu.
3) Move the mouse pointer below this table, right-click, and select Paste from the
context menu. The Copy table window opens.
4) Change the table name to Pop and click Next.
5) Click the >> button to move all the Fields from the left window to the right window
and click Next.
6) Since all the Fields already have the proper File Type formating, no changes should be
needed. However, this is the time and place to make these changes if they are needed.
(See Caution below for the reason why.) Click Create. The new table is created.
Caution

Once tables have been created using the wizard, editing them is limited. The
Primary key can not be changed in any way. It is possible to add new fields and
remove fields. It is possible to change the field type when creating the field as well
as later as long as it is not the primary key. Once data has been added to the
database, deleting a field will also delete any data contained in that field. When
creating a new table, it pays to create the fields with the correct names, length and
format before data is added.

Caution

Tables can be deleted in a very simple way. But doing so removes all of the data
contained in every field of the table. Unless you are sure, do not delete a table.
To delete a table, right-click it in the list of tables. Select Delete from the context
menu. A pop up window asks if you are sure you want to delete the table. Once
you click Yes, the table and its data are gone forever unless you have a backup.

Creating tables in Design View

Design View is a more advanced method for creating a new table. It allows you to directly
enter information about each field in the table. We will use this method for the tables of our
database.
Note

While the Field type and formatting are different in Design View, the concepts are
the same as in the Wizard.

The first table to be created is Fuel. Its fields are FuelID, Date, FuelCost, FuelQuantity,
Odometer, and PaymentType. FuelCost uses currency and two decimal places. FuelQuantity
and Odometer uses the number format with 3 decimal places and 1 decimal place
respectively. PaymentType uses the text format.
1) Click Create Table in Design View.
2) FuelID entries:
a) Enter FuelID as the first Field Name.
b) Select Integer[INTEGER] as the Field Type from the dropdown list. (The default
setting is Text[VARCHAR].)
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Tip

Shortcut for selecting from the Field Type dropdown list: use the key for the first
letter of the choice. This might require using the letter more than once to get the
choice you want. You can cycle through the choices for a given letter by repeatedly
using that letter.
After typing the name of the field in the Fields column, use the Tab key to move to
the Field Type column. This will enter the field name and highlight the dropdown
list. You can then use the key for the first letter of your choice to select the field
type. Just remember to use it the correct number of times if necessary.

c) Change the Field Properties in the bottom section.
•

Change AutoValue from No to Yes (Figure 128).

Figure 128: Field Properties section (AutoValue)
d) Set FuelID as the Primary key.
•

Right-click on the green triangle to the left of FuelID (Figure 129).

Figure 129: Primary key field
•

Note

Click Primary Key in the context menu. This places a key icon in front of
FuelID.

The primary key serves only one purpose. Any name can be used for this field. It is
not necessary to use FuelID as the name of the primary key field. We have used it so
we know to which table it belong by its name.

3) All other entries:
a) Enter the next field name in the first column (Field Name column).
b) Select the Field Type for each field.
•

For Date use Date[DATE]. (Use the D key once to select it.)

•

PaymentType uses Text[VARCHAR], the default setting.

•

All other fields use Number[NUMERIC]. (Use the N key once to select it.)

c) Select the Field Properties (Figure 130).
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Figure 130: Field Properties section
•

FuelCost, FuelQuantity, and Odometer need changes in the Field Properties
section (Figure 130).
•

FuelQuantity: Change Length to 6 and Decimal places to 3. (Many fuel
pumps measure fuel to thousands of a gallon in the USA where I live.)

•

Odometer: Change the Length to 10 and the Decimal places to 1.

•

FuelCost: Change the Length to 5 and Decimal places to 2. Click the
Format example button. This opens the Field Format window (Figure
131).

Figure 131: Field Format options
•

Use Currency as the Category and anything in the Format list with two
decimal places.

4) Repeat these steps for each field in the table.
To access additional formatting options, click the button to the right of the Format
example panel (Format example button).
5) Description can be anything, or can be left blank. (Figure 132 is an example of this.)
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6) To save and close the table, select File > Close. Name the table Fuel.

Figure 132: Example of Description entries
Follow the same steps to create the Vacations table. The fields and their field types are listed
in Figure 132. Make sure you make Date field the primary key before closing, naming the
table Vacations, and saving it.
Creating tables for the list box

When the same information can be used in several fields, design a table for each type of
information. Each table will contain two fields: the information field, and ID in this order.
1) Follow the directions in “Creating tables in Design View” on page 169. In the table we
will create, the two fields can be Type and PaymentID. Make sure that the AutoValue is
set to Yes for the PaymentID field. Set the PaymentID field as the primary key. (See
Figure 133.)
2) Save the table using the name Payment Type.

Figure 133: Table in Design View
Note:

172

If you have several tables to create with the same fields, design one table and
produce the other tables by cutting and pasting. (See “Creating a table by copying
an existing table” on page 168.)
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Adding data to the list table

List tables do not require a form. Instead, add their data directly to the table. In this example,
use the names of the two people with a bank card and cash for cash purchases.
1) In the main database window, click on the Tables icon (Figure 125). Right-click on
Payment Type and select Open from the context menu.
a) Enter Dan in the first row. Use the tab key to move to the second row.
b) Enter Kevin in the second row.
c) Enter Cash in the third row.
2) Save and close the table window.
Tip

Note

The Enter key can also be used to move from field entry to field entry. For this
example, enter Jan. in the first Name field. Enter moves the cursor to the ID field.
Enter then moves the cursor to the second Name field.
The Down Arrow key can also be used to move from row to row.
The PaymentID field contains <AutoField> until you use the Enter key to move to
the second row. Then it becomes a 0. As you add the entries to each row, the rows of
the PaymentID field change to consecutive whole numbers. For example the first
three numbers in this field are 0,1,2.

Creating a View

A View is a query. Because of this, the details of how to create and use a View are in the
Creating queries section.

Figure 134: View of some fields from the Vacations table
A View is also a table. Its fields come from the fields of one or more tables of the database. It
provides a way to look at a number of fields without regard to the table to which any of the
fields belong. A View can consists of some of the fields on one table as in Figure 134. Or, it
can consist of fields from more than one field as in Figure 135.

Figure 135: View of fields from the Fuel and Payment Type tables
Caution

Data can not be entered into a View like it can be added to a table. It is strictly for
viewing data which has already been added.
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Defining relationships
Now that the tables have been created, what are the relationships between our tables? This is
the time to define them based upon the questions we asked and answered in the beginning.
When on vacation, we want to enter all of our expenses all at one time each day. Most of
these expenses are in the Vacations table, but the fuel we buy is not. So, we will relate these
two tables using the Date fields. Since the Fuel table may have more than one entry per date,
this relationship between the Vacations and Fuel tables is one to many. (It is designated 1:n.)
The Vacations tables also contains several fields for the type of payment used. For each field
listing the payment type, there is only one entry from the Payment Type table. This is a one to
one relationship: one field in one table to one entry from the other table. (It is designated 1:1.)
Other tables also contain fields for the type of payment. The relationship between these fields
of those tables and the Payment Type table are also 1:1.
Since the Payment Type table only provides a static list, we will not be defining a relationship
between the Payment Type table and the fields of the other tables which use the entries of the
Payment Type table. That will be done when the forms are created.
The Fuel and Maintenance tables do not really have a relationship even though they share
similar fields: Date, and Odometer. Unless a person is in a habit of regularly getting fuel and
having their vehicle serviced, the entries in these tables do not share anything in common.
Tip

As you create your own databases, you need to also determine where tables
are related and how.

New Relation icon
Add Tables
Figure 136: Relation design window
We begin defining relationships by Tools > Relationships. The Automobile –
OpenOffice.org Base: Relation design window opens (Figure 136). The icons we will use are
Add Tables and New Relation.
1) Click the Add Tables icon. The Add Tables window opens.
a) There are two ways to add a table to the Relation design window.
•

Double-click the name of the table. In our case, do this for both Vacations and
Fuel.

•

Or, click the name of the table and then click Add.

b) Click Close when you have added the tables you want (Figure 175).
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Figure 137: Added table lists
2) Defining the relationship between the Vacations and Fuel tables.
a) Two ways exist to do this:
●

Click and drag the Date field in the Fuel table to the Date field in the Vacations
table. When you release the left mouse button, a connecting line forms between
the two date fields (Figure 138).

Figure 138: Designation for a 1:n relationship
●

Or, click the New Relation icon. This opens the Relations window (Figure
139). Our two tables are listed in the Tables involved section.
•

In the Fields involved section, click the dropdown list under the Fuel label.

Figure 139: Setting the relationship between tables
•

Select Date from the Fuel table list.

•

Click in the cell to the right of this dropdown list. This opens a dropdown
list for the Vacations table.

•

Select Date from the Vacations table list. It should now look like Figure
140.

•

Click OK.
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Figure 140: Selected fields in a relationship
3) Modifying the Update options and Delete options section of the Relation window.
a) Right-click the line connecting the Date fields in the two table lists to open a
context menu.
b) Select Edit to open the Relation window (Figure 141).
c) Select Update cascade.
d) Select Delete cascade.

Figure 141: Update options and Delete options section
While these options are not absolutely necessary, they do help. Having these options selected
permits you to update a table that has a relationship defined with another table. It also permits
you to delete a field from the table.

Creating a database form
Databases are used to store data. But, how is the data put into the database? Forms are used
to do this. In the language of databases, a form is a front end for data entry and editing.
A simple form consists of the fields from a table (Figure 207). More complex forms can
contain much more. These can contain additional text, graphics, selection boxes and many
other elements. Figure 206 is made from the same table with a text label (Fuel Purchases), a
list box placed in PaymentType, and a graphic background.
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Figure 142: Fields of a simple form

Figure 143: Simple Form with additions

Using the Wizard to create a form
We will use the Wizard to create two forms: Fuel and Vacations. The Fuel form will be a
simple form while the Vacations form will contain a form and a subform. We will create the
Vacations form with its subform and let you modify the Fuel form using the same process.
In the main database window (Figure 125), click the Form icon. Double-click Use Wizard to
Create Form to open the wizard (Figure 144). Simple forms use only require some of these
steps while more complex forms may use all of them.
Step 1: Select fields.
1) Under Tables or queries, select Vacations as the table. Available fields lists the fields
for the Vacations table.
2) Click the right double arrow to move all of these fields to the Fields in the form list.
Click Next.

Figure 144: Form Wizard steps
Step 2: Set up a subform.
Since we have already created a relationship between the Fuel and Vacations tables, we will
use that relationship. If no relationship had been defined, this would be done in step 4.
1) Click the box labeled Add Subform.
2) Click the radio button labeled Subform based upon existing relation.
3) Fuel is listed as a relation we want to add. So, click Fuel to highlight it as in Figure
145. Click Next.
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Figure 145: Adding a subform
Step 3: Add subform fields.
This step is exactly the same as step 1. The only difference is that not all of the fields will
be used in the subform.
1. Select Fuel under Tables or queries.
2. Use the >> button to move all the fields to the right.
3. Click the FuelID field to highlight it.
4. Use the < button to move the FuelID to the left (Figure 146).
5. Click Next.

Figure 146: Selecting fields of a subform
Step 4: Get joined fields.
This step is for tables or queries for which no relationship has been defined. Since we want to
list all expenses by the day they occur in both the form and subform, we will joint the Date
fields of these two tables (Figure 147).
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Figure 147: Selection of joined subform and main form fields
1) Select Date from the First joined subform field dropdown list. This is the Date field in
the Fuel table. This is not the Primary key for the Fuel table, but it is known as a
Foreign key.
2) Select Date from the First joined main form field dropdown list. This is the Date field
in the Vacations table. This is the Primary key for the Vacations table. Click Next.
Note

Caution

It is possible to create a relationship between two tables that is based upon more
than one pair of fields. How to do that and why is discussed in the Base Guide.
When selecting a pair of fields from two tables to use as a relationship, they have to
have the same field type. That is why we used the Date field from both tables: both
their field types are Date[DATE].
Whether a single pair of fields from two tables are chosen as the relationship or two
or more pairs are chosen, certain requirements must be met for the form to work.
• No field from the subform can be the Primary key for its table. (FuelID
cannot be used.)
• Each pair of joined fields must have the same file type.
• One of the fields from the main form must be the Primary key for its table.
(Date would have to be used.)

Step 5: Arrange controls.
Note

Each control in a form consists of two parts: label and field. This step in
creating the form determine where a control's label and field are placed in
relationship with each other. The four choices from left to right are
Columnar left, Columnar - Labels on top, As Data Sheet, and In Blocks Labels Above (Figure 148).

1) Arrangement of the main form: Click Columnar - Labels on top. (The labels will be
placed above their field.
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2) Arrangement of the subform: Click As Data Sheet. (The labels are column headings
and the field entries are in spreadsheet format.) Click Next.

Figure 148: Control arrangements
Step 6: Set data entry.
Unless you have a need for any of these entries to be checked, accept the default settings.
Click Next.
Step 7: Apply styles.
1) Select the color you want in the Apply Styles list. (I chose the beige which is Orange 4
in the Color table.)
2) Select the Field border you want. (I prefer the 3-D look. You might want to experiment
with the different possible settings.)
3) Click Next.
Step 8: Set name.
1) Enter the name for the form. In this case, it is Fuel.
2) Click the circle in from of Modify the form. (This circle is called a radio button.)
3) Click Next. The form opens in Edit mode.

Modifying a form
We will be moving the controls to different places in the form and changing the background
to a picture. We will also modify the label for the PaymentType field as well as change the
field to a list box.
First, we must decide what we want to change and to what. The discussion will follow this
ten step outline.
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1) The Date field in the main form needs a dropdown capability. It also needs to be
lengthened to show the day of the week, month, day, and year.
2) Shorten the length of the payment fields (all fields containing the word payment).
3) The controls need to be move into groups: food, fuel subform, and miscellaneous.
4) Some of the labels need to have their wording changed. Some single words should be
two words. Some abbreviations should be used if possible (Misc. for miscellaneous).
5) The widths of several fields and labels need to be changed. Only Lunch, Supper,
Motel, and Tolls have acceptable lengths. But for a better appearance, changes will be
made to these as well.
6) All the fields whose label ends in Payment will be replaced with a list box. This box
contains the entries from the Payment Type table.
7) The Note field needs to be lengthened vertically and a scroll bar added. It also needs to
be moved.
8) Changes need to be made in the Date and PaymentType columns of the subform that
are similar to the changes in the main form.
9) Headings need to be added for each group in the main form.
10)The background needs to be changed to a picture. Some of the labels will have to be
modified so that they can be read clearly. The font color of the headings need to be
changed as well.
Here are some pointers that we will be using in these steps. The controls in the main form
consists of a label and its field. Sometimes we want to work with the entire control, and other
times we want to work with only the label or field. There are times when we want to work
with a group of controls.
•

Clicking a label or field selects the entire control. A border appears around the control
with eight green handles (Figure 149). You can then drag and drop it where you want.

•

Control+click a label or field selects only the label or field (Figure 150).

Figure 149: A selected control
•

By using the Tab key, you can change the selection from the field to the label or the
label to the field.

Figure 150: Selecting a field of a
control
•

Moving a group of controls is almost as easy as moving one of them.
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a) Click the field of one of the top left control to be moved to select it.
b) Move the cursor to just above and to the left of the selected control.
c) Drag the cursor to the bottom right of the group of controls and release the mouse
button.
●

As you drag the cursor, a dashed box appears showing what is contained in
your selection. Make sure it is big enough to include the entire length of all the
controls.

●

When you release the mouse button, a border with its green handles appears
around the controls you selected (Figure 151).

Figure 151: Selecting multiple
controls
d) Move the cursor over one of the fields. It changes to a double arrow (Figure 152).

Figure 152: Double arrow
e) Drag the group of controls to where you want them.
Before changing the Date field, we will move the Lunch and Tolls controls to the right 5 cm
(2 inches).
Tip

When either changing a size or moving a control, two properties of the Form Design
toolbar should be selected: Snap to Grid, and Guides when Moving. Your controls
will line up better, and an outline of what you are moving moves as the cursor moves.
You should also have both rulers active (Tools > Options > OpenOffice.org
Writer > View). Since the form is created in Writer, that is where you have to make
sure both horizontal and vertical rulers have a check in the box in front of them.

Note

I use centimeters when making changes in a form because centimeters are more
accurate than inches. When moving controls (fields and their labels), placement is
also more accurate. You can change your rulers from inches to centimeters by rightclicking each ruler and selecting centimeter from the context menu. You do not have
to understand what centimeters are. You only have to match your controls, labels, or
fields to specific numerals on a ruler.

Step 1: Change the Date field.
1) Control+click the Date field to select it (Figure 150).
2) Move the cursor over the middle green handle on the right
side. It should change to a single arrow (Figure 205).
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Figure 153: Single arrow
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3) Hold the left mouse button down as you drag the cursor to the right until the length is
6 cm. The vertical dashed line is lined up with the 6. (This is approximately 2.4
inches.) Release the mouse button.
4) Click the Control icon in the Form Controls toolbar (Figure 154). It is the one circled
in red. The Properties: Date Field window opens. Each line contains a property of the
field.

Figure 154: Form Controls toolbar
a) Go to the Date format property. This is a dropdown list with Standard (short) as
the default setting.
●

Click the default Standard (short) to open the list.

●

Click the Standard (long) entry to select it.

b) Scroll down to the Dropdown property. Its default setting is No. It is also a
dropdown list.

Tip

●

Click the default No setting to open the list.

●

Click Yes to select it.

To see what the Date field will look like, click the Form Mode On/Off icon (the
second icon from the left in Figure 154). You can do this any time you want to see
the form with the changes you have made.

Step 2: Shorten the width of a field.
All of the fields whose label contains the word payment are too wide. They need shortening
before the controls are moved.
1) Control+click the BPayment field (Figure 155).

Figure 155: Selecting a field
a) Move the cursor over the middle green handle on the right. The cursor becomes a
single arrow.
b) Drag the cursor to the left until the field is 2.5 cm wide (1 inch).
Note

If you have the Snap to Grid and Guides when moving icons selected in the Design
Format toolbar, you will see how wide the field is as you shorten it.

c) Repeat these steps to shorten these fields: Lpayment, SPayment, SnPayment,
Mpayment, and MiscPayment.
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Step 3: Move the controls to group them by category.
We want to move the controls so that they look like Figure 156.

Figure 156: Positioning of Controls
1) Click the first control you want to move. A border appears around the control with
eight green handles.
2) Move the cursor over the label or field of the control. It becomes a double arrow
(Figure 152).
3) Drag and drop the control to where you want it.
Caution

Do not use Control+click when moving a field. It moves either the field or the
label but not both. To move both, use a mouse click and drag to the desired spot.

4) Use the same steps to move the rest of the controls to where they belong.
Note

The only way to learn to do these two steps well is to practice them. Another way
exists which will place controls where you want them, but this is a more advanced
feature and will be explained in the Base Guide.

Step 4: Change the label wording.
Field names need to be single words. However, the labels for the fields can be more than one
word. So, we will change them. To do so, we will be editing the text in the label.
1) Control+click the SnackNo label. Do one of the following:
a) Right-click the SnackNo label.
●
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Select Control from the context menu (Figure 157). The window that opens is
labeled Properties: Label field. It contains all of the properties of the selected
label.
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Figure 157: Context menu
1) In the Label selection, click between the k and N in SnackNo.
2) Use the spacebar to make SnackNo into
two words.
3) Place a . (period) after the No.
1) Close the Properties window.

Figure 158: Multi-word label

b) Or, click the Control icon in the Form Control toolbar (Figure 159). The
Properties window opens. The rest of the steps are the same.

Figure 159: Form Controls toolbar
2) Use the same procedure to change these labels as well: BPayment to Payment,
LPayment to Payment, SPayment to Payment, Miscellaneous to Misc., SnackCost to
Snack Cost, MPayment to Payment, MiscPayment to Misc. Payment, and MiscNotes
to Misc. Notes.
Tip

All of the listings in the Properties window can be modified by you. For example,
by changing the Alignment from Left to Center, the word or words in the label are
centered within the Label. When you have some time, you might want to
experiment with different settings just to see the results you get.

Step 5: Change the widths of the labels and fields.
We want the following controls to be 2 cm wide (0.8 inches): Breakfast, Lunch, Supper,
Odometer, Snack No., Tolls, Snack Cost, Motel, and Misc. All of the payment fields were
changed in step 2, but Misc. Payment needs to be changed to 3 cm (1.2 inches).
1) Click Breakfast. The border around it appears with eight green handles.
2) Move the cursor over the middle green handle on the right. The cursor changes into a
single arrow.
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3) Drag and drop the cursor to the left to shorten the control or to the right to lengthen the
control. Use the guide lines to determine the width.
4) Repeat for the other listed controls.
Step 6: Replace fields with other fields.
We want to replace the PaymentType field with a List Box. Then we can choose the type of
payment from the Payment Type table rather than having to manually enter the type. In my
case, each of my payment types begins with a different letter. If I enter the first letter of the
payment type, the rest of the word automatically appears. I can then go to the next field.
1) Control+click the Payment field for Breakfast. The green handles appear around the
field but not around the Label.

Figure 160: Selecting a field of a control
2) Right-click within the green handles and select Replace with > List Box. (Figure 157
is the context menu which contains the Replace with select, and Figure 161 is the list
of replacement fields.)

Figure 161: Replacement fields
3) Click the Control icon in the Form Controls toolbar (Figure 159) to open the Properties
window.
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4) On the General tab, scroll down to the Dropdown selection. Change the No to Yes in
this dropdown list.

Figure 162: Dropdown list open to reveal choices
5) Click the Data tab.

Figure 163: Type of list contents dropdown list
a) Type of list contents is a dropdown list. Change it to Sql.
b) Type the following exactly as it is in the List contents box:
SELECT "Type", "Type" FROM "Payment Type"
Tip

You should be able to copy and paste SELECT "Type", "Type" FROM "Payment
Type" from above directly into the List content box. Just make sure you copy from
the S in SELECT to the double quotation mark after the phrase Payment Type and
no more than this.
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Figure 164: List content for payment type fields
Note

What you wrote is called an SQL command. The words SELECT and FROM are
written in capital letters because they are commands. When the command SELECT is
used, it requires a field name within quotation marks and then the field’s alias, also
within quotation marks. In this case, the field and its alias are the same. The FROM
command requires the name of the table which contains the field. Single-word table
names do not require quotation marks, but multiple-word table names do.

6) Repeat these steps for the payment fields for Lunch, Supper, Motel, Snacks, and Misc.
The main form should look like Figure 165 as far as where the controls are located. It
also shows what the Note control should look like. Those changes are explained in the
next step.
7) Close the Properties window.

Figure 165: Position of controls in main form
Step 7: Change the Note field.
We want the Note control where it is located in Figure 165. Since it has a memo field type, it
needs a vertical scrollbar for additional text space if desired.
1) Click the Note control.
2) Control+click the Note field. The green handles should surround the Note field but not
its label.
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3) Click the Control icon to open the Properties window (Figure 154).
4) Scroll down to the Scrollbars setting. Change the selection from None to Vertical in
this dropdown list.

Figure 166: Scrollbar selections in Properties window
5) Close the Properties window.
6) Lengthen the Note field.
a) Move the cursor over the middle green handle at the bottom of the Note field. It
becomes a vertical single arrow.
b) Drag the cursor down until the length is 6 cm (2.4 inches).
Step 8: Change labels and fields in a subform.
The Date column needs to be widened. The field in the PaymentType column needs to be
changed to a list box. The label for PaymentType column needs to be two words.
1) Change the PaymentType column.
a) Right-click the label PaymentType to open a context menu (Figure 167).

Figure 167: Choices for modifying a control in a subform
b) Select Replace with, and then select List box from the context menu.
c) Again right-click the label PaymentType to open a context menu.
d) Select Column. This opens the Properties window. (Figure 168)
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e) In the Label box, change PaymentType to Payment Type.

Figure 168: Properties window for control in a subform
f) Click the Data tab.
g) From the Type of list contents dropdown list, select sql.
h) Type the following exactly as it is written:
SELECT "Type", "Type" FROM "Payment Type"
i) Close the Properties window.
Tip

Step 6: Replace fields with other fields., beginning with part 5, contains more
detailed instruction.

Step 9: Add headings to groups.
1) Make sure the cursor in in the upper left corner. If it is not, click in that corner to move
it there.
2) Use the Enter key to move the cursor to the fifth line from the top.
3) Change the Apply Styles dropdown list from Default to Heading 2 (Figure 169).

Figure 169: Apply Styles list
4) Use the spacebar to move the cursor to where you want the heading to start.
5) Type the heading Meals.
6) Use the spacebar to move the cursor to the center of snack area.
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7) Type the heading Snacks.
8) Use the Enter key to move the cursor between the Supper control and the subform.
9) Use the spacebar to move the cursor to the center of the subform.
10) Type the heading Fuel Data.
Note

If you know how to use styles, you can open the Styles and Formatting window
using F11. Right-clicking the Heading 2 paragraph style allows you to modify the
appearance of all three headings. See the Writer Guide Chapter 6.

Step 10: Change the background of a form.
The background for a form can be a color, or a graphic (picture). You can use any of the
colors in the Color Table at Tools > Options > OpenOffice.org > Colors. If you know how
to create custom colors, you can use them. You can also use a picture (graphic file) as the
background. We will use a picture found in OOo: sky.gif (Figure 170). Since the background
is dark in places, many of the labels and headings will need changing in order to be seen.

Figure 170: background graphic
1) Select the labels of the top row of controls.
a) Control+click the Date label.
b) Control+shift+click the rest of the labels of the top row. The border will gradually
grow to the right as you do this until all the labels are enclosed in it.

Figure 171: Selecting multiple labels at one time
c) Click the Control icon in the Design Form toolbar to open the Properties window.
d) Change the Background selection from Default to Light cyan. (This is a dropdown
list.)
2) Select the other labels in the same way and then change their background color.
3) Close the Properties window.
Note

I have chosen to use Light cyan as the background color for my labels. You are free
to choose whatever color you wish including a custom color you earlier created.

4) Press the F11 key to open the Styles and Formatting window (Figure 172). Notice the
left icon has a black outline around it. This is the Paragraph Styles icon. Below it is a
list of paragraph styles including headings.
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Figure 172: Top portion of the Styles and Formatting window
a) Right-click Heading 2 and select Modify from the context menu.

Figure 173: Tabs of the Paragraphs: Heading 2 window
b) On the Paragraph Style dialog (Figure 173), click the Font Effects tab.

Figure 174: Left side of Font Effects tab
c) Change the Font color dropdown list to Light cyan.
d) Click OK to close the Paragraph Style: Heading 2 dialog.
e) Press the F11 key to close the Formatting and Styles window.
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Tip

Learning how to use styles can be very helpful at times. By using styles, we
changed the font color for all three headings at one time. There are other methods of
changing the font color, but they require repeating the same steps for each heading.

5) Right-click the background and select Page from the context menu.
6) Click the Background tab (Figure 175).

Figure 175: Background tab of Page Styles
a) Change the As dropdown list from Color to Graphic.
b) Search for this file: sky.gif. It is located in the Gallery folder of OOo.
c) Click the Browse button in the File section. Browse to the folder containing
sky.gif.
d) Select this file and click Open.
e) In the Type section, select Area.
f) Click OK to close the Page Style: Default window.
The form should look like Figure 177.
Step 11: Change the tab order.
The Tab key moves the cursor from field to field. This is much easier to do than to click each
field to enter data into it. It also permits us to group our expenses into areas before we begin
entering data. For example, all of our meal receipts can be grouped together as can our snacks
and also our fuel purchases.
1) Control+click the Date field.
2) Click the Form Design icon in the Form Controls toolbar to open the Form Design
toolbar (Figure 176).

Figure 176: Form Controls toolbar with Form Design icon circled
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Figure 177: Finished form
3) Click the Activation Order icon (Figure 178).

Figure 178: Form Design toolbar with Activation Order icon circled
4) Rearrange the order of the fields in the Tab Order window (Figure 179).

Figure 179: Tab Order window
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a) Find the txtMPayment listing near the bottom of the list and click it.
b) Click the Move Up button until txtPayment is just below fmtMotel.
c) Use the same two steps to put the fields in the same order as in Figure 180.

Figure 180: Tab order for the main form
d) Click OK.
5) Save and close the form.
6) Save the database.

Creating forms in Design View
This method requires using the Form Controls and Form Design toolbars extensively. These
techniques are beyond the scope of this document. Instructions for creating forms using
Design view will be described in the Database Guide.

Creating subforms in Design View
Again, this is beyond the scope of this document. Creation of subforms in Design View will
be described in the Database Guide.
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Accessing other data sources
OpenOffice.org allows data sources to be accessed and then linked into OOo documents. For
example, a mail merge links an external document containing a list of names and addresses
into a letter, with one copy of the letter being generated for each entry.
To register a data source, choose File > New > Database to open the Database Wizard.
Select Connect to an existing database. This allows access to the list of data sources that
can be registered with OOo. These data sources can be accessed similarly to a dBase database
as explained in the next section.
Once a data source has been registered, it can be used in any other OOo component (for
example Writer or Calc) by selecting View > Data Sources or pressing the F4 key.
Tip

Mozilla Address Books and dBase databases (among others) can be accessed, and
entries can be added or changed.

Caution

Spreadsheets can be accessed, but no changes can be made in the spreadsheet
entries. All changes in a spreadsheet sheet must be made in the spreadsheet, itself.
Update the database afterwards to see the changes made in the spreadsheet.

Accessing a dBase database
1) File > New > Database opens the Database Wizard window.
Note

Clicking the New icon and Database in the drop-down menu also open the
Database Wizard window. (See Figure 124.)

2) Select Connect to an existing database. Pressing the TAB key highlights the
Database type drop-down list. Typing D selects dBase. Click Next.
Note

Clicking the arrows opens a menu from which you can select dBase (Figure 181).

Figure 181: Database type selection
3) Click Browse and select the folder containing the database. Click Next.
4) Accept the default settings: Register the database for me, and Open the database for
editing. Click Finish. Name and save the database in the location of your choice.
5) Create the Form using the Form Wizard as explained in “Creating a database form”
beginning on page 176.
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Accessing a Mozilla address book
Accessing a Mozilla Address Book is very similar to accessing a dBase database.
1) Select File > New > Database.
2) Select Connect to an existing database. Select Mozilla Address Book as the database
type (Figure 181).
3) Register this data source.
These are steps 1, 2 and 4 of “Accessing a dBase database” on page 196.

Accessing spreadsheets
Accessing a spreadsheet is also very similar to accessing a dBase database.
1) Select File > New > Database.
2) Select Connect to an existing database. Select Spreadsheet as the Database type
(Figure 181).
3) Click Browse to locate the spreadsheet you want to access. If the spreadsheet is
password protected, check the Password required box. Click Next.
4) If the spreadsheet requires a user’s name, enter it. If a password is also required, check
its box. Click Next.
Caution

This method of accessing a spreadsheet does not allow you to change anything in
the spreadsheet. All modifications must be made in the spreadsheet itself. This
method only allows you to view the contents of the spreadsheet, run queries, and
create reports based upon the data already entered into the spreadsheet.

Registering databases created by OOo2.x
This is a simple procedure. Tools > Options > OpenOffice.org Base > Databases. Under
Registered databases,there is a list of these databases. Below this list are three buttons:
New..., Delete, Edit... To register a database created by OOo2.x:
1) Click New.
2) Browse to where the database is located.
3) Make sure the registered name is correct.
4) Click OK.
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Using data sources in OpenOffice.org
Having registered the data source, whether a spreadsheet, text document, external database or
other accepted data source, you can use it in other OpenOffice.org components including
Writer and Calc.

Viewing data sources
Open a document in Writer or Calc. To view the data sources available, press F4 or select
View > Data Sources from the pull-down menu. This brings up a list of registered databases,
which will include Bibliography and any other database registered.
To view each database, click on the + to the left of the database’s name. (This has been done
for the Automobile database in Figure 182.) This brings up Tables and Queries. Click on the
+ next to Tables to view the individual tables created. Now double-click on a table to see all
the records held in it.

Figure 182: Databases

Editing data sources
Some data sources can be edited in the View Data Sources dialog. A spreadsheet can not. A
record can be edited, added or deleted.
The data is displayed on the right side of the screen. Click in a field to edit the value.
Beneath the records are five tiny buttons. The first four move backwards or forwards through
the records, or to the beginning or end. The fifth button, with a small star, inserts a new
record (Figure 183).
Insert new record
Figure 183: View Data Sources navigation buttons
To delete a record, right-click on the gray box to the left of a row to highlight the entire row,
and select Delete Rows to remove the selected row.

Figure 184: Deleting a row in the Data View window
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Launching Base to work on data sources
You can launch OOo Base at any time from the View Data Source pane. Just right-click on a
database or the Tables or Queries icons and select Edit Database File. Once in Base, you can
edit, add and delete tables, queries, forms and reports.

Using data sources in OOo documents
To insert a field from a table into a document (for example a Calc spreadsheet or Writer
document), click on the field name (the gray square at the top of the field list) and, with the
left mouse button held down, drag the field onto the document. In a Writer document, it will
appear as <FIELD> (where FIELD is the name of the field you dragged). In Calc it will
appear as a text box.
One common way to use a data source is to perform a mail merge. Selecting Tools > Mail
Merge Wizard or clicking on the Mail Merge icon (a small paper-and-envelope icon on the
View Data Source pane) launches the Mail Merge wizard which steps through creating a mail
merge document. This is covered in Chapter 11 (Using Mail Merge) in the Writer Guide.

Entering data in a form
Records are used to organize the data we enter into a form. They also organize the data we
enter into a subform (Figure 185).

Figure 185: Single Record
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Each type of field allows a different method to enter the data. In most if not all cases, more
than one method can be used.
The first step to entering data in a form is to open it from the main database window.
•

Click the Forms icon in the Database list.

•

Find the form’s name in the Forms list (Vacations).

•

Double-click the form’s name.

The quickest way to enter a date in the Date field is to click the arrow that opens the
dropdown calendar. Then click the date you want (Figure 186). Use the Tab key to go to the
Odometer field.
•

Click the left arrow before May to go back one month (April 2007).

•

Click the right arrow after 2007 to go forward one month (June 2007).

•

Multiple clicks in either direction will change the month and year the same number of
times as the number of clicks.

Figure 186: Calendar dropdown
The Odometer, Tolls, and Motel fields are numerical fields. Enter values directly into them,
or use the up and down arrows. When the value is entered, use the Tab key to go to the next
field.
•

The up arrow increases the value, and the down arrow decreases the value.

•

These two arrows only change the numerals to the left of the decimal place.

•

Numerals to the right of the decimal place must be changed by deleting them and
typing the desired ones.

The Motel's Payment field is a dropdown list. If as in my case, all of the elements of the list
start with different letters, typing the first letter will select the desired letter.
•

•
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If two or more elements of the list have the same first letter, repeated typing of the first
letter will cycle through the elements with this same first letter. So, if you accidentally
go past the the element you wanted, you can keep typing the first letter until it
reappears again.
When the selection is correct, use the Tab key to go to the Misc. field.
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The rest of the fields of the main form are either numerical fields or dropdown lists until we
reach the Misc. Notes field. It is a text field. Type anything you desire in this field just as you
would any simple text editor.
Caution

Since the Tab key is used to move between fields, it can not be used in a text field.
All spacing must be done by the spacebar. Finally, the Enter key only acts as a line
break to move the cursor to the next line.

Note

If we did not have a subform for fuel data, using the Tab key would save all of the
fields, clear them, and make the form ready to accept data on the second record.

Since we have a subform form, using the Tab key places the cursor in the first Date field of
the subform with the date automatically entered to match the Date field of the main form.
The FuelCost, FuelQuanity, and Odometer fields are numerical fields. The Payment field is a
dropdown list. Enter the data just as you did in the main form, and use the Tab key to go to
the next field.
When you use the Tab key to leave the Payment field, it goes to the Date field of the next line
and automatically enters the date. Now you can enter your second set of fuel data for this day.
To move to another record when the form has a subform, the directional arrows at the bottom
must be use. There are four of them from left to right: First Record, Previous Record, Next
Record, and Last Record (Figure 187). To the right of these arrows in the New Record icon.
To create a new record while in another record, click the New Record icon. And, two choices
exist for creating a new record following the present record.
•

Click the Next Record icon.

•

Or, click the New Record icon.
Figure 187: Navigation arrows of a form

Tip

The number in the Record box is the number of the record whose data is shown in
the form. (The data from the second record of the Vacations form was displayed
when I took the screenshot for Figure 187.)
If you know the number of the record you want, you can enter it into the record box
and then use the Enter key to take you to that record.

Figure 188 is a record with data inserted in its fields. Note that not all fields have data in
them. It is only necessary to have data in every field if you determine ahead of time to require
all fields contain data.
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Figure 188: Sample record of the Vacation form and subform

Creating queries
Queries are used to get specific information from a database. Using our CD-Collection table,
we will create a list of albums by a particular artist. We will do this using the Wizard. The
information we might want from the Fuel table includes what our fuel economy is. We will
do this using the Design View.
Note

Queries blur the differences between a database and a data source. A database is
only one type of data source. However, searching for usable information from a data
source requires a query. Since the query (one part of a database) does this, the data
source appears to become one part of that database: its table or tables. Query
results, themselves, are special tables within the database.

Using the Wizard to create a query
Queries created by the wizard provide a list or lists of information based upon what one
wants to know. It is possible to obtain a single answer or multiple answers, depending upon
the circumstances. Queries which require calculations are best created with the Design view.
In the main database window (Figure 125), click the Queries icon in the Databases section,
then in the Tasks section, click Use Wizard to Create Query. The Query Wizard window
opens (Figure 189). The information we want is what albums are by a certain musical group
or individual (the album’s author). We can include when each album was bought.
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Note

When working with a query, more than one table can be used. Since different tables
may contain the same field names, the format for naming fields in a query is Table
name and field name. A period (.) is placed between the table name and the field
name.

Figure 189: First page of the Query Wizard
Step 1: Select the fields.
1) Select the CD-Collection table from the dropdown list of tables.
a) If the Tables selection is not Table: CD-Collection, click the arrow (circled in red
in Figure 189).
b) Click Table: CD-Collection in the list to select it.
2) Select fields from the CD-Collection table in the Available fields list.
a) Click AlbumTitle, and use the > button (black oval in Figure 189) to move it to the
Fields in Query list.
b) Move the Artist and DatePurchased fields in the same manner.
Tip

To change the order of the fields, select the field you want to move and click the up
or down arrow to move it up or down (circled in magenta in Figure 189).

c) Use the up arrow to change the order of the fields: artist, album, and date
purchased.
●

Click the CD-Collection.Artist field.

●

Click the up arrow to move it above CD-Collection.AlbumTitle.
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Figure 190: List of fields added to the query
d) Click Next.
Step 2: Select the sorting order.
Up to four fields can be used to sort the information of our query. A little simple logic helps
at this point. Which field is most important?
In our query, the artist is most important. The album title is less important, and the date
purchased is of least importance. Of course, if we were interested in what music we bought
on a given day, the date purchased would be the most important.

Figure 191: Sorting order page
1) Click the first Sort by dropdown list.
a) Click CD-Collection.Artist to select it.
b) If you want the artists to be listed in alphabetical order (a-z), select Ascending on
the right. If you want the artist listed in reverse order (z-a), select Descending on
the right (Figure 191).
2) Click the second Sort by dropdown list.
a) Click CD-Collection.ArtistTitle
b) Select Ascending or Descending according to the order you want.
3) Repeat this process for CD-Collection.DatePurchased.
4) Click Next.
Step 3: Select the search conditions.
The search conditions available are listed in Figure 192. They allow us to compare the name
we entered with the names of the artist in our database and decide whether to include a
particular artist in our query or not.
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Figure 192: Search conditions in the Query Wizard
•

is equal to: the same as

•

is not equal to: not the same as

•

is smaller than: comes before

•

is greater than: comes after

•

is equal or less than: the same as or comes before

•

is equal or greater than: the same as or comes after

•

like: similar to in some way

Note

These conditions apply to numbers, letters (using the alphabetical order), and dates.

1) Since we are only searching for one thing, we will use the default setting of Match all
of the following.
2) We are looking for a particular artist, so select is equal to.
3) Enter the name of the artist in the Value box. Click Next.
Step 4: Select type of query.
We want simple information, so the default setting: Detailed query is what we want. Click
Next at the bottom of the window.
Note

Since we have a simple query, the Grouping and Grouping conditions are not
needed. Those two steps are skipped in our query.

Step 5: Assign aliases if desired.
We want the default settings. Click Next.
Step 6: Overview.
Name the query (suggestion: Query_Artists). To the right of this are two choices. Select
Display Query. Click Finish.
Step 7: Modify the query.
We are skipping this step since we have nothing to modify. If you select the Modify Query
choice, the query would open in Design view. To make modifications, follow the instructions
in the next section, “Using the Design View to create a query”.
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Using the Design View to create a query
Creating a query using Design View is not as hard as it may first seem. It may take multiple
steps, but each step is fairly simple.
What fuel economy is our vehicle getting (miles per gallon in the USA)? This question
requires creating two queries, with the first query being used as part of the second query.
Caution

The procedures we will be using only work with relational databases. This is
because of how relational databases are constructed. The elements of a relational
database are unique. (The primary key insures this uniqueness.) That is, there are no
two elements which are exactly alike. This allows us to select specific elements to
place into our queries. Without the elements of the relational database being unique
from all other elements, we could not perform these procedures.

Step 1: Open the first query in Design View.
Click Create Query in Design View.
Step 2: Add tables.

Figure 193: Add Tables or Query window
1) Click Fuel to highlight it.
2) Click Add.
3) Click Close.
Tip

Move the cursor over the bottom edge of the fuel table (Figure 194). The cursor
become a single arrow with two heads. Drag the bottom of the table to make it
longer and easier to see all of the fields in the table.

Figure 194: Fuel table in query
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Step 3: Add fields to the table at the bottom.
1) Double-click the FuelID field in the Fuel table.
2) Double-click the Odometer field.
3) Double-click the FuelQuantity field.
The table at the bottom of the query window should now have three columns (Figure 195).

Figure 195: Query table
Step 4: Set the criterion for the query.
We want to the query's FuelID to begin with the numeral 1.
1) Type >0 in the Criterion cell under FuelID in the query table
2) Click the Run Query icon in the Query Design toolbar. This icon is circled in red in
Figure 196.

Figure 196: Query Design toolbar
Figure 197 contains the Fuel table with my entries and the query results based upon the Fuel
table.

Figure 197: Fuel table and query of the fuel table
Step 5: Save and close the query.
Since this query contains the ending odometer reading for our calculations, name it EndReading when saving it. Then close the query.
Step 6: Create the query to calculate the fuel economy.
1) Click Create Query in Design View to open a new query.
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2) Add the Fuel table to the query just as you did in step 2: Add tables. But, do not close
the Add Tables window.
3) Add the End-Reading query to this query.
a) Click the Query radio button to get the list of queries in the database (Figure 198).

Figure 198: Selecting queries to add to another
query
b) Click End-Reading.
c) Click Add, and then click Close.
Step 7: Add fields to the table at the bottom of the query.

Figure 199: Tables in this query
We are going to calculate the fuel economy. To do this we need the FuelQuantity and distance
traveled. Since the FuelQuantity we want to use is at the ending odometer reading, we will
use the End-Reading query to get it. We will also use the Odometer field from the Fuel table
and End-Reading query.
1) Double-click FuelQuantity in the End-Reading query.
2) Double-click Odometer in the End-Reading query.
3) Double-click Odometer in the Fuel table.

Figure 200: Added fields to the query
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Step 8: Enter the FuelID difference field.
We want the difference between the FuelID value of the Fuel table and FuelID value of the
End-Reading query to equal one (1).
1) Type "End-Reading".FuelID - Fuel.FuelID in the field to the right of the Odometer
field of the Fuel Table (Figure 201).
Type the numeral 1 (one) in the Criterion cell of this column.
Caution

When entering fields for these calculations, you must follow this format: table or
query name followed by a period follow by the field name. For hyphenated or
multiple-word names (table or query), use double quotes around the table or query
name. The query will then add the rest of the double quotes as in Figure 201.
Use the arithmetical symbol between the two. More than one calculation can be
done by using parentheses to group the arithmetical operations.

Figure 201: Typing in calculation of fields
2) Calculate the distance traveled (Figure 202):
•

Type "End-Reading".Odometer – Fuel.Odometer in the Field cell.

•

Type >0 in the Criterion cell.

Figure 202: Field for distance traveled calculations
3) Calculate fuel economy (Figure 203):
a) Type ("End-Reading".Odometer – Fuel.Odometer)/"End-Reading".FuelQuanity in
the Field in the next column to the right.
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Figure 203: Fuel economy calculation field
Step 9: Run the query and make some modification.
After we run the query to make sure it works correctly, we will hide all of the fields that we
do not need.
1) Click the Run Query icon in the Design Query toolbar. (Figure 196) The results are in
Figure 204.

Figure 204: Result of running the fuel economy query
Notice that not all of the last column label is visible because some of the labels are
long. We can fix this problem by using an alias for many of the fields. The labels are
replaced by their aliases.
2) Add Aliases: Type in aliases as they are listed in Figure 200.

Figure 205: Query table with aliases added
3) Run the query again. The results are in Figure 199.

Figure 206: Query run with aliases
We really do not need the column showing the difference between the FuelID fields
from the table and query. So, we will hide it. While it will not be visible, it will still
be used in the calculations.
4) Hide a field that does not need to be seen.
Remove the check in the box of the Visible cell as in Figure 193.
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Figure 207: Making a field invisible in a query run
5) Rerun the query (Figure 190).

Figure 208: Query run with aliases
Step 10: Close, save, and name the query.
My suggestion for a name is Fuel Economy.
There are obviously other calculations that can be made in this query such as cost per
distance traveled and how much of the cost belongs to each of the payments types.
Note

To fully use queries requires a knowledge of mathematics and specifically set
operations (unions, intersections, and, or, complements, and any combinations of
these). For example, we listed all of our criteria in one row. That means that all of
these criteria have to be met before a row of values will be created in the query.
This is how the and operator works on sets.
It also requires having a copy of the Hsqldb User Guide available from
http://hsqldb.org/.

Creating reports
Reports provide information found in the database in a useful way. In this they are similar to
queries. Reports are generated from the database’s tables or queries. They can contain all of
the fields of the table or query or just a selected group of fields. Reports can be static or
dynamic. Static reports contain the data in the selected fields at the time the report was
created. Dynamic reports can be updated to show the latest data.
For example, a report on vacation expenses divided into categories should probably be a
static report because it is based upon specific data that does not change. However, a report on
the fuel data should probably be a dynamic report, because this report depends upon data that
does change.
Caution

All reports are based upon a single table or query. So you need first to decide what
fields you want to use in the report. If you want to use fields from different tables,
you must first combine these fields in a single query. Then you can create a report
on this query.
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An example of this caution is creating a report on vacation expenses. Fuel costs are one part
of that report as are meal costs. These values are contained in fields of two different tables:
Vacations and Fuel. So this report requires creating a query.

Creating a static report
We will create a report on vacation expenses. Certain questions need to be asked before
creating the report.
•

What information do we want in the report?

•

How do we want the information arraigned?

•

What fields are required to provide this information?

•

Will a query have to be created because these fields are in different tables?

•

Are there any calculations required in the data before being added to the report?

The expenses for our vacation are motel, tolls, miscellaneous, breakfast, lunch, supper,
snacks, and fuel. One possible report would simply list the totals of each of these expense
groups. Another possible report would list the expense totals for each day of the vacation. A
third possible report would list the totals for each expense group for each type of payment.
(This would let us know where the money came from to pay the expenses.) At the present
time, using the data from the queries in a spreadsheet is the best way to handle reports like
this. In the near future, the report feature will include these abilities.
For our purposes, we will create two reports. The first one will list the expenses each day
other than fuel. The second report will list the fuel costs each day.
The fields we will need for the first report from the Vacations table are: Date, Motel, Toll,
Breakfast, Lunch, Supper, SnackCost, and Miscellaneous. This report will not require an
additional query.
The second report involves the Fuel table. Since fuel was purchased and entered into this
table at times other than during the vacation, a query needs to be created that contains only
the fuel purchased during the vacation.
Vacations table report
1) Create a new report.
a) Click the Reports icon in the Database list in the Automobile – OpenOffice.org
window (Figure 125).
b) In the Tasks list, click Use Wizard to Create Report. The Report Wizard window
opens.
2) Select the fields.
a) Select Table: Vacations in the Tables or Queries dropdown list.
b) Use the > to move these fields from the Available fields list to the Fields in report
list: Date, Motel, Tolls, Miscellaneous, Breakfast, Lunch, Supper, and SnackCost
(Figure 184). Click Next.
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Figure 209: Adding fields to a report
3) Label the fields.
Shorten Miscellaneous to Misc. Click Next.
4) Group fields.
Since we are grouping by the date, use the > button to move the Date field to the
Grouping list. Click Next.

5) Sort options.
We do not want to do any additional sorting. Click Next.
6) Choose layout.
We will be using the default settings for the layout. Click Next.
Note

If you feel adventurous, try selecting some of the other layout choices. After
selecting a choice, drag and drop the Report Wizard window so that you can see
what you have selected. (Move the cursor over the Heading of this window, and
then drag and drop.)

7) Create report.
a) Label the report: Vacation Expenses.
b) Select Static report.
c) Click Finished.
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Vacation fuel report
1) Create a query containing only fuel bought on the days of the vacation.
a) Open a query in Design View.
b) Follow the steps for adding tables in Add tables. Add the Fuel table.
c) Double-click these fields in the Fuel table listing: Date and FuelCost to enter them
in the table at the bottom of the query.
d) In the Criterion cell of the Date field, type the following:
BETWEEN #5/25/2007# AND #5/26/2007#

Figure 210: Setting the criterion for a query
e) Save, name, and close the query. (Suggestion: Vacation Fuel Purchases.)
Tip

When using dates in a query, enter them in numerical form MM/DDYYYY or
DD/MM/YYYY depending upon your language's default setting for dates (my
default setting is MM/DD/YYYY).
All dates must have a # before and after it. Hence, May 25, 2007 is written
#05/25/2007#.

2) Open a new report.
a) Right-click the Vacation Fuel Purchases query.
b) Select Report Wizard from the context menu.
Note

When a new report is opened in this way, the query used to open it is automatically
selected in the Tables or Queries dropdown list.

3) Create the report.
Use >> to move both fields from the Available Fields to the Fields in Report list.
Click Next.
4) Label fields.
Add a space to FuelCost to make it Fuel Cost (two words). Click Next.
5) Group fields.
a) Click Date to highlight it.
b) Use > to move the Date field to the Groupings list. Click Next.
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6) Choose layout.
We will be making no changes in the layout. Click Next.
7) Create report (final settings).
a) Use the suggested name, which is the same as the query.
b) Select Static report. Click Finish.

Creating a dynamic report
We will create a report with some statistics on our fuel consumption. To do this, we have to
modify two queries: End-Reading and Fuel Economy. We will be adding the FuelCost field to
the End-Reading query. Then we will add the FuelCost field from the End-Reading query to
the Fuel Economy query.
Tip

When opening a query to edit it, it might appear as in Figure 174. If you move your
cursor over the black line (circled in red), it becomes a double headed arrow. Drag
and drop it to a lower position.

Figure 211: Appearance of query when opened for editing
1) Add the FuelCost field to the End-Reading query:
a) Right-click the End-Reading query and select Edit from the context menu.
b) In the Fuel table list, double-click to add FuelCost to the bottom table (Figure
171).
c) Save and close the query.
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Figure 212: Adding an additional field to the query
2) Add the FuelCost field from the End-Reading query to the Fuel Economy query.
a) Right-click the Fuel Economy query and select Edit from the context menu.
b) Double-click the FuelCost field in the End-Reading query list to the table at the
bottom.
3) Add a calculation field to the right of the FuelCost field.
a) Type the following in the Field cell:
"End-Reading".FuelCost/("End-Reading".Odometer – Fuel.Odometer)
b) Type the following in the Alias cell:
cost per mile
Note

If you use the metric system, cost per km is the appropriate alias.

4) Save and close the query.
5) Open a new report.
Right-click the Fuel Economy query and select Report Wizard.
6) Select fields.
Move all the fields from the Available fields to the Fields in report list. Use the >> to
do so. Click Next.
7) Label fields.
Change FuelCost to Fuel Cost by placing a space between the words. Click Next.
8) Group fields.
Use > to move the Date field to the Groupings list. Click Next.
9) Sort options: the wizard skipped this one.
10)Choose layout.
Accept the default. Click Next.
11)Create the report.
a) Change the report name to Fuel Statistics.
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b) The default setting is Dynamic report, so no change is necessary.
c) Select Modify report layout. Click Finish.

Modifying a report
At the end of the last section, we left the Fuel Statistics report open in the edit mode (Figure
166). We will be working on that report. These same steps can be used with any report that
you open for editing.

Figure 213: A report in edit mode
The Author is the name you listed in Tools > Options > OpenOffice.org > User Data. The
date is not correct. The columns need to be moved to the left to give a better appearance.
None of the numbers are correct, but their only purpose is to show the number of decimal
places.
Step 1: Change the date.
1) Click to the right of the date (4/26/20) so that the cursor is next to the field. Use the
Backspace key to erase the date.
2) Insert > Fields > Date. This places today’s date where the original date was.
3) Changing the date formating:
a) Double-click the date field you just inserted. The Edit Fields: Document window
opens (Figure 164).

Figure 214: Modifying a date field
b) Since this is a dynamic report, change the Select field from Date (fixed) to Date.
c) Change the Format to what you desire. (I use the Friday, December 31, 1999
choice.) Click OK.
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Step 2: Change the column widths.
The column widths can be changed by moving the cursor over the right border of each
column so that it becomes a double-headed arrow. Then drag and drop it where you want it.
This has to be done for each column in each table in the report. This can also be done with
the last column on the right even though there is no black border. It should now look
something like Figure 163.

Figure 215: Realigned columns in a report
Step 3: Change the number formating in the cells.
The fuel quantity should have three decimal places. The Begin, End, and Distance should
have one decimal place. Fuel Cost should be currency and have two decimal places, and Cost
per mile should have three decimal places.
1) Right-click the cell below Quantity to open the context menu. (The cell is circled in
red in Figure 163.)
2) Select Number format.
3) In the Options section (Figure 162),
a) Change the number of Decimal places to 3.
b) Click the green checkmark. Click OK.

Figure 216: Option section of the Number Formating window
4) Change the Fuel Cost field.
a) Right-click in the cell below Fuel Cost.
b) Select Number Format.
c) In the Category list, select Currency. Click OK.
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5) Change the Cost per mile field.
a) Right-click in the cell below Cost per mile.
b) Select Number Format.
c) In the Category list, select Currency.
d) In the Option section:
●

Set the number of decimal places to 3.

●

Click the green checkmark.

e) Click OK.
Step 4: Save and close the report.
Double-click the report. It should now look like Figure 160.

Figure 217: Final report
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Chapter 11
Getting Started with Math
OpenOffice.org's Equation Editor

What is Math?

What is Math?
Math is OpenOffice.org (OOo)’s component for writing mathematical equations. It is most
commonly used as an equation editor for text documents, but it can also be used with other
types of documents or stand-alone. When used inside Writer, the equation is treated as an
object inside the text document.
Note

The equation editor is for writing equations in symbolic form (as in equation 1). If
you want to evaluate a numeric value, see the Calc Guide.

df  x
−1
2
=ln  xtan  x 
dx

(1)

Getting started
To insert an equation, go to Insert > Object > Formula.
The equation editor opens at the bottom of the screen, and the floating Selection window
appears. You will also see a small box (with a gray border) in your document, where the
formula will be displayed, as shown in Figure 218.

Figure 218. Equation Editor, Selection window, and location of resulting equation.
The equation editor uses a markup language to represent formulas. For example, %beta
creates the Greek character beta (  ). This markup is designed to read similar to English
a
whenever possible. For example, a over b produces a fraction: .
b
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Entering a formula
There are three ways to enter a formula:
•

Select a symbol from the Selection window.

•

Right-click on the equation editor and select the symbol from the context menu.

•

Type markup in the equation editor.

The context menu and the Selection window insert the markup corresponding to a symbol.
Incidentally, this provides a convenient way to learn the OOoMath markup.
Note

Click on the document body to exit the formula editor.
Double-click on a formula to enter the formula editor again.

The Selection window
The simplest method for entering a formula is the Selection window, shown in Figure 219.

Categories

Symbols

Figure 219. Symbols are divided into
categories
The Selection window is divided into two main portions.
•

The top shows the symbol categories. Click on these to change the list of symbols.

•

The bottom shows the symbols available in the current category.

TIP

You can hide (or unhide) the Selection window with View > Selection.
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Example 1: 5×4
For this example we will enter a simple formula: 5×4 On the Selection window:
1) Select the top-left button of the categories (top) section (Figure 220).
2) Click on the multiplication symbol (shown in Figure 220).
Unary/binary operators

Multiplication

Figure 220. Unary/binary
operators
When you select the multiplication symbol on the Selection window, two things happen:
•

The equation editor shows the markup: <?> times <?>

•

The body of the document shows a gray box with the figure: ×

Figure 221. The multiplication symbol
The “ <?> ” symbols (Figure 221) are placeholders that you can replace by other text. The
equation will update automatically, and the result should resemble Figure 222.
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Figure 222. Result of entering "5" and "4" next to the "times"
operator
Tip

To keep the equation from updating automatically, select View >AutoUpdate display.
To update a formula manually, press F9 or select View > Update.

Right-click menu
Another way to access mathematical symbols is to right-click on the equation editor. This
produces a menu as shown in Figure 223.

Figure 223. Right-click menu
Note

The entries in this menu correspond exactly to those in the Selection window.

Markup
You can type the markup directly on the equation editor. For example, you can type “5 times
4” to obtain 5×4 . If you know the markup, this can be the fastest way to enter a formula.
Tip

As a mnemonic, the formula markup resembles the way the formula reads in English.

Below is a short list of common equations and their corresponding markup.
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Display

Command

a=b

Display

Command

a=b

a

sqrt {a}

a^2

an

a_n

∫ f  x dx

int f(x) dx

∑ an

sum a_n

a≤b

a <= b

∞

infinity

a×b

a times b

x⋅y

x cdot y

a

2

Greek characters
Greek characters (  ,  ,  , , etc) are common in mathematical formulas. These characters
are not available in the selection box or the right-click menu. Fortunately, the markup for
Greek characters is simple: Type a % sign followed the name of the character, in English.
•

To type a lowercase character, write the name of the character in lowercase.

•

To type an uppercase character, write the name of the character in uppercase.

See the table below for some examples.
Lowercase

Note

Uppercase

%alpha 



%ALPHA 

A

%beta





%BETA



B

%gamma 



%GAMMA 



%psi





%PSI





%phi





%PHI





%theta 



%THETA 



A complete table of Greek characters is included in Chapter 16 (Math Objects) in
the Writer Guide.

Another way to enter Greek characters is by using the catalog window. Go to Tools >
Catalog. The catalog window is shown in Figure 224. Under “Symbol Set” select “Greek”
and double-click on a Greek letter from the list.
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Figure 224. Catalog - used for entering Greek characters

Example 2:  ≃ 3.14159
For this example we will suppose that:
•

We want to enter the above formula (the value of pi rounded to 5 decimal places).

•

We know the name of the Greek character (“pi”).

•

But we do not know the markup associated with the ≃ symbol.

Step 1: Type “%” followed by the text “pi”. This displays the Greek character  .
Step 2: Open the Selection window (View > Selection).
Step 3: The ≃ symbol is a relation, so we click on the relations button
mouse over this button you see the tooltip “Relations” (Figure 225).

. If you hover the

Figure 225. Tooltip indicates the "Relations"
button.
Step 4: Delete the <?> text and add “3.14159” at the end of the equation. Hence we end up
with the markup “ %pi simeq 3.14159 ”. The result is shown in Figure 226.
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Figure 226. Final result

Customizations
Formula editor as a floating window
As seen in Figure 218, the formula editor can cover a large part of the Writer window. To turn
the formula editor into a floating window, do this:
1) Hover the mouse over the editor frame, as shown in Figure 227.
2) Hold down the Control key and double-click.

Figure 227. Hold down the Control key and double-click on the
border of the math editor to turn it into a floating window.
Figure 228 shows the result. You can make the floating window back into an embedded
frame, using the same steps. Hold down the Control key and double-click the window frame.

Figure 228. Equation editor as a floating window
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How can I make a formula bigger?
This is one of the most common questions people ask about OOoMath. The answer is simple,
but not intuitive:
1) Start the formula editor and go to Format > Font size.

Figure 229. Changing the font size for a formula
2) Select a larger font size under “Base Size” (top-most entry), as shown in Figure 230.

Figure 230. Edit "Base size" (top) to make a formula
bigger.
The result of this change is illustrated in Figure 231.

Figure 231. Result of changing the base font
size.
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Formula layout
The most difficult part of using OOoMath comes when writing complicated equations. This
section provides some advice about writing complex formulas.

Brackets are your friends
OOoMath knows nothing about order of operation. You must use brackets to state the order
of operations explicitly. Consider the following example:
Markup
2 over

Result
x + 1

2 over {x + 1}

2
1
x
2
x1

Equations over more than one line
Suppose you want to type an equation covering more than one line. For example:

x=3
y=1

Your first reaction would be to simply press the Enter key. However, if you press the Enter
key, though the markup goes to a new line, the resulting equation does not. You must type the
newline command explicitly. This is illustrated in the table below.
Markup
x = 3

Result

x=3 y=1

y = 1
x = 3 newline
y = 1
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Common problem areas
How do I add limits to my sum/integral?
The “sum” and “int” commands can (optionally) take in the parameters “from” and “to”.
These are used for lower and upper limits respectively. These parameters can be used singly
or together. Limits for integrals are usually treated as subscripts and superscripts.
Markup

Result
n

sum from k = 1 to n a_k

∑ ak
k =1
x

int from 0 to x f(t) dt
or
int_0^x f(t) dt

∫ f t dt

int from Re f

∫f

or

0

x

∫0

f t dt

ℜ

∞

sum to infinity 2^{-n}

Note

∑ 2−n

For more details on integrals and sums, see Chapter 16 (Math Objects) in the Writer
Guide.

Brackets with matrices look ugly!
For background, we start with an overview of the matrix command:
Markup

Result

a
c

matrix { a # b ## c # d }

Note

b
d

Rows are separated by two #’s and entries within each row are separated by one #.

The first problem people have with matrices is that brackets do not “scale” with the matrix:
Markup
(

matrix { a # b ## c # d }

Result
)

a b 
c d

OOoMath provides “scalable” brackets. That is, the brackets grow in size to match the size of
their contents. Use the commands left( and right) to make scalable brackets.
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Markup
left(

TIP

Result

matrix { a # b ## c # d }

right)

a
c

b
d

 

Use left[ and right] to obtain square brackets.

How do I make a derivative?
Making derivatives essentially comes down to one trick: Tell OOo it’s a fraction.
In other words, you have to use the “over” command. Combine this with either the letter “d”
(for a total derivative) or the “partial” command (for a partial derivative) to achieve the effect
of a derivative.
Markup

Result

{df} over {dx}

df
dx

{partial f} over {partial y}

∂f
∂y

{partial^2 f} over {partial t^2}

∂2 f
∂t 2

Note

Notice that we had to use squiggly brackets to make the derivative.

Numbering equations
Equation numbering is one of OOoMath’s best hidden features. The steps are simple, but
obscure:
1) Start a new line.
2) Type “fn” and then press F3.
The “fn” is replaced by a numbered formula:
(2)

E=mc 2

Now you can double-click on the formula to edit it. For example, here is the Riemann Zeta
function:
∞

 z =∑
n=1
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You can reference an equation (“as shown in Equation (2)”) with these steps:
1) Insert > Cross-reference..
2) Click on the References tab (Figure 229).
3) Under Type, select Text.
4) Under Selection, pick the equation number.
5) Under Format, choose Reference.
6) Click Insert.
Done! If you later add more equations to the paper before the referenced equation, all the
equations will automatically renumber and the cross-references will update.

Figure 232. Inserting a cross-reference to an equation number.
TIP

To insert the equation number without parenthesis around it, choose Numbering
instead of Reference under Format
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What is a template?

What is a template?
A template is a model that you use to create other documents. For example, you can create a
template for business reports that has your company’s logo on the first page. New documents
created from this template will all have your company’s logo on the first page.
Templates can contain anything that regular documents can contain, such as text, graphics, a
set of styles, and user-specific setup information such as measurement units, language, the
default printer, and toolbar and menu customization.
All documents in OpenOffice.org (OOo) are based on templates. You can create a specific
template for any document type (text, spreadsheet, drawing, presentation). If you do not
specify a template when you start a new document, then the document is based on the default
template for that type of document. If you have not specified a default template, OOo uses the
blank template for that type of document that is installed with OOo. See “Setting a default
template” on page 243 for more information.
This chapter shows you how to:
•

Use a template to create a document

•

Create a template

•

Edit a template

•

Set a default template

•

Organize templates

Using a template to create a document
To use a template to create a document:
1) From the main menu, choose File > New > Templates and Documents. The
Templates and Documents window opens. (See Figure 233.)
2) In the box on the left, click the Templates icon if it is not already selected. A list of
template folders appears in the center box.
3) Double-click the folder that contains the template that you want to use. A list of all the
templates contained in that folder appears in the center box.
4) Click the template that you want to use. You can preview the selected template or view
the template’s properties:
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•

To preview the template, click the Preview icon. A preview of the template
appears in the box on the right.

•

To view the template’s properties, click the Document Properties icon. The
template’s properties appear in the box on the right.
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5) Click Open. The Templates and Documents window closes and a new document based
on the selected template opens in OOo. You can then edit and save the new document
just as you would any other document.

Figure 233. Templates and Documents window

Creating a template
You can create your own templates in two ways:
•

From a document

•

Using a wizard

Creating a template from a document
To create a template from a document:
1) Open a new or existing document of the type you want to make into a template (text
document, spreadsheet, drawing, presentation).
2) Add the content and styles that you want.
3) From the main menu, choose File > Templates > Save. The Templates window opens
(see Figure 234).
4) In the New template field, type a name for the new template.
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5) In the Categories list, click the category to which you want to assign the template.
(The category is simply the template folder in which you want to save the template.
For example, to save the template in the “My Templates” folder, click the My
Templates category.)
To learn more about template folders, see “Organizing templates” on page 243.
6) Click OK. OOo saves the new template and the Templates window closes.

Figure 234. Saving a new template
Any settings that can be added to or modified in a document can be saved in a template. For
example, below are some of the settings (although not exhaustive) that can be included in a
Writer document and then saved as a template for later use:
•

Printer settings: which printer, single sided / double sided, and paper size, and so on

•

Styles to be used, including character, page, frame, numbering and paragraph styles

•

Format and settings regarding indexes, tables, bibliographies, table of contents

Creating a template using a wizard
You can use wizards to create these types of templates:
•

Letter

•

Fax

•

Agenda

•

Presentation

•

Web page

For example, the Fax Wizard steps you through the following choices:
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•

Type of fax (business or personal)

•

Document elements like the date, subject line (business fax), salutation, and
complementary close
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•

Options for sender and recipient information (business fax)

•

Text to include in the footer (business fax)

To create a template using a wizard:
7) From the main menu, choose File > Wizards > type of template required (Figure 235).

Figure 235. Creating a template using a wizard
8) Follow the instructions on the pages of the wizard. This process is slightly different for
each type of template, but the format is very similar.
9) In the last section of the wizard, you can specify the name and location for saving the
template. The default location is your user templates directory, but you can choose a
different location if you prefer.
10)Finally, you have the option of creating a new document from your template
immediately, or manually changing the template. For future documents, you can re-use
the template created by the wizard, just as you would use any other template.

Editing a template
You can edit a template’s styles and content, and then, if you wish, you can reapply the
template’s styles to documents that were created from that template. (Note that you can only
reapply styles. You cannot reapply content.)
To edit a template:
1) From the main menu, choose File > Templates > Organize. The Template
Management window opens (see Figure 236).
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Figure 236. Template management window
2) In the box on the left, double-click the folder that contains the template that you want
to edit. A list of all the templates contained in that folder appears underneath the folder
name.
3) Click the template that you want to edit.
4) Click the Commands button.
5) From the drop-down menu, choose Edit. The Template Management window closes
and the selected template opens.
6) Edit the template just as you would any other document. To save your changes, choose
File > Save from the main menu.
The next time that you open a document that was created from the changed template, the
following message appears.

Figure 237. Apply current styles message
Click Yes to apply the template’s changed styles to the document. Click No if you do not
want to apply the template’s changed styles to the document. Whichever option you choose,
the message box closes and the document opens in OOo.
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Caution

If you choose No in the message box shown in , that message will not appear again
the next time you open the document after changing the template it is based on. You
will not get another chance to update the styles from the template, although you can
use the macro given in the Note below to re-enable this feature.

Note

To re-enable updating from a template:
1) Use Tools > Macros > Organize Macros > OpenOffice.org Basic. Select the
document from the list, click the +, and select Standard. If Standard has a +
beside it, click that and select a module.
2) Name the macro. For example, you could call it FixDocument. If the Edit button is
active, click it. If the Edit button is not active, click New, type a module name in
the pop-up dialog, and click OK.
3) In the Basic window, enter the following:
Sub FixDocument
TemplateName = ThisComponent.DocumentInfo.Template
if TemplateName <> "" then
ThisComponent.DocumentInfo.Template = TemplateName
end if
End Sub

4) Click the Run BASIC icon, then close the Basic window.
5) Save the document.
Next time when you open this document you will have the update from template
feature back.

Adding templates with Extension Manager
The Package Manager was introduced in OOo 2.0.4 and renamed the Extension Manager in
OOo 2.1. This feature provides an easy way to install collections of templates, graphics,
macros, or other add-ins that have been “packaged” into files with a .OXT extension.
1) After you download a package, select Tools > Extension Manager from the menu bar.
In the Extension Manager dialog (Figure 238), click Add.
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Figure 238: Installing a package of templates
2) A file browser window opens. Find and select the package of templates you want to
install and click Open.
3) On the Extension Manager dialog (Figure 237), select the package you just added and
click Enable.

Figure 239: Enabling a newly-added package of templates
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Setting a default template
If you create a document by choosing File > New > Text Document (or Spreadsheet,
Presentation, or Drawing) from the main menu, OOo creates the document from the Default
template for that type of document. You can, however, set a custom template to be the
default. You can reset the default later if you choose.

Setting a custom template as the default
You can set any template to be the default, as long as it is in one of the folders displayed in
the Template Management window.
To set a custom template as the default:
1) From the main menu, choose File > Templates > Organize. The Template
Management window (Figure 236) opens.
2) In the box on the left, double-click the folder containing the template that you want to
set as the default.
3) Click the template that you want to set as the default.
4) Click the Commands button.
5) From the drop-down menu, choose Set As Default Template. The next time that you
create a document by choosing File > New, the document will be created from this
template.

Resetting the default to OOo’s in-built Default
template
To re-enable OOo’s Default template for a document type as the default:
1) From the main menu, choose File > Templates > Organize. The Template
Management window (Figure 236) opens.
2) In the box on the left, click any folder.
3) Click the Commands button.
4) From the drop-down menu, choose Reset Default Template.

Organizing templates
OOo can only use templates that are in OOo template folders. You can, however, create new
OOo template folders and use them to organize your templates. For example, you might have
one template folder for report templates and another for letter templates. You can also import
and export templates.
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To begin, choose File > Templates > Organize from the main menu. The Template
Management window (Figure 236) opens.
Note

All the actions made by the Commands button in the Template Management window
can be made as well by right-clicking on the templates or the folders.

Creating a template folder
To create a template folder:
1) In the Template Management window, click any folder.
2) Click the Commands button.
3) From the drop-down menu, choose New. A new folder called Untitled appears.
4) Type a name for the new folder, and then press the Enter key. OOo saves the folder
with the name that you entered.

Deleting a template folder
You cannot delete template folders supplied with OOo or installed using the Extension
Manager; you can only delete template folders that you have created.
To delete a template folder:
1) In the Template Management window, click the folder that you want to delete.
2) Click the Commands button.
3) From the drop-down menu, choose Delete. A message box appears and asks you to
confirm the deletion. Click Yes.

Moving a template
To move a template from one template folder to another template folder:
1) In the Template Management window, double-click the folder that contains the
template you want to move. A list of all the templates contained in that folder appears
underneath the folder name.
2) Click the template that you want to move and drag it to the desired folder. If you do
not have the authority to delete templates from the source folder, this action copies the
template instead of moving it.

Deleting a template
You cannot delete the templates supplied with OOo or installed using the Extension
Manager; you can only delete templates that you have created.
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To delete a template:
1) In the Template Management window, double-click the folder that contains the
template you want to delete. A list of all the templates contained in that folder appears
underneath the folder name.
2) Click the template that you want to delete.
3) Click the Commands button.
4) From the drop-down menu, choose Delete. A message box appears and asks you to
confirm the deletion. Click Yes.

Importing a template
If the template that you want to use is in a different location, you must import it into an OOo
template folder.
To import a template into a template folder:
1) In the Template Management window, double-click the folder into which you want to
import the template.
2) Click the Commands button.
3) From the drop-down menu, choose Import Template. A standard file browser window
opens.
4) Find and select the template that you want to import and click Open. The file browser
window closes and the template appears in the selected folder.

Exporting a template
To export a template from a template folder to another location:
1) In the Template Management window, double-click the folder that contains the
template you want to export. A list of all the templates contained in that folder appears
underneath the folder name.
2) Click the template that you want to export.
3) Click the Commands button.
4) From the drop-down menu, choose Export Template. The Save As window opens.
5) Find the folder into which you want to export the template and click Save.
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Working with Styles:
Introduction to Styles in OpenOffice.org

What are styles?

What are styles?
A style is a set of formats that you can apply to selected pages, text, frames, and other
elements in your document to quickly change their appearance. When you apply a style, you
apply a whole group of formats at the same time.
OpenOffice.org supports the following types of styles:
•

Page styles include margins, headers and footers, borders and backgrounds. In Calc,
page styles also include the sequence for printing sheets.

•

Paragraph styles control all aspects of a paragraph’s appearance, such as text
alignment, tab stops, line spacing, and borders, and can include character formatting.

•

Character styles affect selected text within a paragraph, such as the font and size of
text, or bold and italic formats.

•

Frame styles are used to format graphic and text frames, including wrapping type,
borders, backgrounds, and columns.

•

Numbering styles apply similar alignment, numbering or bullet characters, and fonts to
numbered or bulleted lists.

•

Cell styles include fonts, alignment, borders, background, number formats (for
example, currency, date, number), and cell protection.

•

Graphics styles in drawings and presentations include line, area, shadowing,
transparency, font, connectors, dimensioning, and other attributes.

•

Presentation styles include attributes for font, indents, spacing, alignment, and tabs.

Different styles are available in the various components of OOo, as listed in Table 2.
Table 2. Styles available in OOo components
Style Type

Writer

Calc

Page

X

X

Paragraph

X

Character

X

Frame

X

Numbering

X

Cell

Impress

X

X

X

X

X

Presentation
Graphics

Draw

(included in
Frame styles)

OpenOffice.org comes with many predefined styles. You can use the styles as provided,
modify them, or create new styles, as described in this chapter.
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Why use styles?
Many people manually format paragraphs, words, tables, page layouts, and other parts of
their documents without paying any attention to styles. They are used to writing documents
according to physical attributes. For example, you might specify the font family, font size,
and any formatting such as bold or italic.
Styles are logical attributes. Using styles means that you stop saying “font size 14pt, Times
New Roman, bold, centered”, and you start saying “Title” because you have defined the
“Title” style to have those characteristics. In other words, styles means that you shift the
emphasis from what the text (or page, or other element) looks like, to what the text is.
Styles help improve consistency in a document. They also make major formatting changes
easy. For example, you may decide to change the indentation of all paragraphs, or change the
font of all titles. For a long document, this simple task can be prohibitive. Styles make the
task easy.
In addition, styles are used by OpenOffice.org for many processes, even if you are not aware
of them. For example, OOo relies on heading styles (or other styles you specify) when it
compiles a table of contents.

Applying styles
OpenOffice.org provides several ways for you to select styles to apply.

Using the Styles and Formatting window
1) Click the Styles and Formatting icon
located at the left-hand end of the object
bar, or click Format > Styles and Formatting, or press F11. The Styles and
Formatting window shows the types of styles available for the OOo component you
are using. Figure 240 shows the window for Writer, with Page Styles visible.
You can move this window to a convenient position on the screen or dock it to an edge
(hold down the Ctrl key and drag it by the title bar to where you want it docked).
2) Click on one of the icons at the top left of the Styles and Formatting window to display
a list of styles in a particular category.
3) To apply an existing style (except for character styles), position the insertion point in
the paragraph, frame, or page, and then double-click on the name of the style in one of
these lists. To apply a character style, select the characters first.
Tip

At the bottom of the Styles and Formatting window is a dropdown list. In Figure
240 the window shows Automatic, meaning the list includes only styles applied
automatically by OOo. You can choose to show all styles or other groups of styles,
for example only custom styles.
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Frame styles
Character styles

List styles
Fill Format mode
Page styles
New style from
selection

Paragraph styles

Update style
Load styles

Figure 240. The Styles and Formatting window for Writer, showing paragraph
styles

Using Fill Format mode
Use Fill Format to apply a style to many different areas quickly without having to go back to
the Styles and Formatting window and double-click every time. This method is quite useful
when you need to format many scattered paragraphs, cells, or other items with the same style.
1) Open the Styles and Formatting window (Figure 240) and select the style you want to
apply.
2) Click the Fill Format mode icon

. The mouse pointer changes to this icon.

3) Position the moving icon on the paragraph, page or frame to be styled and click the
mouse button.
4) If you are applying a character style, hold down the mouse button while selecting the
characters.
5) To quit Fill Format mode, click the Fill Format mode icon again or press the Esc key.
Caution

When this mode is active, a right-click anywhere in the document undoes the
last Fill Format action. Be careful not to accidentally right-click and thus undo
actions you want to keep.

Using the Apply Style list
After you have used a style at least once in a document, the style name appears on the Apply
Style list (Figure 241) at the left-hand end of the Formatting toolbar, next to the Styles and
Formatting icon.
You can open this list and click once on the style you want, or you can use the up and down
arrow keys to move through the list and then press Enter to apply the highlighted style.
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Figure 241. The Apply Style list on the Formatting toolbar
Tip

Select More... at the bottom of the list to open the Styles and Formatting window.

Assigning styles to shortcut keys
OOo provides a set of predefined keyboard shortcuts that allow you to quickly apply styles
while typing in a document. You can redefine these shortcuts or define your own.
1) Click Tools > Customize > Keyboard. The Keyboard page of the Customize dialog
(Figure 242) opens.
2) To have the shortcut key assignment available only with one component (for example,
Writer), select that component’s name in the upper right corner of the page; otherwise
select OpenOffice.org button to make it available to every component.
3) Choose the shortcut keys you want to define. In this example we have chosen Ctrl+9.
4) In the Functions section at the bottom of the dialog, scroll down in the Category list to
Styles and click the + sign.
5) Choose the type of style (our example uses a paragraph style). The Function list will
display the names of the available styles for the selected type. The example shows
some of OOo’s predefined styles.
6) To set Ctrl+9 to be the shortcut key combination for the Text Body style, select Text
Body in the Function list, and then click Modify. Ctrl+9 now appears in the Keys list.
7) Make any other required changes and then click OK to save these settings and close
the dialog.
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Figure 242. Defining keyboard shortcuts for applying styles

Modifying styles
OpenOffice.org provides two ways to modify styles (both the predefined styles and custom
styles that you create):
•

Changing a style using the Style dialog

•

Updating a style from a selection

Tip
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Any changes you make to a style are effective only in the document you are working
on. The changes do not go into any associated template. If you want the changes to
apply to more than one document, you need to change the template (see Chapter 12,
Working with Templates) or copy the styles into the other documents as described in
“Copying and moving styles“ on page 255.
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Changing a style using the Style dialog
To change an existing style using the Style dialog, right-click on the required style in the
Styles and Formatting window (Figure 240) and select Modify from the pop-up menu.
The Style dialog displayed depends on the type of style selected. Each style dialog has several
tabs. See the chapters on styles in the user guides for details.

Updating a style from a selection
To update a style from a selection:
1) Open the Styles and Formatting window.
2) In the document, select an item that has the format you want to adopt as a style.
3) In the Styles and Formatting window, select the style you want to update (single-click,
not double-click), then long-click on the arrow next to the New Style from Selection
icon and click on Update Style (see Figure 243).

Figure 243. Updating a style from a selection

Using AutoUpdate (paragraph and frame styles only)
If the AutoUpdate checkbox is selected on the Organizer page of the Paragraph Style or
Frame Style dialog, applying direct formatting to a paragraph or frame using this style in your
document automatically updates the style itself.
Tip

If you are in the habit of manually overriding styles in your document, be sure that
AutoUpdate is not enabled.

Updating styles from another document or template
You can update styles by copying or loading them from a template or another document. See
“Copying and moving styles” on page 255.
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Creating new (custom) styles
You may want to add some new styles. You can do this in two ways:
• Creating a new style using the Style dialog
• Creating a new style from a selection

Creating a new style using the Style dialog
To create a new style using the Style dialog, right-click in the Styles and Formatting window
and select New from the pop-up menu.
If you want your new style to be linked with an existing style, first select that style and then
right-click and select New.
If you link styles, then when you change the base style (for example, by changing the font
from Times to Helvetica), all the linked fonts will change as well. Sometimes this is exactly
what you want; other times you do not want the changes to apply to all the linked styles. It
pays to plan ahead.
The dialogs and choices are the same for defining new styles and for modifying existing
styles. See the chapters on styles in the user guides for details.

Creating a new style from a selection
You can create a new style by copying an existing style. This new style applies only to this
document; it will not be saved in the template.
1) Open the Styles and Formatting window and choose the type of style you want to
create.
2) In the document, select the item you want to save as a style.
3) In the Styles and Formatting window, click on the New Style from Selection icon.
4) In the Create Style dialog (Figure 244), type a name for the new style. The list shows
the names of existing custom styles of the selected type. Click OK to save the new
style.
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Figure 244: Naming a new style created from a
selection

Dragging and dropping a selection to create a style
You can drag and drop a text selection into the Styles and Formatting window to create a new
style.
Writer

Select some text and drag it to the Styles and Formatting window. If Paragraph Styles are
active, the paragraph style will be added to the list. If Character Styles are active, the
character style will be added to the list.
Calc

Drag a cell selection to the Styles and Formatting window to create cell styles.
Draw/Impress

Select and drag drawing objects to the Styles and Formatting window to create graphics
styles.

Copying and moving styles
You can copy or move styles from one template or document into another template or
document, in two ways:
•

Using the Template Management dialog

•

Loading styles from a template or document

Using the Template Management dialog
To copy or move styles using the Template Management dialog:
1) Click File > Templates > Organize.
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2) In the Template Management dialog (Figure 246), set the lists at the bottom to either
Templates or Documents, as needed. The default is Templates on the left and
Documents on the right.
Tip

To load styles from a file that is not open, click the File button. When you return to
this window, both lists show the selected file as well as all the currently open
documents.

Figure 245: Choosing to copy styles from a document, not a template
3) Open the folders and find the templates from and to which you want to copy. Doubleclick on the name of the template or document, and then double-click the Styles icon
to show the list of individual styles (Figure 247).
4) To copy a style, hold down the Ctrl key and drag the name of the style from one list to
the other.
Caution

If you do not hold down the Control key when dragging, the style will be moved
from one list to the other. The style will be deleted from the list you are dragging it
from.

5) Repeat for each style you want to copy. If the receiving template or document has a lot
of styles, you may not see any change on screen unless you scroll down in the list.
When you are finished, click Close.
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Figure 246: Copying a style from one document to another

Loading styles from a template or document
You can copy styles by loading them from a template or another document:
1) Open the document you want to copy styles into.
2) In the Styles and Formatting window, long-click on the arrow next to the New Style
from Selection icon, and then click on Load Styles (see Figure 243).
3) On the Load Styles dialog (Figure 247), find and select the template you want to copy
styles from.

Figure 247. Copying styles from a template into the open document
4) Select the checkboxes for the categories of styles to be copied. Select Overwrite if
you want the styles being copied to replace any styles of the same names in the
document you’re copying them into.
5) Click OK to copy the styles. You will not see any change on screen.
Note

To copy the styles from another document, click the From File button to open a
window from which you can select the required document.
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Deleting styles
You cannot remove (delete) any of OOo’s predefined styles from a template, even if you are
not using them.
You can remove any user-defined (custom) styles; but before you do, you should make sure
the styles are not in use. If an unwanted style is in use, you will want to replace it with a
substitute style.
Replacing styles (and then deleting the unwanted ones) can be very useful if you are dealing
with a document that has been worked on by several writers or has been formed by
combining several documents from different sources.
To delete unwanted styles, right-click on them (one at a time) in the Styles and Formatting
window and click Delete on the pop-up menu.
If the style is in use, you receive the message shown in Figure 248.

Figure 248. Deleting an applied style
Caution

Make sure the style is not in use before deletion. Otherwise, all objects with that
style will return to the default style and retain their formatting as manual
formatting. This can be a problem in a long document.

If the style is not in use, you receive the message shown in Figure 245.

Figure 249. Deleting a style that is not in use
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Chapter 14
Working with the Gallery

What is the Gallery?

What is the Gallery?
The Gallery contains objects (graphics and sounds) that you can insert into your documents.
The Gallery is available in all components of OpenOffice.org.
To open the Gallery, choose Tools > Gallery, or click the Gallery icon
open, these choices close it.

. If the Gallery is

Graphics in the Gallery are grouped by themes, such as Bullets, Rulers, and 3D Effects. You
can create other groups or “themes” as you wish.
The box on the left of the gallery window lists the available themes. Click on a theme to see
its graphics displayed in the Gallery window.
Figures 250 and 251 show two views of one of the themes supplied with OpenOffice.org.
You have the option of Icon View or Detailed View for the Gallery, and you can hide or show
the Gallery by clicking on the Hide button.

Figure 250. Icon view of one theme in the Gallery

Figure 251. Detailed view of the same theme in the Gallery
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Inserting objects into a document
You can copy or link an object from the Gallery into a document. The difference is that a
linked object can be updated in your document if the object is changed in the Gallery, simply
by updating the link.
To insert an object:
1) Choose Tools > Gallery and select a theme.
2) Select an object with a single click, then drag and drop the object into the document.
(See Figure 252.)

1

2
3

4

Figure 252. Copying a graphic object from the Gallery into a document
You also can right-click on the object to open the context menu and select Insert > Copy.

Inserting objects as links
To insert an object as a link:
1) Choose Tools > Gallery and select a theme.
2) Select an object with a single click, then while pressing the Shift and Ctrl keys, drag
and drop the object into the document.
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Inserting an object as a background
To insert an object as the background to a page or paragraph:
1) Choose Tools > Gallery and select a theme.
2) Select an object with a single click, right-click on the object and choose Insert >
Background > Page or Paragraph.

Managing the Gallery
The default themes are locked; no items can be added or deleted from these themes. The
locked themes are easily recognizable by right-clicking on them; the only available option in
the pop-up menu is Properties.
In a default installation, only the My themes theme is customizable, although new themes can
be added as explained in

Adding objects to the Gallery
Method 1 (selecting a file):
1) Right-click on the theme name in the list of themes and choose Properties from the
pop-up menu.
2) Click the Files tab, if necessary.
3) Click Add.
4) Select a file and click Open. The image is added to the theme.
Method 2 (drag and drop):
1) Open the document containing an image you want to add to the Gallery, and display
the Gallery theme to which you want to add it.
2) Position the mouse pointer above the image, without clicking.
3) If the mouse pointer changes to a hand symbol, the image refers to a hyperlink. In this
case, press the Alt key while you click the image, to select it without executing the
respective link. If the mouse pointer does not change to a hand symbol, you can simply
click the image to select it.
4) Once the image is selected, evident from the green selection handles around it, release
the mouse button. Click again on the image, keeping the mouse button pressed for
more than two seconds. Without releasing the mouse button, drag the image into the
document.
5) Release the mouse button.
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Deleting objects from the Gallery
To delete an object from a theme:
1) Right-click on the name of the graphics file or its thumbnail in the Gallery.
2) Click Delete on the pop-up menu. A message appears, asking if you want to delete this
object. Click Yes.
Note

Deleting the name of a file from the list in the Gallery does not delete the file from
the hard disk or other location.

Adding a new theme to the Gallery
1) Click the New Theme button above the list of themes (see Figure 250).
2) Click the General tab and type a name for the new theme.
3) Click the Files tab.
4) Click Find Files. The Select Path dialog opens (Figure 253). Browse to the folder that
contains the image files for the new theme and click OK.
5) Back on the Files tab, either click on Add All to install all of the files in the selected
folder, or use File Type and/or select one or more files from the displayed list, and
click on Add to install a selection of files to the new theme.
6) Click OK when finished.

Figure 253. Setting up a new theme in the Gallery
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Note

The files do not show in the large box under the File Type box; and under the
General tab, the Contents will display as “0 Objects,” but the chosen files will be
inserted into the new theme. Remember, you can always add or delete image files
later.

Deleting a theme from the Gallery
To delete a theme from the Gallery:
1) Go to Tools > Gallery.
2) In the left part of the Gallery, select in the list the theme you wish to delete.
3) Right-click on the theme, then click Delete on the pop-up menu.

Location of the Gallery and the objects in it
Graphics and other objects shown in the Gallery can be located anywhere on your computer’s
hard disk, on a network drive, or on a CD-ROM. Listings in the Gallery refer to the location
of each object. When you add graphics to the Gallery, the files are not moved or copied; only
the location of each new object is added as a reference.
In a workgroup situation, you may have access to a shared Gallery (where you cannot change
the contents unless authorized to do so) and a user Gallery, where you can add, change, or
delete objects.
The location of the user Gallery is specified in Tools > Options > OpenOffice.org > Paths.
Typically it is something like \openoffice\user\gallery, although the exact location depends on
your operating system. You can change this location, and you can copy your gallery files
(*.sdv) to other computers.
Gallery contents provided with OOo are stored in a location like openoffice\share\gallery.
You cannot change this location.
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Using Fontwork
Creating Graphical Text Art Objects

What is Fontwork?

What is Fontwork?
With Fontwork you can create graphical text art objects for making your work more
attractive. There are many different settings for text art objects (line, area, position, size, and
more), so you have a large choice. You will surely find one that fits your document.
Fontwork is available with each component of OpenOffice.org (OOo), but you will notice
small differences in the way that each component displays it.

The Fontwork toolbars
You can use two different toolbars for creating and editing a Fontwork object.
•

Go to View > Toolbars > Fontwork.

Figure 254. The floating Fontwork
toolbar
•

If you click on an existing Fontwork object, the Formatting toolbar changes to
display the Fontwork options as in Figure 255. The contents of this toolbar vary
depending on the OOo component.
Formatting toolbar

Figure 255. The Formatting toolbar in Writer when a Fontwork object is selected

Creating a Fontwork object
1) On the Drawing or Fontwork toolbar, click the Fontwork Gallery icon:
. If the
Drawing toolbar is not visible, go to View > Toolbars > Drawing to display it.
2) In the Fontwork Gallery dialog (Figure 256), select a Fontwork style, then click OK.
The Fontwork object will appear in your document. Notice the blue squares around the
edge (indicating that the object is selected) and the yellow dot; these are discussed in
“Moving and resizing Fontwork objects” on page 273.
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Figure 256. The Fontwork Gallery
3) Double-click the object to edit the Fontwork text Type your own text in place of the
black Fontwork text that appears over the object (Figure 257).

Figure 257. Editing Fontwork text
4) Click anywhere in a free space or press Esc to apply your changes.

Editing a Fontwork object
Now that the Fontwork object is created, you can edit some of its attributes. To do this, you
can use the Fontwork toolbar, the Formatting toolbar, or menu options as described in this
section.
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Using the Fontwork toolbar
Make sure that the Fontwork toolbar, shown in Figure 254, is visible. If you do not see it, go
to View > Toolbars > Fontwork.
Click on the different icons to edit Fontwork objects:
Fontwork Shape: Edits the shape of the selected object. You can choose from a palette
of shapes, as shown in Figure 258.

Figure 258. Fontwork toolbar showing palette of shapes
Fontwork Same Letter Heights: Changes the height of characters in the object.
Toggles between normal height (some characters taller than others, for example capital
letters, d, h, l and others) and all letters the same height. See Figure 259.

Figure 259. Left: normal letters; right: same letter heights
Fontwork Alignment: Changes the alignment of characters. Choices are left align,
center, right align, word justify, and stretch justify. The effects of the text alignment
can only be seen if the text spans over two or more lines. In the stretch justify mode,
all the lines are filled completely.

Figure 260: The extended alignment toolbar
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Fontwork Character Spacing: Changes the character spacing and kerning in the
object. For custom spacing, input a percentage value: 100% is normal spacing; less than
100% is tight spacing; more than 100% is expanded spacing.

Figure 261: The extended character spacing toolbar

Using the Formatting toolbar
Now let us go further and customize the Fontwork object with several more attributes.
Click on the Fontwork object. The Formatting toolbar changes to show all the options for
editing the object. (For example, the toolbar shown in Figure 262 will appear when you use
Fontwork in Writer.)
On the Formatting toolbar you have a large choice of options for customizing your object.
These choices are the same as the ones for other drawing objects. You can read about them in
more detail in the Draw Guide.
Arrow Style

Line

Line Width

Line Style

Area

Line Color

Rotate

To Foreground

Area Style / Filling

To Background

Bring to Front

Alignment

Change
Anchor

Send to Back Ungroup Group

Figure 262. Formatting toolbar with a Fontwork object selected in Writer
Line options

Line icon: Opens a dialog (Figure 263) with three tabs: Line, Line Styles, Arrow Styles.
•

•

Use the Line tab to edit the most common properties of the line around the selected
Fontwork object, by choosing from previously-defined attributes including line style,
line color, and arrow styles.
Use the Lines Styles and Arrow Styles tabs to edit the properties of line and arrow
styles, and define new styles.
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Arrow Style icon: Choose from the different arrow styles.
Line Style box: Choose from the available line styles.
Line Width box: Set the width of the line.
Line Color box: Select the color of the line.

Figure 263. Line options dialog
Area options

Area icon: Opens a dialog (Figure 264) with seven tabs: Area, Shadow, Transparency,
Colors, Gradients, Hatching, Bitmaps.
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•

Area tab: Choose from the predefined list a color, bitmap, gradient or hatching pattern
to fill the selected object.

•

Shadow tab: Set the shadow properties of the selected object.

•

Transparency tab: Set the transparency properties of the selected object.

•

Colors tab: Modify the available colors or add new ones to appear on the Area tab.

•

Gradients tab: Modify the available gradients or add new ones to appear on the Area
tab.

•

Hatching tab: Modify the available hatching patterns or add new ones to appear on the
Area tab.
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•

Bitmaps tab: Create simple bitmap patterns and import bitmaps, to make them
available on the Area tab.

Area Style / Filling boxes: Select the type of the fill of the selected object. For more detailed
settings, use the Area icon.

Figure 264. Area options dialog
Positioning options

Rotate icon: Rotate the selected object manually using the mouse to drag the object.
To Foreground icon: Moves the selected object in front of the text.
To Background icon: Moves the selected object behind the text.
Alignment icon: Modifies the alignment of the selected objects.
Bring to front icon: Moves the selected object in front of the others.
Send to back icon: Moves the selected object behind the others.
Change Anchor icon: Switch between anchoring options:
•

To Page - The object keeps the same position in relation to the page margins. It does
not move as you add or delete text.

•

To Paragraph - The object is associated with a paragraph and moves with the
paragraph. It may be placed in the margin or another location.
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•

•

To Character - The object is associated with a character but is not in the text sequence.
It moves with the paragraph but may be placed in the margin or another location. This
method is similar to anchoring to a paragraph.
As Character - The object is placed in the document like any character and moves with
the paragraph as you add or delete text before the object.

Ungroup icon: Ungroups the selected objects, so you can manage them individually .
Group icon: Groups the selected objects, so you can manage them as a single object.

Using menu options
You can use some the choices on the Format menu to anchor, align, arrange and group
selected Fontwork objects, wrap text around them, and flip them horizontally and vertically.
You can also right-click on a Fontwork object and choose many of the same options from the
pop-up menu. In addition, the pop-up menu provides quick access to the Line, Area, Text, and
Position and Size dialogs. The Line and Area dialogs are described on pages 269 and 270.
The Text dialog offers only a few options for Fontwork objects and is not discussed here.
On the Position and Size dialog (Figure 260), you can enter precise values concerning size
and position. For more information, see the Draw Guide.

Figure 265. Position and Size dialog
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Moving and resizing Fontwork objects
When you select a Fontwork object, eight blue squares (known as handles) appear around the
edge of the object, as shown in Figure 257. You can drag these handles to resize the object.
A yellow dot also appears on the object. This dot may be along an edge of the object, or it
may be somewhere else; see Figure 261 for an example. If you hover the pointer over this
yellow dot, the pointer turns into a hand symbol. You can drag the dot in different directions
to distort the object.

Figure 266. Yellow dot
Hovering the pointer over other parts of the object turns the pointer into the usual symbol for
dragging the object to another part of the page.
For precise control of the location and size of the object, use the Position and Size dialog
(Figure 260).
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Creating Web Pages
Saving Documents as HTML Files

Introduction

Introduction
This chapter describes how to save documents as web pages from Writer, Calc, Draw and
Impress.
Note

Cross references do not become hyperlinks in an HTML document.

Inserting hyperlinks
When you type text (such as a website addresses or URL) that can be used as a hyperlink,
OOo formats it automatically, creating the hyperlink and applying to the text a color and
underlining. If this does not happen, you can enable this feature using Tools > AutoCorrect >
Options and selecting the URL Recognition checkbox.
Tips

If you do not want OOo to convert a specific URL to a hyperlink, select Edit > Undo
Insert from the menu bar or press Control+Z immediately after the formatting has
been applied.
To change the color of hyperlinks, go to Tools > Options > OpenOffice.org >
Appearance, scroll to Unvisited links and/or Visited links, select the checkboxes,
pick the new colors and click OK. Caution: this will change the color for all
hyperlinks in all components of OpenOffice.org—this may not be what you want.
In Writer and Calc (but not Draw or Impress), you can also change the Internet link
character style or define and apply new styles to selected links.

You can also insert and modify links using the Hyperlink dialog (Figure 267). To display the
dialog, click the Hyperlink icon
on the Standard toolbar or select Insert > Hyperlink
from the menu bar. To turn existing text into a link, highlight it before opening the Hyperlink
dialog.
On the left hand side, select one of the four types of hyperlinks:
• Internet: a web address, normally starting with http://
• Mail & News: for example an email address.
• Document: the hyperlink points to another document or to another place in the
presentation.
• New document: the hyperlink creates a new document.
The top right part of the dialog changes according to the choice made for the hyperlink type.
A full description of all the choices, and their interactions, is beyond the scope of this chapter.
Here is a summary of the most common choices used in presentations.
For an Internet type hyperlink, choose the type of hyperlink (choose between Web, FTP or
Telnet), and enter the required web address (URL).
For a Mail and News type hyperlink, specify whether it is a mail or news link, the receiver
address and for email, also the subject.
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Figure 267. Hyperlink dialog showing details for Internet links
For a Document type hyperlink, specify the document path (the Open File button opens a file
browser); leave this blank if you want to link to a target in the same presentation. Optionally
specify the target in the document (for example a specific slide). Click on the Target icon to
open the Navigator where you can select the target, or if you know the name of the target, you
can type it into the box.
For a New Document type hyperlink, specify whether to edit the newly created document
immediately or just create it (Edit later) and the type of document to create (text,
spreadsheet, etc.). For a presentation, Edit now is the more likely choice. The Select path
button opens a directory picker.
The Further settings section in the bottom right part of the dialog is common to all the
hyperlink types, although some choices are more relevant to some types of links.
•

Set the value of Frame to determine how the hyperlink will open. This applies to
documents that open in a Web browser.

•

Form specifies if the link is to be presented as text or as a button. See “” for more
information.

•

Text specifies the text that will be visible to the user.

•

•

Name is applicable to HTML documents. It specifies text that will be added as a NAME
attribute in the HTML code behind the hyperlink.
Event button: this button will be activated to allow OOo to react to events for which
the user has written some code (macro). This function is not covered in this book.
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Editing hyperlinks
To edit an existing link:
1) Either move the cursor into the link using the keyboard arrow keys, or click on the
letters HYP in the status bar to change it to SEL (as shown in Figure 268) and use the
mouse to position the cursor.

HYP or SEL
Figure 268. Writer status bar
2) Click Edit > Hyperlink. The Hyperlink dialog (Figure 267) opens.
Tip

If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until
you have edited all of them. Be sure to click Apply after each one. When you are
finished, click Close.

Saving Writer documents as web pages
Writer’s HTML capabilities include saving existing documents in HTML format, creating
new documents as HTML and creating several different types of web pages using a wizard.
The easiest way to create HTML documents is to start with an existing Writer document. You
can view it as it will appear on a web page by using View > Web Layout.

Saving a document as a single web page
To save a document as a single web page (HTML format), select Save As from the File menu
and specify HTML Document as the file type.
Note

Writer does not replace multiple spaces in the original document with the HTML
code for non-breaking spaces. If you want to have extra spaces in your HTML file or
web page, you need to insert non-breaking spaces in OOo. To do this, press
Control+Spacebar instead of just Spacebar.

Saving a document as a series of web pages
Writer can save a large document as a series of web pages (HTML files) with a table of
contents page. To do this:
1) Decide which headings in the document should start on a new page and make sure all
those headings have the same style (for example, Heading 1).
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2) Select File > Send and click on Create HTML Document.
3) In the dialog (Figure 269), enter the file name to save the pages under. Also specify
which style indicates a new page (as decided in step 1).
4) Click Save to create the multi-page HTML document. (For those who may be
interested, the resulting HTML files conform to the HTML 4 Transitional.)

Figure 269. Creating a series of web pages from one document

Creating web pages using a Wizard
OOo’s Web wizard allows you to create several types of standard web pages. To use it:
1) Select File > Wizards > Web Page. On the first page of the Wizard (Figure 270),
choose settings and click Next.
Note

If this is your first web page, the only settings option is Default.
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Figure 270. Web page wizard step 1
2) Choose or browse to the document you would like to format and add the Title,
Summary and Author information as shown in Figure 271. Click Next.

Figure 271. Web page wizard step 2
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3) Chose a layout for the web site by clicking on the layout boxes shown in Figure 272.
Click Next.

Figure 272. Web page wizard step 3
4) Chose the information to be listed and the screen resolution, as shown in Figure 273.
Click Next.

Figure 273. Web page wizard step 4

Chapter 16 Creating Web Pages

281

Saving Writer documents as web pages

5) Select a style for the page. Use the drop-down list, shown in Figure 274, to choose
different styles and color combinations. You can browse to a background image and
icon set from the Gallery. Click Next.

Figure 274. Web page wizard step 5
6) Enter general information such as Title and HTML Metadata information, as shown in
Figure 275. Click Next.

Figure 275. Web page wizard step 6
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7) Chose where to save the file and preview the page if you wish, as shown in Figure
276. Click Finish.

Figure 276. Web page wizard step 7
To edit or view the document’s underlying HTML code, click View > HTML Source or click
the HTML Source icon
on the Main toolbar.

Saving Calc spreadsheets as web pages
Calc can save files as HTML documents. As for Writer, use File > Save As and select HTML
Document, or File > Wizards > Web Page.
If the file contains more than one sheet, the additional sheets will follow one another in the
HTML file. Links to each sheet will be placed at the top of the document. Calc also allows
the insertion of links directly into the spreadsheet using the Hyperlink dialog.

Saving Impress presentations as web pages
You can export presentations as Macromedia Flash files: select File > Export and choose
Macromedia Flash for the file type.
You can also convert presentations into a series of web pages, as described below.
Note

Saving as web pages (HTML format) does not retain animation and slide transitions.

1) To begin, select File > Export and choose HTML Document as the file type.
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2) Create a folder for the files, supply a name for the resulting HTML file, and click
Save. The HTML Export Wizard opens.
Note

Depending on the size of your presentation and the number of graphics it contains,
the HTML export function creates many HTML, JPG, and GIF files. If you simply
save to your desktop (not in a specific folder), these separate HTML and graphics
files will be all over your desktop. So be sure to create a folder to hold all the files.

3) Choose the design for all of the pages, either from an existing design or by creating a
new one.
If you have not previously saved a design, the Existing Design choice is not available.

4) Click Next to select the type of web pages to create.
• Standard HTML: one page for each slide, with navigation links to move from slide
to slide.
• Standard HTML with frames: one page with a navigation bar on the left-hand side;
uses slide title as navigation links. Click on links to display pages in right-hand
side.
• Automatic: one page for each slide, with each page set with the Refresh meta tag so
a browser automatically cycles from one page to the next.
•
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WebCast: generates an ASP or Perl application to display the slides. Unfortunately
OOo has no direct support for PHP as yet.
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5) Decide how the images will be saved (GIF or JPG) and what resolution to use.
When choosing a resolution, consider what the majority of your viewers might have. If
you use a high resolution, then a viewer with a medium-resolution monitor will have
to scroll sideways to see the entire slide—probably not desirable.

6) If Create title page was chosen in step 4, supply the information for it on the next
page. The title contains an author name, e-mail address and home page, along with any
additional information you want to include.
This page of the Wizard does not display if Create title page was not chosen.
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7) Choose the navigation button style to use to move from one page to another. If you do
not choose any, OOo will create a text navigator.

8) Select the color scheme for the web pages. Available schemes include the document’s
existing scheme, one based upon browser colors, and a completely user-defined
scheme. You can save a new scheme so that it will appear on the first page of the
HTML export wizard.
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9) Click Create to generate the HTML files. If this is a new design, a small dialog pops
up. If you might want to reuse this design, you can give it a name and save it.
Otherwise, click Do Not Save.

Saving Draw documents as web pages
Exporting drawings from OpenOffice.org’s Draw application is similar to exporting a
presentation from Impress. Use File > Export and select HTML Document as the file type.
When using the wizard, you can choose to create the web page at any time by clicking the
Create button.
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Your first macro
A macro is a saved sequence of commands or keystrokes that are stored for later use. An
example of a simple macro is one that “types” your address. The OpenOffice.org macro
language is very flexible, allowing automation of both simple and complex tasks. Macros are
especially useful to repeat a task the same way over and over again.
OpenOffice.org macros are usually written in a language called StarBasic, or just abbreviated
Basic. Although you can learn Basic and write macros, there is a steep learning curve to
writing macros from scratch. The usual method for a beginner is to use the built-in macro
recorder, which records your keystrokes and saves them for use.
Most tasks in OpenOffice.org are accomplished by “dispatching a command” (sending a
command), which is intercepted and used. The macro recorder works by recording the
commands that are dispatched (see “The dispatch framework” on page 299).

Creating a simple macro
Imagine repeatedly entering simple information. Although you can store the information in
the clipboard, if you use the clipboard for something else, the contents are changed. Storing
the contents as a macro is a simple solution. (In some simple cases, including the example
used here, a better solution is to use AutoText.)
10)Use Tools > Macros > Record Macro to start recording a macro. A small window is
displayed so you know that OpenOffice.org is recording.

11)Type the desired information or perform an appropriate series of operations. In this
case, I typed my name, Andrew Pitonyak.
12)Click the Stop Recording button to stop recording, save the macro, and display the
OpenOffice.org Basic Macros dialog (see Figure 277).
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Figure 277: OOo Macro Organizer dialog, DBInspection library selected.
13)Be certain to open the library container named My Macros. Find the library named
Standard under My Macros. Be warned, every library container has a library named
Standard. Select the Standard library and click New Module to create a new module to
contain the macro.

Figure 278: Give your module a meaningful name.
14)The default module name is Module1; choose a better name. Although it is still not
descriptive, I used Recorded. Type a descriptive name and click OK to create the
module. The OpenOffice.org Basic Macros dialog is displayed again, showing the new
module.
15)Highlight the newly created module. In the upper left corner, type the macro name to
use, such as “EnterMyname”, and then click Save to save the macro.
If you followed all of the steps, the Standard library now contains a module named Recorded,
which contains the EnterMyName macro, as shown in Figure 279. When OOo creates a new
module, it automatically adds the macro named Main; as seen in Figure 279.

Running the macro
Use Tools > Macros > Run Macro to open the Macro Selector dialog (see Figure 279).
Select the newly created macro and click Run.
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Figure 279: Select your macro and click Run.
There are other methods to run a macro. For example, use Tools > Macros > Organize
Macros > OpenOffice.org Basic to open the macro organizer, which contains a Run button
as well. The author, an avid macro writer, prefers the macro organizer because the dialog
usually opens faster, but the selection process may be slightly slower.

Viewing and editing the macro
You can view and edit the macro that was just created. Use Tools > Macros > Organize
Macros > OpenOffice.org Basic to open the OpenOffice.org Basic Macros dialog (see
Figure 279). Select the new macro and click Edit to open the macro in the Basic IDE
(Integrated Development Environment).
Listing 1: Generated “EnterMyname” macro.
REM *****
Sub Main

BASIC

*****

End Sub
sub EnterMyName
rem ---------------------------------------------------------------------rem define variables
dim document
as object
dim dispatcher as object
rem ---------------------------------------------------------------------rem get access to the document
document
= ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
rem ---------------------------------------------------------------------dim args1(0) as new com.sun.star.beans.PropertyValue
args1(0).Name = "Text"
args1(0).Value = "Andrew Pitonyak"
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args1())
end sub
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The macro in Listing 1 is not as complicated as it first appears. Learning a few things helps
significantly in understanding the generated macros. The discussion starts with features near
the top of the macro listing and describes them. If you like to avoid details, then simply
change the text “Andrew Pitonyak” to what you want to insert at the current cursor position.
Comments start with REM

The keyword REM, short for remark, starts a macro comment. All text after REM (on the
same line) is ignored. As a short cut, the single quote character can also be used to start a
comment.
Tip

StarBasic is not case-sensitive for keywords, so REM, Rem, and rem all start a
comment. If you use symbolic constants defined by the API, it is safer to assume
that the names are case-sensitive—if this matters to you, then you are probably too
advanced to read this document.

Defining subroutines with SUB

Individual macros are stored in subroutines defined with the keyword SUB. A subroutine
ends using the words END SUB. The macro starts by defining the subroutine named Main,
which is empty and does nothing. The next subroutine, EnterMyName, is the subroutine of
interest, and it contains the newly generated code.
Tip

OpenOffice.org creates an empty subroutine named Main when it creates a module.

There are advanced topics that are beyond the scope of this document, but knowing about
them might be of interest:
•

•

You can write a subroutine so that values are sent into the macro when it is called from
another macro. Recorded macros do not accept arguments from other macros.
Another kind of subroutine is called a function. A function is a subroutine that can
return a value to a calling macro. The keyword FUNCTION is used rather than SUB to
define a function. Generated macros are always of type SUB.

Defining variables using DIM

A very simple macro can use hard coded values for everything. Unfortunately, even simple
macros that interact with OpenOffice.org must store intermediate values. Storing an
intermediate value is similar to writing information on a piece of paper so that you can look
at it later. The DIM statement is similar to setting aside a piece of paper to be used to store a
message or note.
The EnterMyName macro defines the variables document and dispatcher as type object.
Other common variable types include string, integer, and date. A third variable named args1
is defined. Args1 is a very complicated type; it is an array of property values. A variable of
type array allows a single variable to contain multiple values, similar to storing multiple
pages in a single book. Values in an array are usually numbered starting from zero. The
number in the parentheses indicates the highest usable number to access a storage location. In
this example, there is only one value, and it is numbered zero. This sounds confusing, but for
now, ignore the problem and more examples will clarify the concept.
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Pulling the macro together

The following details are very complete; it is not important to understand all of the details.
The first line defines the start of the macro.
sub EnterMyName

Declare two variables:
dim document
as object
dim dispatcher as object

ThisComponent refers to the current document.
The CurrentController property of a document refers to a service that “controls” the
document. For example, when you type, it is the current controller that notices. The current
controller then dispatches the changes to the document’s frame.
The Frame property of a controller returns a main frame for a document. Therefore, the
variable named document refers to a document’s frame, which receives dispatched
commands.
document = ThisComponent.CurrentController.Frame

Most tasks in OpenOffice.org are accomplished by dispatching a command. Starting with
OOo version 2.0, a dispatch helper object is available, which greatly facilitates executing
dispatches from a macro. The method CreateUnoService accepts the name of a service and it
tries to create an instance of that service. On completion, the dispatcher variable contains a
reference to a DispatchHelper.
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

Declare an array of properties. Each property has a name and a value. In other words, it is a
name/value pair. The created array has one property at index zero.
dim args1(0) as new com.sun.star.beans.PropertyValue

Give the property the name “Text” and the value “Andrew Pitonyak”, which is the text that is
inserted when the macro is run.
args1(0).Name = "Text"
args1(0).Value = "Andrew Pitonyak"

This is where the magic happens. The dispatch helper sends a dispatch to the document’s
frame (stored in the variable named document) with the command “.uno:InsertText”. The
next two arguments, frame name and search flags, are beyond the scope of this document.
The last argument is the array of property values to be used while executing the command
InsertText.
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args1())

Finally, the end of the subroutine.
end sub
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A recorded macro repeats the same task over and over again. Before creating a recorded
macro, I usually ask two questions:
1) Can the task be summarized as a simple set of commands that do not change?
2) Can the steps be arranged such that the last command leaves the cursor ready for the
next command?

A complicated example
I frequently copy rows and columns of data from a web site and format them as a table in a
text document. First, I copy the table from the web site to the clipboard. To avoid strange
formatting and fonts, I paste the text into a Writer document as unformatted text. I reformat
the text with tabs between columns so that I can use Table > Convert > Text to Table to
convert to a table.
I inspect the text to see if I can record a macro to format the text (remember the two questions
that I ask). As an example, I copied the FontWeight constants group from the OpenOffice.org
web site. The first column indicates the constant name. Each name is followed by a space and
a tab.
DONTKNOW
THIN

specifies a 50% font weight.

ULTRALIGHT
LIGHT

The font weight is not specified/known.
specifies a 60% font weight.

specifies a 75% font weight.

SEMILIGHT

specifies a 90% font weight.

NORMAL specifies a normal font weight.
SEMIBOLD
BOLD

specifies a 110% font weight.
specifies a 150% font weight.

ULTRABOLD
BLACK

specifies a 175% font weight.

specifies a 200% font weight.

I want the first column to contain the numeric value, the second column the name, and the
third column the description. The desired work is easily accomplished for every row except
for DONTKNOW and NORMAL, which do not contain a numeric value—but I know that
the values are 0 and 100, so I will enter those manually.
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The data can be cleaned in multiple ways—all of them easy. The first example uses
keystrokes that assume the cursor is at the start of the line with the text THIN.
1) Use Tools > Macros > Record Macro to start recording.
2) Press Ctrl+Right Arrow to move the cursor to the start of “specifies”.
3) Press Backspace twice to remove the tab and the space.
4) Press Tab to add the tab without the space after the constant name.
5) Press Delete to delete the lower case s and then press S to add an upper case S.
6) Press Ctrl+Right Arrow twice to move the cursor to the start of the number.
7) Press Ctrl+Shift+Right Arrow to select and move the cursor before the % sign.
8) Press Ctrl+C to copy the selected text to the clipboard.
9) Press End to move the cursor to the end of the line.
10)Press Backspace twice to remove the two trailing spaces.
11)Press Home to move the cursor to the start of the line.
12)Press Ctrl+V to paste the selected number to the start of the line.
13)Pasting the value also pasted an extra space, so press Backspace to remove the extra
space.
14)Press Tab to insert a tab between the number and the name.
15)Press Home to move to the start of the line.
16)Press down arrow to move to the next line.
17)Stop recording the macro and save the macro.
It takes much longer to read and write the steps than to record the macro. Work slowly and
think about the steps as you do them. With practice this becomes second nature.
The generated macro has been modified to contain the step number in the comments to match
the code to the step above.
Listing 2: Copy the numeric value to the start of the column.
sub CopyNumToCol1
rem ---------------------------------------------------------------------rem define variables
dim document
as object
dim dispatcher as object
rem ---------------------------------------------------------------------rem get access to the document
document
= ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
rem (2) Press Ctrl+Right Arrow to move the cursor to the start of “specifies”.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())
rem (3) Press Backspace twice to remove the tab and the space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
296

Chapter 17 Getting Started with Macros

Creating a macro

rem ---------------------------------------------------------------------dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem (4) Press Tab to add the tab without the space after the constant name.
dim args4(0) as new com.sun.star.beans.PropertyValue
args4(0).Name = "Text"
args4(0).Value = CHR$(9)
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args4())
rem (5) Press Delete to delete the lower case s ....
dispatcher.executeDispatch(document, ".uno:Delete", "", 0, Array())
rem (5) ... and then press S to add an upper case S.
dim args6(0) as new com.sun.star.beans.PropertyValue
args6(0).Name = "Text"
args6(0).Value = "S"
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args6())
rem (6) Press Ctrl+Right Arrow twice to move the cursor to the number.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())
rem ---------------------------------------------------------------------dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())
rem (7) Press Ctrl+Shift+Right Arrow to select the number.
dispatcher.executeDispatch(document, ".uno:WordRightSel", "", 0, Array())
rem (8) Press Ctrl+C to copy the selected text to the clipboard.
dispatcher.executeDispatch(document, ".uno:Copy", "", 0, Array())
rem (9) Press End to move the cursor to the end of the line.
dispatcher.executeDispatch(document, ".uno:GoToEndOfLine", "", 0, Array())
rem (10) Press Backspace twice to remove the two trailing spaces.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem ---------------------------------------------------------------------dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem (11) Press Home to move the cursor to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())
rem (12) Press Ctrl+V to paste the selected number to the start of the line.
dispatcher.executeDispatch(document, ".uno:Paste", "", 0, Array())
rem (13) Press Backspace to remove the extra space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem (14) Press Tab to insert a tab between the number and the name.
dim args17(0) as new com.sun.star.beans.PropertyValue
args17(0).Name = "Text"
args17(0).Value = CHR$(9)
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args17())
rem (15) Press Home to move to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())
Chapter 17 Getting Started with Macros

297

Creating a macro

rem (16) Press down arrow to move to the next line.
dim args19(1) as new com.sun.star.beans.PropertyValue
args19(0).Name = "Count"
args19(0).Value = 1
args19(1).Name = "Select"
args19(1).Value = false
dispatcher.executeDispatch(document, ".uno:GoDown", "", 0, args19())
end sub

Cursor movements are used for all operations (as opposed to searching). If run on the
DONTKNOW line, the word weight is moved to the front of the line, and the first “The” is
changed to “She”. This is not perfect, but I should not have run the macro on the lines that
did not have the proper format; I need to do these manually.

Running the macro quickly
It is tedious to repeatedly run the macro using Tools > Macros > Run Macro (see Figure
279). The macro can be run from the IDE. Use Tools > Macros > Organize Macros >
OpenOffice.org Basic to open the Basic Macro dialog. Select your macro and click Edit to
open the macro in the IDE.
The IDE has a Run Basic icon in the toolbar that runs the first macro in the IDE. Unless you
change the first macro, it is the empty macro named Main. Modify Main so that it reads as
shown in Listing 3.
Listing 3: Modify Main to call CopyNumToCol1.
Sub Main
CopyNumToCol1
End Sub

Now, you can run CopyNumToCol1 by repeatedly clicking the Run Basic icon in the toolbar
of the IDE. This is very fast and easy, especially for temporary macros that will be used a few
times and then discarded.
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Sometimes the macro recorder fails
Understanding the OpenOffice.org internals helps to understand how and why the macro
recorder frequently fails. The primary offender is related to the dispatch framework and its
relationship to the macro recorder.

The dispatch framework
The purpose of the dispatch framework is to provide a uniform access to components
(documents) for commands that usually correspond to menu items. I can use File > Save
from the menu, the shortcut keys Ctrl+S, or click on the Save toolbar icon. All of these
commands are translated into the same “dispatch command”, which is sent to the current
document.
The dispatch framework can also be used to send “commands” back to the UI (User
Interface). For example, after saving the document, the File Save command is disabled. As
soon as the document has been changed, the File Save command is enabled.
If we see a dispatch command, it is text such as .uno:InsertObject or .uno:GoToStartOfLine.
The command is sent to the document’s frame, and the frame passes on the command until an
object is found that can handle the command.

How the macro recorder uses the dispatch
framework
The macro recorder records the generated dispatches. The recorder is relatively simple to
implement and the same commands that are issued are recorded for later use. The problem is
that not all dispatched commands are complete. For example, inserting an object generates
the following code:
dispatcher.executeDispatch(document, ".uno:InsertObject", "", 0, Array())

It is not possible to specify what kind of object to create or insert. If an object is inserted from
a file, you cannot specify which file to insert.
I recorded a macro and used Tools > Options to open and modify configuration items. The
generated macro does not record any configuration changes; in fact, the generated code is
commented so it will not even be run.
rem dispatcher.executeDispatch(document, ".uno:OptionsTreeDialog", "", 0,
Array())

If a dialog is opened, the command to open the dialog is likely to be generated. Any work
done inside the dialog is not likely to be recorded. Examples include macro organization
dialogs, inserting special characters, and similar types of dialogs. Other possible problems
using the macro recorder include things such as inserting a formula, setting user data, setting
filters in Calc, actions in database forms, and exporting a document to an encrypted PDF file.
You never know for certain what will work unless you try it, however. The actions from the
search dialog are properly captured, for example.
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Other options
When the macro recorder is not able to solve a specific problem, the usual solution is to write
code using the OpenOffice.org objects. Unfortunately, there is a steep learning curve for the
OOo objects. It is usually best to start with simple examples and then branch out slowly as
you learn more. Learning to read generated macros is a good place to start.
If you record Calc macros, and the recorder can correctly generate a macro, there is an add-in
created by Paolo Mantovani, which converts Calc macros when they are recorded. The final
code manipulates OpenOffice.org objects rather than generating dispatches. This can be very
useful for learning the object model.
You can download the macro recorder from Paolo’s web site directly or from the OOo
Macros web site. You should check both places to see which contains the latest version.
http://www.paolo-mantovani.org/downloads/DispatchToApiRecorder/
http://www.ooomacros.org/user.php

Macro organization
In OpenOffice.org, macros are grouped in modules, modules are grouped in libraries, and
libraries are grouped in library containers. A library is usually used as a major grouping for
either an entire category of macros, or for an entire application. Modules usually split
functionality types such as user interaction and calculations. Individual macros are
subroutines and functions.

Figure 280: Macro Library hierarchy.
Use Tools > Macros > Organize Macros > OpenOffice.org Basic to open the
OpenOffice.org Basic Macros dialog (see Figure 281). All available library containers are
shown in the Macro from list. Every document is a library container, capable of containing
multiple libraries. The application itself acts as two library containers, one container for
macros distributed with OpenOffice.org called OpenOffice.org Macros, and one container for
personal macros called My Macros. As shown in Figure 281, only two documents are
currently open.
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Figure 281: Library containers are shown on the left.
The OpenOffice.org Macros are stored with the application runtime code, which may not be
editable to you unless you are an administrator. This is just as well since these macros should
not be changed and you should not store your own macros in the OOo container.
Unless your macros are applicable to a single document, and only to a single document, your
macros will probably be stored in the My Macros container. The My Macros container is
stored in your user area or home directory.
If a macro is contained in a document, then a recorded macro will attempt to work on that
document; primarily because it uses “ThisComponent” for its actions.
Every library container contains a library named Standard. It is better to create your own
libraries with meaningful names than to use the Standard library. Not only are meaningful
names easier to manage, but they can also be imported into other library containers whereas
the Standard library cannot.
Caution

OpenOffice.org allows you to import libraries into a library container, but it will not
allow you to overwrite the library named Standard. Therefore, if you store your
macros in the Standard library, you cannot import them into another library
container.

Just as it makes good sense to give your libraries meaningful names, it is prudent to use
meaningful names for your modules. By default, OpenOffice.org uses names such as
Module1. Feel free to use your own meaningful name.
As you create your macros, you must decide where to store them. Storing a macro in a
document is useful if the document will be shared and you want the macro to be included
with the document. Macros stored in the application library container named My Macros,
however, are globally available to all documents.
Macros are not available until the library that contains them is loaded. The Standard library
and Template library, however, are automatically loaded. A loaded library is displayed
differently from a library that is not loaded. To load the library and the modules it contains,
double-click on the library.
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Where are macros stored?
OpenOffice.org stores user-specific data in a directory under the user’s home directory. For
example, on Windows, this is C:\Documents and Settings\<name>\Application Data. User
macros are stored in OpenOffice.org2\user\basic. Each library is stored in its own directory
off the basic directory.
It is not important to understand where macros are stored for casual use. If you know where
they are stored, however, you can create a backup, share your macros, or inspect them if there
is an error. For example, on one or more of my OpenOffice.org upgrades, all of my macros
disappeared. Although the macros were still on disk, the macros were not copied to the new
directories. The solution was to import the macros into the new installation.
Use Tools > Macros > Organize Dialogs to open the OpenOffice.org Macros organizer
dialog. Another common way to open this dialog is to use Tools > Macros > Organize
Macros > OpenOffice.org Basic to open the OpenOffice.org Macros dialog and then click
the Organizer button (see Figure 282).

Figure 282: The macro organizer dialog.
The OpenOffice.org Macro Organizer dialog provides functionality to create, delete, and
rename libraries, modules, and dialogs. Select the library container to use and then click the
Import button to import macro libraries (see Figure 283).
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Tip

You cannot import the library named Standard.

Tip

On Linux, the OpenOffice.org-specific files are stored in a directory whose name
begins with a period. Directories and files with names beginning with a period are
not shown in a normal selection dialog. To open the directory, I navigated to the
parent directory, entered the name .openoffice.org2, and then clicked Open. This
opened the directory, which was not initially shown.
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Figure 283: Select a macro library to import.
Navigate to the directory containing the library to import. There are usually two files from
which to choose, dialog.xlb and script.xlb. It does not matter which of these two files you
select; both will be imported. Select a file and click Open to continue (see Figure 284).

Figure 284: Choose library import options.
If the library already exists, it will not be replaced unless Replace existing libraries is
checked. If Insert as reference is checked, the library is referenced in its current location, but
you cannot edit the library. If Insert as reference is not checked, however, the library is
copied to the user’s macro directory.
Macros can be stored in libraries inside OpenOffice.org documents. Select a document rather
than a directory on disk (as shown in Figure 283) to import libraries contained in a document.

Downloading macros to import
Macros are available for download. Some macros are contained in documents, some as
regular files that you must select and import, and some as macro text that should be copied
and pasted into the Basic IDE; use Tools > Macros > Organize Macros > OpenOffice.org
Basic to open the OpenOffice.org Macros dialog, choose the macro to edit, and then click
Edit to open the macro in the Basic IDE.
Some macros are available as free downloads on the Internet (see Table 3).
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Table 3. Places to find macro examples.
Location

Description

http://www.ooomacros.org/

Excellent collection of packaged macros.

http://www.pitonyak.org/oo.php

Reference materials regarding macros.

http://www.pitonyak.org/database/

Reference materials regarding database macros.

http://development.openoffice.org/

Lots of links to everything.

http://www.oooforum.org/

Many examples and help.

How to run a macro
A typical method to run a macro is as follows:
1) Use Tools > Macros > Run Macro to open the Macro Selector dialog (see Figure
285).
2) Select the library and module in the Library list (left hand side).
3) Select the macro in the Macro name list (right hand side).
4) Click Run to run the macro.

Figure 285. Use the Macro Selector dialog to run macros.
Although you can use Tools > Macros > Run Macro to run all macros, this is not efficient
for frequently run macros. A more common technique is to assign a macro to a toolbar button,
menu item, keyboard shortcut, or a button embedded in a document. While choosing a
method, it is also good to ask questions such as:
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•

Should the macro be available for only one document, or globally for all documents?

•

Does the macro pertain to a specific document type, such as a Calc document?

•

How frequently will the macro be used?
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The answers will determine where to store the macro and how to make it available. For
example, you will probably not add a rarely used macro to a toolbar. To help determine your
choices, see Table 4.
Table 4. Methods for starting a macro.
Type

OpenOffice.org

Document Type

Document

Toolbar

No

Yes

Yes

Menu

No

Yes

Yes

Shortcut

Yes

Yes

No

Event

Yes

No

Yes

To add a menu item, keyboard shortcut, or toolbar icon that calls a macro, use the Customize
dialog (see Figure 286). Open this dialog in either of these ways:
•

Choose Tools > Customize from the main menu bar.

•

Each toolbar has an icon

that opens a menu; choose the Customize Toolbar option.

Figure 286: OpenOffice.org Customize dialog.
Tip

Complete coverage of the Customize dialog is beyond the scope of this document.
Click the Help button to access the help pages included with OpenOffice.org.

The Customize dialog contains tabs to configure menus, keyboard bindings, toolbars, and
events.
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Toolbar
Macros can be added to toolbars. To see more about modifying toolbars, see Chapter 4
(Menus and Toolbars).

Menu item
Use Tools > Customize to open the Customize dialog, and select the Menus tab. You can
modify an existing menu, or create new menus that call macros. To see more about modifying
menus, see Chapter 4 (Menus and Toolbars).

Keyboard shortcuts
Use Tools > Customize to open the Customize dialog, and select the Keyboard tab.
Assigning keyboard shortcuts is discussed in Appendix A (Keyboard Shortcuts).

Event
In OpenOffice.org, when something happens, we say that an event occurred. For example, a
document was opened, a key was pressed, or the mouse moved. OpenOffice.org allows
events to cause a macro to be called; the macro is then called an event handler. Full coverage
of event handlers is well beyond the scope of this document, but a little knowledge can
accomplish much.
Caution

Be careful when you configure an event handler. For example, assume that you
write an event handler that is called every time that a key is pressed, but you make a
mistake so the event is not properly handled. One possible result is that your event
handler will consume all key presses, forcing you to forcibly terminate
OpenOffice.org.

Use Tools > Customize to open the Customize dialog, and select the Events tab (see Figure
287). The events in the Customize dialog are related to the entire application and specific
documents. Use the Save In box to choose OpenOffice.org, or a specific document.
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Figure 287: Assign macro to an application level event.
A common use is to assign the Open Document event to call a specific macro. The macro
then performs certain setup tasks for the document. Select the desired event and click the
Macro button to open the Macro Selector dialog (see Figure 280).
Select the desired macro and click OK to assign the macro to the event. The Events tab
shows that the event has been assigned to a macro (see Figure 278). When the document
opens, the PrintHello macro is run.

Figure 288: Assign macro to the document open event.
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Figure 289: PrintHello is assigned to the Open Document event.
Many objects in a document can be set to call macros when events occur. The most common
usage is to add a control, such as a button, into a document. Even double-clicking on a
graphic opens a dialog with a Macros tab that allows you to assign a macro to an event.

Extensions
An extension is a package that can be installed into OpenOffice.org to add new functionality.
Extensions can be written in almost any programming language and may be simple or
sophisticated. Extensions can be grouped into types:
•

Calc Add-Ins, which provide new functionality for Calc, including new functions that
act like normal built-in functions

•

New components and functionality, which normally include some level of UI
integration such as new menus or toolbars

•

Data pilots that are used directly in Calc

•

Chart Add-Ins with new chart types

•

Linguistic components such as spell checkers

•

Document templates and images

Although individual extensions can be found in different places, there is an extension
repository at: http://wiki.services.openoffice.org/wiki/Extensions_repository. To learn more
about extensions, see Chapter 12 (Working with Templates) in this book.

Writing macros without the recorder
The examples covered in this chapter are created using the macro recorder and the dispatcher.
You can also write macros that directly access the objects that comprise OpenOffice.org. In
other words, you can directly manipulate a document.
Directly manipulating OOo’s internal objects is an advanced topic that is beyond the scope of
this chapter. A simple example, however, demonstrates how this works.
Listing 4: Append the text “Hello” to the current document.
Sub AppendHello
Dim oDoc
Dim sTextService$
Dim oCurs
REM ThisComponent refers to the currently active document.
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oDoc = ThisComponent
REM Verify that this is a text document
sTextService = "com.sun.star.text.TextDocument"
If NOT oDoc.supportsService(sTextService) Then
MsgBox "This macro only works with a text document"
Exit Sub
End If
REM Get the view cursor from the current controller.
oCurs = oDoc.currentController.getViewCursor()
REM Move the cursor to the end of the document
oCurs.gotoEnd(False)
REM Insert text "Hello" at the end of the document
oCurs.Text.insertString(oCurs, "Hello", False)
End Sub

Finding more information
Numerous resources are available that provide help with writing macros. Use Help >
OpenOffice.org Help to open the OOo help pages. The upper left corner of the OOo help
system contains a drop-down list that determines which help set is displayed. To view the
help for Basic, the drop-down must display Help about OpenOffice.org Basic.

Included material
Many excellent macros are included with OOo. Use Tools > Macros > Organize Macros >
OpenOffice.org Basic to open the Macro dialog. Expand the Tools library in the
OpenOffice.org library container. Inspect the Debug module—some good examples include
WritedbgInfo(document) and printdbgInfo(sheet).

Online resources
The following links and references contain information regarding macro programming:
•

http://www.openoffice.org (the main link)

•

http://codesnippets.services.openoffice.org/ (categorized examples)

•

http://www.oooforum.org (if you need help with your macros this is a good place to
ask, probably one of the best supported OOo forums on the web)

•

http://api.openoffice.org/docs/common/ref/com/sun/star/module-ix.html (official IDL
reference, here you'll find almost every command with a description)

•

http://api.openoffice.org/DevelopersGuide/DevelopersGuide.html (official
documentation that contains a detailed explanation)

•

http://www.pitonyak.org/oo.php (Andrew Pitonyak’s macro page)

•

http://www.pitonyak.org/AndrewMacro.odt (numerous examples of working macros)
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•

http://www.pitonyak.org/book/ (Andrew Pitonyak wrote a book on macros)

•

http://www.pitonyak.org/database/ (numerous macro examples using Base)

•

http://docs.sun.com/app/docs (Sun wrote a book on macro programming—very well
written and laid out)

•

http://documentation.openoffice.org (contains content related to macros)

•

http://ooextras.sourceforge.net/ (examples)

•

http://sourceforge.net/project/showfiles.php?group_id=43716 (examples)

•

http://homepages.paradise.net.nz/hillview/OOo/ (numerous excellent macros,
including reveal codes macros, key macros, and information on converting from MS
Office)

Published material
The following published sources contain macro examples. The most obvious example is the
documentation from Sun. Start from Sun’s documentation site http://docs.sun.com/app/docs
and search for StarOffice documentation.
Andrew Pitonyak wrote a book called OpenOffice.org Macros Explained. Two chapters are
available as direct downloads from the publisher. See http://www.pitonyak.org/book/.
Dr. Mark Alexander Bain wrote Learn OpenOffice.org Spreadsheet Macro Programming (see
http://www.packtpub.com/openoffice-ooobasic-calc-automation/book).
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Appendix A
Keyboard Shortcuts

Introduction

Introduction
You can use OpenOffice.org (OOo) without requiring a pointing device, such as a mouse or
trackball, by using its built-in keyboard shortcuts. Tasks as varied and complex as docking
and un-docking toolbars and windows, or changing the size or position of objects, can all be
accomplished with only a keyboard.
OOo has a general set of keyboard shortcuts, available in all components, and a componentspecific set directly related to the work of that component (Writer, Calc, Impress, Draw and
Base). This document describes the general set: the component specific shortcuts are fully
described in the appropriate appendix of the relevant component guide.
For help with OOo’s keyboard shortcuts, or using OOo with a keyboard only, search the OOo
Help using the “shortcut” or “accessibility” keywords.

Assigning shortcut keys
In addition to using the built-in keyboard shortcuts (listed later in this Appendix), you can
define your own. You can assign shortcuts to standard OOo functions or your own macros
and save them for use with the entire OpenOffice.org suite.
Caution

Be careful when reassigning your operating system’s or OOo’s predefined shortcut
keys. Many key assignments are universally understood shortcuts, such as F1 for
Help, and are always expected to provide certain results. Although you can easily
reset the shortcut key assignments to the OOo defaults, changing some common
shortcut keys can cause confusion, frustration and possible data loss or corruption,
especially if other users share your computer.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.
5) Select Tools > Customize > Keyboard. The Customize dialog (Figure 290) opens.
6) To have the shortcut key assignment available in all components of OpenOffice.org
select the OpenOffice.org button.
7) Next select the required function from the Category and Function lists.
8) Now select the desired shortcut keys in the Shortcut keys list and click the Modify
button at the upper right.
9) Click OK to accept the change. Now the chosen shortcut keys will execute the
function chosen in step 3 above whenever they are pressed.
Notes
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1. All existing shortcut keys for the currently selected Function are listed in the
Keys selection box. If the Keys list is empty, it indicates that the chosen key
combination is free for use. If it were not, and you wished to reassign a shortcut
key combination that is already in use, you must first Delete the existing Key.
2. Shortcut keys that are greyed-out in the listing on the Customize dialog, such as
F1 and F10, are not available for reassignment.
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Figure 290: Customize dialog

Saving changes to a file
Changes to the shortcut key assignments (and other configurations) can be saved in a
keyboard configuration file for use at a later time, thus permitting you to create and apply
different configurations as the need arises. To save keyboard shortcuts to a file:
1) After making your keyboard shortcut assignments, click the Save button near the
bottom right of the Customize dialog (Figure 290).
2) In the Save Keyboard Configuration dialog, select All files from the Save as Type list.
3) Next enter a name for the keyboard configuration file in the File name box, or select
an existing file from the list. If you need to, browse to find a file from another location.
4) Click Save. A confirmation dialog will appear if you are about to overwrite an existing
file, otherwise there will be no feedback and the file will be saved.

Appendix A Keyboard Shortcuts

313

Assigning shortcut keys

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the
Load button near the bottom right of the Customize dialog (Figure 290), and then select the
configuration file from the Load Keyboard Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the
bottom right of the Customize dialog (Figure 290). Use this feature with care as no
confirmation dialog will be displayed; the defaults will be set without any further notice or
user input.

Running macros
You can also define shortcut key combinations that will run macros. These shortcut keys are
strictly user-defined; none are built in. For information on macros, see Chapter 17 (Getting
started with macros).
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General shortcut keys for OpenOffice.org
Shortcut Keys

Result

Enter key
Esc

Activates the focused button in a dialog.
Terminates the action or dialog. If in OpenOffice.org Help: goes up
one level.
Toggles the focused check box in a dialog.
Changes the active control field in an option section of a dialog.
Advances focus to the next section or element in a dialog.
Moves the focus to the previous section or element in a dialog.
Opens the list of the control field currently selected in a dialog.
These shortcut keys apply not only to combo boxes but also to icon
buttons with pop-up menus. Close an opened list by pressing the
Escape key.
Deletes the selected items into the recycle bin.
Deletes the selected items without putting them in the recycle bin.
When a folder is shown: goes up one level (goes back).
Removes direct formatting from selected text or objects (as in
Format > Default Formatting).
When positioned at the start of a header, a tab is inserted.
Activates the selected OLE object.

Spacebar
Arrow keys
Tab
Shift + Tab
Alt+Down Arrow

Del
Shift+Del
Backspace
Ctrl+Shift+Space
Ctrl + Tab
Enter (if an OLE object
is selected)
Enter (if a drawing
object or text object is
selected)
Ctrl + O
Ctrl + S
Ctrl + N
Shift+Ctrl+N
Ctrl + P
Ctrl + Q
Ctrl + X
Ctrl + C
Ctrl + V
Ctrl + Shift + V
Ctrl + A
Ctrl + Z
Ctrl + Y
Ctrl+F
Ctrl+Shift+F
Ctrl+Shift+J
Ctrl+Shift+R
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Activates text input mode.
Opens a document.
Saves the current document.
Creates a new document.
Opens Templates and Documents dialog.
Prints document.
Exits application.
Cuts out the selected elements.
Copies the selected items.
Pastes from the clipboard.
Opens the Paste Special dialog.
Selects all.
Undoes last action.
Redoes last action.
Calls the Find & Replace dialog.
Searches for the last entered search term.
Toggles the view between fullscreen mode and normal mode in
Writer or Calc.
Redraws the document view.
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Shortcut Keys

Result

Shift+Ctrl+I
Ctrl+I

Enable or disable the selection cursor in read-only text.
Applies the Italic attribute to the selected area. If the cursor is
positioned in a word, this word is also marked in italic.
Applies The Bold attribute to the selected area. If the cursor is
positioned in a word, this word is also put in bold.
Applies the Underlined attribute to the selected area. If the cursor
is positioned in a word, this word is also underlined.

Ctrl+B
Ctrl+U

Keyboard shortcuts using the function keys
Shortcut Keys
F1
Shift + F1
Shift+F2
Ctrl+F4 or Alt+F4
F6
Shift+F6
F10
Shift+F10
Ctrl+F11

Result
Starts the OpenOffice.org Help.
In the OpenOffice.org Help: jumps to main help page.
Activates Extended Tips for the mouse pointer, which turns into a
question mark. Move the pointer over an item (command, icon or
control) to view the extended tip.
Displays an extended tip for the item (command, icon or control)
currently selected by using the keyboard.
Closes the current document (close OpenOffice.org when the last
open document is closed).
Sets focus in next sub-window (for example, document/data
source view).
Sets focus in previous sub-window.
Activates the first menu (File menu).
Opens the context menu.
Opens the Style Catalog.

Shortcut keys in the Gallery
Shortcut Keys
Tab
Shift+Tab
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Result
Moves between areas.
Moves between areas (backwards).
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Shortcut keys in the New Theme area of the Gallery
Shortcut keys
Up arrow
Down arrow
Ctrl+Enter
Shift+F10
Ctrl+U
Ctrl+R
Ctrl+D
Insert

Result
Moves the selection up.
Moves the selection down.
Opens the Properties dialog.
Opens a context menu.
Refreshes the selected theme.
Opens the Enter Title dialog.
Deletes the selected theme.
Inserts a new theme.

Shortcut keys in the Gallery preview area
Shortcut keys
Home
End
Left Arrow
Right Arrow
Up Arrow
Down Arrow
Page Up
Page Down
Ctrl+Shift+Insert
Ctrl+I
Ctrl+T
Ctrl+P
Spacebar
Enter
Step backward

Result
Jumps to the first entry.
Jumps to the last entry.
Selects the next Gallery element on the left.
Selects the next Gallery element on the right.
Selects the next Gallery element above.
Selects the next Gallery element below.
Scrolls up one screen.
Scrolls down one screen.
Inserts the selected object as a linked object into the current document.
Inserts a copy of the selected object into the current document.
Opens the Enter Title dialog.
Switches between themes view and object view.
Switches between themes view and object view.
Switches between themes view and object view.
Switches back to main overview (only in object view).

Selecting rows and columns in a table
Shortcut keys
Spacebar
Ctrl+Spacebar
Shift+Spacebar
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Result
Toggles row selection, except when the row is in edit mode.
Toggles row selection.
Selects the current column.
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Shortcut keys for drawing objects

Shortcut keys for drawing objects
Shortcut keys
Select the toolbar with
F6. Use the Down Arrow
and Right Arrow to select
the desired toolbar icon
and press Ctrl+Enter
Select the document with
Ctrl+F6 and press Tab
Tab
Shift+Tab
Ctrl+Home
Ctrl+End
Esc
Esc (in Handle Selection
Mode)
Up/down/left/right arrow
Alt+Up/Down/Left/Right
Arrow

Spacebar

Shift+Spacebar
Ctrl+Tab

Shift+Ctrl+Tab
Ctrl+Enter
Ctrl+Enter at the
Selection icon
Esc

Any text or numerical key
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Result
Inserts a Drawing Object.

Selects a Drawing Object.
Selects the next Drawing Object.
Selects the previous Drawing Object.
Selects the first Drawing Object.
Selects the last Drawing Object.
Ends Drawing Object selection.
Exits Handle Selection Mode and returns to Object Selection Mode.
Moves the selected point (the snap-to-grid functions are
temporarily disabled, but end points still snap to each other).
Moves the selected Drawing Object one pixel (in Selection Mode).
Re-sizes a Drawing Object (in Handle Selection Mode).
Rotates a Drawing Object (in Rotation Mode).
Opens the properties dialog for a Drawing Object.
Activates the Point Selection mode for the selected drawing object.
Selects a point of a drawing object (in Point Selection mode) or
cancels the selection.
The selected point blinks once per second.
Selects an additional point in Point Selection mode.
Selects the next point of the drawing object (Point Selection
mode).
In Rotation mode, the center of rotation can also be selected.
Selects the previous point of the drawing object (Point Selection
mode).
Places a new drawing object with default size in the center of the
current view.
Activates the first drawing object in the document.
Leaves the Point Selection mode. The drawing object is selected
afterwards.
Edits a point of a drawing object (Point Edit mode).
If a drawing object is selected, switches to edit mode and places
the cursor at the end of the text in the drawing object. A printable
character is inserted.
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Index
3
3D view 58

A
accessibility features 312
accessibility options 63
advantages of OpenOffice.org 4
antialiasing screen font 58
appearance options 62
Apply Style list 250
area fill, editing 137
arranging objects 132
Asian language support 69
AutoCorrect 71, 82
AutoFormat 82, 86
automatic saving 28
autorecovery 9, 28
AutoText 83
AutoUpdate styles 253

B
background images from Gallery 262
Base 4
Basic 290
BibTeX, export to 30
BitTorrent 10
brackets (Math) 230
bring forward 132
bulleted lists 86
Bullets and Numbering toolbar 86

C
Calc 3
Calc macros 300
cell reference 103
cells
spreadsheet 100
change tracking 89
changes, accepting or rejecting 91
circle, drawing 129
CMYK 124
Color Bar 123
color options 60
color palette 123
color scheme 62
columns and rows
freezing 110
inserting 107
selecting 106
unfreezing 111
command line, starting Writer 21
Index

comment on a marked change 90
comparing documents 89
comparison of office suites 5
complex text layout (CTL) 4, 69
components of OpenOffice.org 2, 5
compression of images 31
conditional hyphen 88
connectors 130
consultants 12
Control+arrow keys 79
Control+C 78
Control+F 79
Control+F3 83
Control+minus sign 88
Control+Shift+minus sign 88
Control+V 78
Control+X 78
Control+Y 89
Control+Z 88
copying object from Gallery 261
create document from template 236
cross-fading 136
custom dictionary 70
Customize dialog 305
customizing
menus 45
toolbars 48

D
data source
description 162
editing 198
linking 196
registering 196
using in OOo documents 199
viewing 198
database
AutoValue 170
creating 164
creating subforms 196
creating tables 165
field types and formats 167
list table 173
planning 163
primary key 165, 168, 170
registering 198
Report Wizard 213
Table Wizard 165
tables 165
database form
activation order 194
background 191
creating in Design View 196
creating using a Wizard 177
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entering data 200
modifying 181
subform 178
tab order 194
database reports
creating 212
modifying 218
static 213
database table
create using wizard 165
dynamic 216
joined fields 179
relationships 174
DataPilot (Calc) 9
dBase database 196
de 243
default file format 25, 66
default languages for documents 68
default template 243
deleting files 35
derivative markup (Math) 232
Design View (Base)
creating a new table 169
creating forms 196
creating queries 207
dictionaries, installing 68
dictionary 82
digital rights management (DRM) 34
digital signature 40
digital signatures 8
DIM 293
dispatch framework 299
dispatch helper 294
dockable window 49
document
create from template 236
document status option 56
document views (Writer) 75
Documentation Project 11
Draw 3, 120, 138
drawing
circle or ellipse 129
copying objects 135
Flash export 138
grid 125
HTML export 138
inserting pictures 138
line 127
rectangle 128
save in a foreign format 138
scale 127
Drawing toolbar 123

E
edit document properties before saving 66
ellipse, drawing 129
email attachments 8
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en-dash and em-dash 84
encryption 8
EPS images in PDF 32
equation
inserting 222
numbering 232
equation editor 222
brackets 230
derivative markup 232
equations over more than one line 230
floating window 228
font size 229
formula layout 230
limits to sum/integral 231
markup 225
matrix markup 231
right-click menu 225
Selection window 223
event handling 306
export to PDF 30
exporting files 8, 30
extended tips 55
Extension Manager 241
extensions 308

F
F11 87
F3 83
fault template 243
FDF 32
features of OpenOffice.org 6
file associations 36
file formats 25
file locations 59
file management 24
file sharing options 62
Fill Format 250
find and replace 79
Flash export 283
Flash, export to 30
floating toolbars 46
floating window 49
font history 58
font options 61
font preview 58
font replacements 61
Fontwork
alignment 268
anchoring 271
area options 270
attributes 269
character spacing 269
creating an object 266
editing an object 267
Formatting toolbar 269
Gallery 266
grouping 272
Index

line options 269
moving and resizing objects 273
positioning options 271
same letter heights 268
toolbar 266, 268
footers and headers 94
form controls 9
formatting
pages 92
paragraphs 84
text 84
Formatting toolbar 46
formula editor
See: equation editor 228
formula files, opening 27
formula layout 230
Forum (user support) 11
Free Software Foundation (FSF) 13
function keys 316
Function Wizard (Calc) 101

G
Gallery
adding objects 262
copying object into document 261
creating a new theme 263
deleting images 263
deleting objects 263
hide/show 260
inserting object as background 262
linking object into document 261
location 264
open/close 260
themes 260
views (icon/detailed) 260
general options 55
glue points 130
GNOME Applications menu 17
GNU/Linux 9
graphic files
opening 27
saving 30
graphics
vector 120
grid (Draw) 125
grid options 126

H
handouts (Impress) 158
headers and footers 94
Help Agent 55
Help system 10
Help Tips 55
hidden objects 132
high contrast 55
history of OpenOffice.org 12
Index

horizontal lines 86
HSB 124
HTML compatibility 67
HTML Export Wizard 284
hyperlinks
editing 278
inserting 276
hyphenating words 87

I
icon size and style (user interface) 57
icons in menus 58
IDE 292
image compression 31
importing files 8, 26
Impress 3
inclination 134
indents 81
inserting slides (Impress) 151
installing and setting up 10
Internet options 70
interoperability features 6

J
Java options 64
Java Runtime Environment (JRE) 162
JRE (Java Runtime Environment) 10, 64

K
KDE Office menu 18
KDocker 21
keyboard shortcuts 9
assigning 312
Customize dialog 312
drawing objects 318
function keys 316
Gallery 316
loading from a file 314
OpenOffice.org general 315
resetting to default values 314
running macros 314
saving to a file 313
table 317
keyboard shortcuts (macros) 305
KnowledgeBase 11

L
language settings 68
language support 4
LaTeX, export to 30
layout method (Writer) 93
LGPL 14
libraries of macros 300
library containers 300
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licensing of OpenOffice.org 13
limits to sum/integral 231
Line and Filling toolbar 122
line, drawing 127
linking object from gallery 261
Linux 9
Linux/GNOME Applications menu 17
Linux/KDE Office menu 18
list table (database) 173
load/save options 65
loading styles 257
locale settings 68
long-click buttons 46

M
Mac Applications folder 19
Mac OS X 9, 10
macro information 12
Macro Organizer dialog 302
Macro Selector dialog 304
Macromedia Flash 283
macros 290
Calc 300
comments 293
creating 295
DIM 293
dispatch framework 299
dispatch helper 294
downloading 303
editing 292
event handling 306
example 295
functions 300
IDE 292, 298
library container 291
library containers 300
menu items 305
module 291
modules 300
organization 300
recording 290
REM 293
resources 309
running 291, 304
storage 302
subroutines 293, 300
variables 293
viewing 292
writing 308
mail merge 8
Mantovani, Paolo 300
margins 127
margins (Writer) 97
master slides 146
Math 4
mathematical equations 222
mathematical markup 225
322

mathematical symbols 223
matrix markup (Math) 231
measurement unit 127
memory options 56
Menu bar 44
menu font, changing 44
menus, customizing 45
Microsoft Office file conversion 67
Microsoft Windows 9
Microsoft Word 20
mouse options 58
Mozilla address book 197
Mozilla plug-in 71
multimedia presentations 9
MySQL 162

N
Native Language Project 11
Navigator 49, 103
non-breaking hyphen 88
non-breaking space 84
Normal view (Impress) 155
notes (Writer) 90
Notes view (Impress) 156
numbered lists 86
numbering equations 232
numbering pages 95

O
OASIS 5, 8
objects
adjusting size 133
arranging 132
dynamic movement 133
dynamic size modification 133
framing 131
hidden 132
moving 133
rotating 134
selecting several 132
Office Assistant (Microsoft) 55
OOExtras 12
OOo Macro Organizer dialog 291
OOoMacros 12
Open and Save As dialogs 38
Open Clip Art Library 12
Open Source Initiative (OSI) 13
Open/Save dialogs 56
OpenDocument format 5, 8, 25
opening files 24
OpenOffice.org Basic Macros dialog 290
Options Bar (Draw) 124
Outline view (Impress) 155
OXT extension 241

Index

P
Package Manager 241
page margins 97, 127
page numbering 95
page style 93, 97
palette, color 123
password protection 27
pasting text 78
path options 59
PDF
blank page export 32
digital rights management (DRM) 34
encrypt 34
EPS images 32
form 32
image compression and resolution 31
initial view selection 32
pages to export 31
security settings 34
user interface settings 32
PDF export 30
PDF options 31
PDF Options dialog 31
Pitonyak, Andrew 12
pixels 120
Porting Project 10
Powerpoint
See: Impress 140
presentation
animations, custom 154
example 140
formatting 144
inserting slides 151
output medium 143
planning 140
running 159
slide design 142
styles 148
title page 149
transition effect 143
transitions (slides) 154
Presentation Wizard 141
presentations
saving 29
primary key 168
primary key (database) 168
Print Layout view (Writer) 75
print options
general 58
spreadsheet (Calc) 115
print range (Calc) 116
printing changes document status 56
printing spreadsheet (Calc) 115
programming languages supported 7

Q
Index

queries (database)
aliases 211
creating using a Wizard 203
creating using Design View 207
joined fields 179
modifying 206
search conditions 205
Query Wizard 203
Quickstarter 20, 56
Quickstarter
Linux 21

R
range of cells, selecting (Calc) 106
rectangle, drawing 128
redlines 89
redoing changes 88
regular expressions 79
relationships (database) 174
REM 293
renaming files 35
replacement table (font) 61
Report Wizard (database) 213
restarting page numbering 96
revision marks 89
RGB 124
right to left (RTL) layout 4
rotating an object 134
row limit (Calc) 9
ruler 81, 97
rulers (Draw) 126

S
save as
web page 278
saving as a Microsoft Word document 76
saving files 27
scaling factor (user interface) 57
screen font antialiasing 58
scripting framework 9
security 27
security features 7
security options 62
selecting objects 131
selection modes 130
send backward 132
setup options 54
sheet (spreadsheet) 100
sheet tabs 102
sheets
deleting 109
entering dates and times 114
entering numbers 114
entering numbers as text 114
entering text 114
inserting 108
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removing split views 113
renaming 110
splitting the window 112
Shift+F8 78
shortcut keys 312, 315
size optimization 66
slanting an object 134
slide master 146
slide show
See: presentation 140
Slide Sorter view (Impress) 157
slide transition effects 34
slide transitions 154
slides
layouts 150
master 146
Slides pane (Impress) 144
snap tools (Draw) 125
Solaris 9
sort order (database fields) 205
special characters 80, 82
spelling checker 82
spelling options 70
splitting the window (Calc) 112
spreadsheet
entering dates and times 114
entering numbers 114
entering numbers as text 114
entering text 114
navigating in 103
new 102
opening 102
printing 115
saving 102
selecting items in 105
using as data source 197
spreadsheets
opening 26
saving 29
Standard toolbar 46
StarBasic 290
starting Writer
preloading OOo under Linux/KDE 21
Status Bar (Draw) 127
styles 84
Apply Style list 250
assigning to shortcut keys 251
AutoUpdate 253
changing using Style dialog 253
creating by dragging and dropping 255
creating from selection 254
creating new 254
creating using Style dialog 254
custom 254
deleting 258
description 248
Fill Format 250
linking 254
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loading from template or document 257
modifying 252
presentation styles 148
types supported 248
updating from a selection 253
Styles and Formatting window 87, 249
SUB 293
subforms (database) 196
subroutines 300
subroutines in macros 293
Sun Microsystems 12
support 11
system font (user interface) 57
system menu 16

T
tab stops 81
tagged PDF 32
Task pane (Impress) 146
tear-off toolbars 46
template
create document from 236
creating from document 237
creating using wizard 238
deleting 244
description 236
editing 239
exporting 245
Extension Manager 241
folders 244
update document styles from 240
Template Management window 243
templates
importing 245
templates (Writer) 75
text (cutting, copying, pasting) 78
text boundaries (show/hide) 62
text documents
opening 26
text in Draw 129
theme
deleting 264
themes 260
themes (Gallery) 263
Tips (Help) 55
title page (slide show) 149
toolbar icons (macros) 305
toolbars
Color Bar 123
creating 49
Draw 120
Drawing 123
Fontwork 266
Line and Filling toolbar 122
Options Bar (Draw) 124
overview 46
tooltips 55
Index

total number of pages 95
tracking changes 89
transitions (slides) 154
two-digit years 56

variables in macros 293
VBA 66
vector graphics 3, 120
versions 89
view options 57

Writer documents 278, 279
wildcards 79
Windows 20
Windows Quickstarter 20
Windows Start Menu 16
windows, dockable/floating 49
wizard
form (database) 177
new document 37
presentation 141
query (database) 203
report (database) 213
table (database) 165
web 279
word completion 83
workspace
Draw 120
Impress 144
Writer 74
workspace views (Impress) 155
Writer 2
Writer workspace 74
writing aids 70

W

X

Web Layout 278
Web Layout view (Writer) 75
web page export
Calc spreadsheets 283
Impress presentations 283
Web wizard (Writer) 279

XHTML, export to 30
XML 66

U
undoing changes 88
unformatted text, pasting 78
unit of measurement 127
URL Recognition 276
user data options 54
user guides 11
user interface options 57
user-specific settings 65

V

Index

Y
year (two digits) 56
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